Bug 136478 - (xorg-segv) xorg-x11-6.8.1-10 dies with SIGSEGV
xorg-x11-6.8.1-10 dies with SIGSEGV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 136552 136560 136605 136631 136632 136692 (view as bug list)
Depends On:
Blocks: FC3Blocker 134551
  Show dependency treegraph
 
Reported: 2004-10-20 08:41 EDT by Nils Philippsen
Modified: 2007-11-30 17:10 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 20:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with kernel 2.6.8-1.610 (33.19 KB, text/plain)
2004-10-20 08:43 EDT, Nils Philippsen
no flags Details
Xorg.0.log with kernel 2.6.9-1.639 (33.19 KB, text/plain)
2004-10-20 08:58 EDT, Nils Philippsen
no flags Details
X.Org-log with Radeon 8500 and kernel 541 (41.12 KB, text/plain)
2004-10-20 10:21 EDT, Henning Norén
no flags Details
Xorg.0.log showing i810 death with signal 11 (129.63 KB, text/plain)
2004-10-20 13:23 EDT, John Ellson
no flags Details

  None (edit)
Description Nils Philippsen 2004-10-20 08:41:32 EDT
Description of problem:
On my laptop, upgrading to the latest xorg-x11 (6.8.1-10) causes X to
crash with SIGSEGV. This is regardless of whether I try it with the
included open source "nv" driver or the proprietary "nvidia" one.
Before anyone asks ;-), this problem occurs on a freshly booted,
untainted system, without the proprietary nvidia libraries in the
library path. The problem is there on both kernel-2.6.8-1.610 and
kernel-2.6.9-1.639.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-10

How reproducible:
Always.

Steps to Reproduce:
- Upgrade to xorg-x11-6.8.1-10
- try to start X (run "X")

Actual results:
X crashes with signal 11

Expected results:
X starts without crashing

Additional info:
from lspci -vvvv:

01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4
Ti 4200 Go AGP 8x] (rev a1) (prog-if 00 [VGA])
        Subsystem: Dell: Unknown device 0179
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop+
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 248 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at f0000000 (32-bit, prefetchable) [size=64M]
        [virtual] Expansion ROM at 80000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 3.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit-
FW- Rate=<none>
Comment 1 Nils Philippsen 2004-10-20 08:42:12 EDT
Forgot: Downgrading to -8 solved the problem for me.
Comment 2 Nils Philippsen 2004-10-20 08:43:30 EDT
Created attachment 105504 [details]
Xorg.0.log with kernel 2.6.8-1.610
Comment 3 Nils Philippsen 2004-10-20 08:58:10 EDT
Created attachment 105505 [details]
Xorg.0.log with kernel 2.6.9-1.639
Comment 4 Sammy 2004-10-20 10:02:06 EDT
Confirm with Redeon 7000 
Comment 5 Henning Norén 2004-10-20 10:19:46 EDT
Confirmed with Radeon 8500 64MB
Comment 6 Henning Norén 2004-10-20 10:21:59 EDT
Created attachment 105510 [details]
X.Org-log with Radeon 8500 and kernel 541
Comment 7 John Ellson 2004-10-20 13:19:23 EDT
Also dies with i810.
Comment 8 John Ellson 2004-10-20 13:23:07 EDT
Created attachment 105533 [details]
Xorg.0.log showing i810 death with signal 11
Comment 9 Kristian Høgsberg 2004-10-20 13:54:53 EDT
Thanks for reporting this.  There should be an xorg-x11-6.8.1-12 out
soon to fix this, in the meantime, avoid the xorg-x11-6.8.1-{9,10,11}
builds and stick to xorg-x11-6.8.1-8.

Kristian
Comment 10 Mike A. Harris 2004-10-20 17:40:19 EDT
Status update:

Since many people are encountering this issue and wanting to know
when the fix will be available, I thought I would provide a simple
update to keep everyone in the loop.

The problem was introduced in a patch which first appeared in the
6.8.1-9 build, which will probably cause most if not all systems
to fail regardless of video hardware or driver being used.  Once
the problem was discovered, Kristian updated his patch to fix the
issue in 6.8.1-12 which we've done some local testing with.

The problem is now fixed in internal CVS, and new packages will
be available once they have passed through our buildsystem.  It
may take several hours, or even a day or more before the -12
build is built on all 7 architectures, depending on the load on
the buildsystem and other factors.  The current time estimate
is that a build should be available before next Monday at the
latest, and a few hours at the earliest.

For those who need a fix in the meantime, please use 6.8.1-8
until we have made -12 available.  As soon as the 6.8.1-12
build is available, I will upload it to people.redhat.com and
provide a URL here for people to download the new rpms for
testing.

In the mean time, please watch this bug report for status updates.

Thanks for your patience.
Comment 11 Bill Nottingham 2004-10-20 17:50:46 EDT
*** Bug 136552 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2004-10-20 18:16:30 EDT
*** Bug 136560 has been marked as a duplicate of this bug. ***
Comment 13 Mike A. Harris 2004-10-20 18:32:25 EDT
xorg-x11-6.8.1-12 is now available for download via ftp,
and http at the following URLs:

    ftp://people.redhat.com/mharris/testing/unstable
    http://people.redhat.com/mharris/testing/unstable

Please test these packages, and update the report to indicate
if the SEGV is no longer reproduceable.  If the problem persists
change the status to "ASSIGNED", otherwise set the status to
"RAWHIDE".

Thanks for testing.
Comment 14 Jeffrey Moyer 2004-10-20 18:36:22 EDT
-12 fixes the problem for me.

Thanks!
Comment 15 Mike A. Harris 2004-10-20 20:23:20 EDT
Thanks for the update.  Setting status to "RAWHIDE".
Comment 16 Alex Roman 2004-10-20 22:47:05 EDT
I confirm it... -12 fixes the problem.
Thank you for the updates Mike Harris! :D
Comment 17 Mike A. Harris 2004-10-20 22:57:39 EDT
Actually, Kristian fixed it.  ;o)  But he also broke it, so he
gets credit for both.  ;o)

*runs*
Comment 18 Thomas Cameron 2004-10-21 00:28:34 EDT
I had the same problem on a dual Xeon 1GHz Dell Precision 620 with an
nVidia GeForce2 GTS card.  The xorg-x11-6.8.1-12 packages fixed it.
Comment 19 Mike A. Harris 2004-10-21 02:01:08 EDT
*** Bug 136605 has been marked as a duplicate of this bug. ***
Comment 20 Mike A. Harris 2004-10-21 09:41:25 EDT
*** Bug 136631 has been marked as a duplicate of this bug. ***
Comment 21 Mike A. Harris 2004-10-21 09:42:40 EDT
*** Bug 136632 has been marked as a duplicate of this bug. ***
Comment 22 Mike A. Harris 2004-10-21 16:53:35 EDT
*** Bug 136692 has been marked as a duplicate of this bug. ***
Comment 23 Bojan Smojver 2004-10-21 23:33:55 EDT
Yep, works for me too (Radeon IGP340M on HP Pavillion ZE-4201) in
6.8.1-12.

Note You need to log in before you can comment on or make changes to this bug.