Bug 175661 - metacity global keybindings can no longer use the "Print" keysym
metacity global keybindings can no longer use the "Print" keysym
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Regression
: 174150 174359 177259 178851 179247 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-13 13:46 EST by Matthew Galgoci
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 11:24:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2005-12-13 13:46:11 EST
Description of problem:

At some point in rawhide, the ability to take a screenshot by pressing the
printscreen button went away. This is incredibly useful for many things,
including debugging remote problems on users desktops and also gettning screen
shots of application states (look ma ... it's broken!).

Version-Release number of selected component (if applicable):

post fc5t1 rawhide

How reproducible:

100%

Steps to Reproduce:
1. press printscreen button

Actual results:

no screenshot is produced

Expected results:

a screenshot should be produced and a dialogue box should pop up asking where
to save the screenshot.
Comment 1 Ray Strode [halfline] 2005-12-13 13:48:49 EST
does running "gnome-screenshot" from the terminal work?
Comment 2 Matthew Galgoci 2005-12-13 13:52:58 EST
running gnome-screenshot from the terminal does take a screenshot, but now we
have the heisenburg uncertainty principle largely affecting what you are taking
a picture of.
Comment 3 Ray Strode [halfline] 2005-12-13 13:55:23 EST
Hi,

Just trying to diagnose the problem (pressing that key calls gnome-screenshot
under the hood).

If you map it to a different key:

gconftool-2 -s /apps/metacity/global_keybindings/run_command_screenshot --type
string "Scroll_Lock"

or something, then does it work (by pressing scroll lock)?
Comment 4 Matthew Galgoci 2005-12-13 14:13:59 EST
If I remap the screenshot tool to another key I am able to take screenshots by
pressing the key I have remapped.
Comment 5 Ray Strode [halfline] 2005-12-13 15:05:23 EST
Thanks.
Comment 6 sangu 2005-12-20 13:28:44 EST
*** Bug 174150 has been marked as a duplicate of this bug. ***
Comment 7 Paul F. Johnson 2006-01-08 15:53:15 EST
*** Bug 177259 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2006-01-11 23:08:35 EST
*** Bug 174359 has been marked as a duplicate of this bug. ***
Comment 9 Ray Strode [halfline] 2006-01-24 18:27:07 EST
Hi,
So this looks like it's an XKB data problem.

If you have a look at /usr/share/X11/xkb/pc/pc

and add // in front of each of these lines:
    key <SYRQ> {
        type= "PC_SYSRQ",
        symbols[Group1]= [ Print, Sys_Req ]
    };
then the problem goes away.

The problem also goes away if we use xkeyboard-config instead of Xorg xkb data.

I think that latter solution may be the better long-term one, but I don't really
know.  Reassinging to xorg.
Comment 10 Mike A. Harris 2006-01-24 20:34:27 EST
Ok, I suspected this problem was a repeat of an older bug reported ages ago,
and Ray tracked it down in bugzilla to the problem I was thinking about:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=69743

We should be able to fix this in the next package build.  I'll update it
once built.

Thanks for the report.
Comment 11 Ray Strode [halfline] 2006-01-25 11:49:22 EST
*** Bug 178851 has been marked as a duplicate of this bug. ***
Comment 12 Pierre Ossman 2006-01-31 07:49:25 EST
*** Bug 179247 has been marked as a duplicate of this bug. ***
Comment 13 Pierre Ossman 2006-02-04 07:50:36 EST
How's that rebuild going?
Comment 14 Mike A. Harris 2006-02-09 11:24:36 EST
I've filed an upstream bug for this, and attached a new patch I created
based off the old XFree86 4.3.0 one we used to ship, so that this gets
fixed upstream for good hopefully this time:

https://bugs.freedesktop.org/show_bug.cgi?id=5848

The patch is in xorg-x11-xkbdata-1.0.1-2, which should show up in rawhide
tomorrow.

Note You need to log in before you can comment on or make changes to this bug.