Bug 189338 - Update TurboGears
Update TurboGears
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: TurboGears (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On: 189340 189363 189384 189416 198284 198285 198287 198288 198289 198905 206836 206837 206838 206839
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 06:29 EDT by Ignacio Vazquez-Abrams
Modified: 2016-09-19 22:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 17:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dennis: fedora‑cvs+


Attachments (Terms of Use)
Rough sample spec file (932 bytes, text/plain)
2006-09-16 12:12 EDT, Toshio Kuratomi
no flags Details

  None (edit)
Description Ignacio Vazquez-Abrams 2006-04-19 06:29:09 EDT
The latest version of TurboGears as of writing this is 0.9a4.
Comment 1 Toshio Kuratomi 2006-07-05 23:47:19 EDT
0.9a6 is out now.
Comment 2 Luke Macken 2006-07-11 00:36:46 EDT
I packaged up the rest of the dependencies for TurboGears 0.9a6 and started
pushing them through the extras review process.

     Bug #198285 - python-simplejson
     Bug #198289 - python-pastescript
     Bug #198287 - python-paste
     Bug #198288 - python-pastedeploy
     Bug #198284 - python-configobj 

It looks like we're going to need to bump a few existing packages too:

    python-cherrypy >= 2.2.1
    python-sqlobject >= 0.7.1dev_r1457
    python-formencode >= 0.5.1

0.9a6 also requires TurboJson, TurboCheetah, and TurboKid.  These are actually
shipped in egg format and are also inside the TurboGears-0.9a6 tarball, so we
will need to pull those out into subpackages too.
Comment 3 Luke Macken 2006-08-04 12:09:25 EDT
I took care of bumping python-cherrypy (Bug #198324) and python-formencode (Bug
#198905).

So we're still waiting on simplejson, pastescript, and pastedeploy to make their
way through the extras review process.  python-sqlobject will also need to get
bumped as well at some point.

In the mean time, I've taken care of updating the TurboGears spec to 0.9a8, and
pulled out subpackages for TurboJson, TurboCheetah, TurboKid, and TGFastData. 
I'm not really sure if the subpackage names are valid in the eyes of the naming
guidelines, but I just went by what the modules were called.

    http://people.redhat.com/lmacken/TurboGears-0.9a8-1.src.rpm

I did a little bit of testing locally, and everything seems to be happy.  Please
feel free to bash around with the packages, or help push them through the review
process.
Comment 4 Luke Macken 2006-09-16 02:33:54 EDT
With the latest release of TurboGears (1.0b1), the plugins have been pulled from
the tarball and are released as separate eggs.  I've been nagging the upstream
for the past couple of weeks to release the tarballs for those packages so we
can get them into extras, but nothing as of yet.  For reference, here are the
plugin dependencies that we are going to need to either get tarballs for, or
figure out how to package the eggs themselves.

    http://files.turbogears.org/eggs/TurboCheetah-0.9.5-py2.4.egg
    http://files.turbogears.org/eggs/TurboJson-0.9.9-py2.4.egg
    http://files.turbogears.org/eggs/TurboKid-0.9.8-py2.4.egg
    http://files.turbogears.org/eggs/TGFastData-0.9a6-py2.4.egg
Comment 5 Toshio Kuratomi 2006-09-16 12:12:14 EDT
Created attachment 136437 [details]
Rough sample spec file

Here's a rough cut at packaging directly from an egg.  It's got quite a few
rough edges but the basics are here.  An egg is a zip file just like a jar is a
zip file so %setup can handle it.  Only installing the .py files allows rpm to
rebuild the .pyc and .pyo's.  The package has a dearth of documentation this
way... not sure if that would be the case with upstream tarballs as well.  It
would be good to include at least some things from the EGG-INFO directory as
documentation (of the license at least) but I haven't checked it out
completely.
Comment 6 Luke Macken 2006-09-17 01:35:01 EDT
The spec looks good; I guess we can stick with the egg until upstream starts
releasing the tarballs for the plugins.  I made RPMS for the rest of the plugins
and started pushing them all through the extras review process.

     Bug #206836 - TurboJson
     Bug #206837 - TurboCheetah
     Bug #206838 - TGFastData
     Bug #206839 - TurboKid
Comment 7 Luke Macken 2006-10-17 17:14:45 EDT
TurboGears 1.0b1 is now in devel.
Comment 8 Luke Macken 2007-03-09 01:20:39 EST
TurboGears is needed for some crucial Fedora Infrastructure and needs to be
packaged for EPEL.

Branch Request: EL-5
Packages:
python-elementtree
python-kid
python-cherrypy 
python-sqlobject 
python-formencode 
python-json 
python-setuptools 
python-turbocheetah 
python-turbojson 
python-turbokid
python-tgfastdata
python-simplejson
python-paste-script 
python-configobj
python-ruledispatch
python-nose
python-psycopg2
python-TestGears
Comment 9 Luke Macken 2007-03-09 01:23:06 EST
Also, Toshio Kuratomi <toshio@tiki-lounge.com> volunteered to help co-maintain
this stack as well.
Comment 10 Jens Petersen 2007-03-11 19:56:47 EDT
Toshio will comaintain both the fc and el packages?
Comment 11 Luke Macken 2007-03-11 20:03:38 EDT
Yes (correct me if I'm wrong, Toshio)
Comment 12 Jens Petersen 2007-03-11 21:21:27 EDT
Okay, added Toshio as comaintainer of Fedora packages for now.
Comment 13 Dennis Gilmore 2007-03-11 23:21:39 EDT
all branched for EL-5 now
Comment 14 Toshio Kuratomi 2007-03-11 23:31:13 EDT
Thanks guys

Note You need to log in before you can comment on or make changes to this bug.