Bug 189577 - ooimpress sometimes crashes on startup in gnome_cups_printer_new_printer_notify_add
Summary: ooimpress sometimes crashes on startup in gnome_cups_printer_new_printer_noti...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomecups (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard: bzcl34nup
Keywords:
: 190121 190792 191051 191551 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-21 10:29 UTC by Radek Vokal
Modified: 2013-03-06 03:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 18:06:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 326572 None None None Never

Description Radek Vokal 2006-04-21 10:29:45 UTC
Description of problem:
OO Presentation crashes on startup. This is rawhide updated system.

How reproducible:
always

Steps to Reproduce:
1. start OO presentation
  
Actual results:
crash

Expected results:
works

Additional info:

Video Driver is probably: nvidia nv
Desktop is: GNOME
libgcj version is: libgcj-4.1.0-8
kernel is: Linux 2.6.16-1.2136_FC6PAE #1 SMP Tue Apr 18 15:15:32 EDT 2006 i686
i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.9.3
accessibility is: false
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 20
Policy from config file:        targeted
...end sestatus details ...
0x46ed660: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e660
0x46edea0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eea0
0x715420:  + 0x420 (__kernel_sigreturn + 0x0)
0x75c6e3: /lib/libc.so.6 + 0x296e3 (abort + 0x103)
0x33f7165: /lib/libdbus-1.so.2 + 0x55165
0x33e0fe7: /lib/libdbus-1.so.2 + 0x3efe7
0x33b2fdd: /lib/libdbus-1.so.2 + 0x10fdd (dbus_connection_set_watch_functions +
0x19d)
0x164f315: /usr/lib/libdbus-glib-1.so.2 + 0x8315
(dbus_connection_setup_with_g_main + 0x125)
0x163e5b0: /usr/lib/libgnomecups-1.0.so.1 + 0x75b0
0x163e87b: /usr/lib/libgnomecups-1.0.so.1 + 0x787b
(gnome_cups_printer_new_printer_notify_add + 0x5b)
0x1632e48: /usr/lib/libgnomeprint/2.12.1/modules/libgnomeprintcups.so + 0x1e48
0x4947e93: /usr/lib/libgnomeprint-2-2.so.0 + 0x46e93 (gpa_printer_list_load + 0x953)
0x4948294: /usr/lib/libgnomeprint-2-2.so.0 + 0x47294 (gpa_init + 0xe4)
0x52a03da: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x4a3da
(psp::CUPSManager::runDests() + 0x22)
0x52a044b: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x4a44b
(psp::CUPSManager::runDestThread(void*) + 0x17)
0x46e653f: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1753f
0x9bb41b: /lib/libpthread.so.0 + 0x541b
0x7fb27e: /lib/libc.so.6 + 0xc827e (__clone + 0x5e)

Comment 1 Caolan McNamara 2006-04-21 10:41:51 UTC
Looks dodgy to me, all sorts of dbus and gnomecups stuff in the stack. What
happens in gedit when you use file->print ?

Comment 2 Radek Vokal 2006-04-21 10:52:50 UTC
It prints. I don't see any crash there. Also OO writer and friends start fine.
Dooh, and now OO Presentation starts without any complain too .. 

Ok, just forget about this bug till I find some steps to reproduce the crash
repeatedly.

Comment 3 Caolan McNamara 2006-04-21 11:05:25 UTC
This looks really like issue 177546 and gnome 326572

Comment 4 Caolan McNamara 2006-04-21 11:06:31 UTC
bug 177546, not issue 177546

Comment 5 Caolan McNamara 2006-04-28 07:44:03 UTC
*** Bug 190121 has been marked as a duplicate of this bug. ***

Comment 6 Caolan McNamara 2006-05-05 08:09:28 UTC
*** Bug 190792 has been marked as a duplicate of this bug. ***

Comment 7 Caolan McNamara 2006-05-09 14:41:38 UTC
*** Bug 191051 has been marked as a duplicate of this bug. ***

Comment 8 Caolan McNamara 2006-05-15 08:49:34 UTC
*** Bug 191551 has been marked as a duplicate of this bug. ***

Comment 9 Radek Vokal 2006-05-31 05:26:04 UTC
Printing is now broken on my rawhide box. Anyway it seems that this particular
crash is gone with the latest update. I think you can close this issue if you
want to.

Comment 10 Bug Zapper 2008-04-03 17:12:29 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 11 Caolan McNamara 2008-04-03 18:06:53 UTC
well we can close this simply because OOo is not using the older gnome printer
dialog but the newer gtk one instead.


Note You need to log in before you can comment on or make changes to this bug.