Bug 201457 - lots of Cyrillic characters uglify the screen before rescue shell is started
lots of Cyrillic characters uglify the screen before rescue shell is started
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 201771 201776 201819 201896 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-05 12:56 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 11:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-08-05 12:56:57 EDT
Description of problem:
While testing rescue mode on an Athlon64 notebook, at some point I started
getting Cyrillic characters on the screen.  I think it was during disk detection
or some other late stage before the shell starts, but I didn't take detailed
notes and no longer remember exactly :-(

Version-Release number of selected component (if applicable):
FC6T2-20060803.1

How reproducible:
Every time

Steps to Reproduce:
1.Boot up the install media in rescue mode
2.Proceed all the way to the shell

Actual results:
At some point you'll get lots of Cyrillic characters, even though the selected
install language was English

Expected results:
No such incomprehensible (for me) stuff :-)

Additional info:
Comment 1 Jeremy Katz 2006-08-07 11:31:36 EDT
We're getting a lockdep warning and kernel errors are leaking through to other
ttys (and since the kernel doesn't have the same idea about character sets, you
get the garbage)
Comment 2 Chris Lumens 2006-08-08 16:08:28 EDT
*** Bug 201771 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2006-08-08 17:02:44 EDT
*** Bug 201776 has been marked as a duplicate of this bug. ***
Comment 4 Julien Demare 2006-08-09 05:30:56 EDT
It east can be due to Suse 10(.1) allready installed. It is my case and his also
:   http://fcp.homelinux.org/modules/newbb/viewtopic.php?topic_id=24774&forum=12
Comment 5 David Cantrell 2006-08-09 09:12:29 EDT
*** Bug 201819 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2006-08-09 13:50:53 EDT
*** Bug 201896 has been marked as a duplicate of this bug. ***
Comment 7 Phil Schaffner 2006-08-12 17:25:57 EDT
Seeing what is apparently the same problem on a FC6 Test2 install on a Lenovo
3000 N100 noteboot with nVidia GeForce Go 7300.
Comment 8 Matthias Saou 2006-09-08 11:11:53 EDT
Seeing this too with 20060908 boot.iso... hmmm, since it doesn't seem to have
been fixed in time for test3, I fear the number of duplicates that might arrive
soon...
Comment 9 David Timms 2006-09-20 09:44:10 EDT
Confirmed present in FC6T3 and in rescue iso from 2006-09-19 on a hp nx6120
notebook.
Comment 10 Jeremy Katz 2006-09-20 11:43:45 EDT
Can people please file the actual kernel oopsen they're getting (or check if
they're bug 200025)

Note that we're going to disable lockdep for the final release, so people won't
hit this except in the case of oopsen.  And there's not anything that can be
done in anaconda to fix it as the kernel is doing direct printks when we have
the terminal in a different mode
Comment 11 David Timms 2006-09-20 16:47:55 EDT
OK. Captured serial debug in minicom {hope the following is correct boot command}:
  linux rescue console=tty0 console=ttyS0,9600n8
=== 
Stack Trace is identical to bug 200025 (sorry 'bout that), except that it
repeats after a message:
 [<c0426d8f>] kthread+0xb0/0xdd
 [<c0401005>] kernel_thread_helper+0x5/0xb
DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
Leftover inexact backtrace:
 [<c0403db6>] show_trace+0xd/0x10
 [<c0403e53>] dump_stack+0x19/0x1b

Note You need to log in before you can comment on or make changes to this bug.