Bug 238263 - gnucash should require g-wrap-devel?
gnucash should require g-wrap-devel?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: g-wrap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 238415 238700 239533 239627 239639 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-28 10:09 EDT by Mads Villadsen
Modified: 2014-03-16 23:06 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.9.6-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 22:04:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Villadsen 2007-04-28 10:09:09 EDT
Description of problem:
gnucash apparently requires g-wrap .so files to run and g-wrap does not contain
.so files and thus causes gnucash to stop working.

The .so files are contained in g-wrap-devel so should gnucash require g-wrap-devel?

Version-Release number of selected component (if applicable):
g-wrap-1.9.6-10
gnucash-2.0.5-3.fc7


How reproducible:
Always

Steps to Reproduce:
1. run gnucash 
2. get error 

ERROR: In procedure dynamic-link:
ERROR: file: "libgw-guile-standard", message: "libgw-guile-standard.so: cannot
open shared object file: No such file or directory"
m


Additional info:
If I install g-wrap-devel gnucash works again.

maxx@ice:~$ rpm -ql g-wrap | grep /usr/lib
/usr/lib/libgw-guile-gw-glib.so.0
/usr/lib/libgw-guile-gw-glib.so.0.0.0
/usr/lib/libgw-guile-standard.so.0
/usr/lib/libgw-guile-standard.so.0.0.0
/usr/lib/libgwrap-core-runtime.so.0
/usr/lib/libgwrap-core-runtime.so.0.0.1
/usr/lib/libgwrap-guile-runtime.so.0
/usr/lib/libgwrap-guile-runtime.so.0.0.2

maxx@ice:~$ rpm -ql g-wrap-devel | grep /usr/lib
/usr/lib/g-wrap
/usr/lib/g-wrap/include
/usr/lib/g-wrap/include/ffi.h
/usr/lib/g-wrap/include/ffitarget.h
/usr/lib/g-wrap/include/g-wrap-2.0-ffi-target.h
/usr/lib/libgw-guile-gw-glib.so
/usr/lib/libgw-guile-standard.so
/usr/lib/libgwrap-core-runtime.so
/usr/lib/libgwrap-guile-runtime.so
/usr/lib/pkgconfig/g-wrap-2.0-guile.pc
Comment 1 eric 2007-04-28 17:48:22 EDT
my gnucash is having the same problem after g-wrap update on apr 27.
(Apr 27 17:19:09 Updated: g-wrap.i386 1.9.6-10)

i thought this was relevant:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=222347
Comment 2 Bill Nottingham 2007-05-01 00:50:20 EDT
gnucash should not require g-wrap-devel; it should be fixed so that whatever is
needed is in the right package.

That being said, I despise the gnucash module system. :)

Comment 3 Bill Nottingham 2007-05-01 00:56:47 EDT
*** Bug 238415 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2007-05-02 23:29:29 EDT
*** Bug 238700 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2007-05-07 22:04:36 EDT
Fixed in g-wrap-1.9.6-11.
Comment 6 Bill Nottingham 2007-05-09 13:51:14 EDT
*** Bug 239533 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2007-05-09 22:40:15 EDT
*** Bug 239627 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2007-05-09 23:57:35 EDT
*** Bug 239639 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.