Bug 355331 - Package wpa_supplicant-0.5.7-12.fc8.i386.rpm is not signed
Package wpa_supplicant-0.5.7-12.fc8.i386.rpm is not signed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 355181 355301 355311 355341 355361 358521 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-27 11:24 EDT by Dick Franks
Modified: 2013-01-09 20:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 12:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rubygems fails with --nogpgcheck (6.53 KB, text/plain)
2007-10-27 13:05 EDT, John Fletcher
no flags Details

  None (edit)
Description Dick Franks 2007-10-27 11:24:33 EDT
Description of problem:

wpa_supplicant RPM not signed.
Although of little interest in itself, problem causes yum update to abort
without doing anything.

Version-Release number of selected component (if applicable):
0.5.7-12

How reproducible:
100%

Steps to Reproduce:
1. yum update wpa_supplicant
2.
3.
  
Actual results:

# yum update wpa_supplicant
Loading "refresh-updatesd" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wpa_supplicant.i386 1:0.5.7-12.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 wpa_supplicant          i386       1:0.5.7-12.fc8   fedora            253 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 253 k
Is this ok [y/N]: y
Downloading Packages:

Package wpa_supplicant-0.5.7-12.fc8.i386.rpm is not signed

Expected results:
Download and update of RPM

Additional info:

yum makes no attempt to update packages which do not depend on failed RPM.
This is something for yum developers to consider.
Comment 1 Will Woods 2007-10-27 12:10:35 EDT
Pre-release packages are not signed. We made a mistake in changing the default
repositories from 'development' to 'fedora' and 'updates' (which require signed
packages) before the final F8 package set was ready.

Once F8 is completed we will sign the packages for the final release and this
problem will go away.

Until that happens, either:
1) Switch back to using the 'development' repo and disable 'fedora' and 'updates'
or
2) Disable gpg checking on the 'fedora' repo.
Comment 2 Will Woods 2007-10-27 12:26:42 EDT
*** Bug 355361 has been marked as a duplicate of this bug. ***
Comment 3 Will Woods 2007-10-27 12:31:10 EDT
*** Bug 355341 has been marked as a duplicate of this bug. ***
Comment 4 Will Woods 2007-10-27 12:31:19 EDT
*** Bug 355311 has been marked as a duplicate of this bug. ***
Comment 5 Will Woods 2007-10-27 12:31:46 EDT
*** Bug 355301 has been marked as a duplicate of this bug. ***
Comment 6 Will Woods 2007-10-27 12:36:52 EDT
*** Bug 355181 has been marked as a duplicate of this bug. ***
Comment 7 John Fletcher 2007-10-27 13:00:25 EDT
You have marked various other bugs which I have submitted as duplicates of this.

I am not convinced of this because some of them were run with --nogpgcheck 
or else the presence of --nogpgcheck made no difference.

I have been able to overcome the no signature problem with --nogpgcheck and I
believe there is a different problem with the installation of e.g. ginac and
gnuplot. 

There is evidence of this in the log files attached to the other (discarded)
reports.

I will not submit any further such reports - I will monitor what comes of it.

John Fletcher

Comment 8 John Fletcher 2007-10-27 13:05:21 EDT
Created attachment 240581 [details]
rubygems fails with --nogpgcheck
Comment 9 Will Woods 2007-10-27 13:12:04 EDT
I'd suggest changing the repository files (as discussed in comment #1) and then
running:

yum clean all

it looks like you might have gotten some bad/mixed up metadata or
half-downloaded files.

hope that helps.
Comment 10 Dick Franks 2007-10-29 12:15:55 EDT
It did.

Selected develpment repo and cleaned out metadata, now ok.

Thanks
Comment 11 Will Woods 2007-10-30 12:30:40 EDT
*** Bug 358521 has been marked as a duplicate of this bug. ***
Comment 12 Jesse Keating 2007-10-30 12:45:08 EDT
All packages in rawhide should be signed now leading up to the F8 release.

Note You need to log in before you can comment on or make changes to this bug.