Bug 355411 - xmlrpc-c-1.06.21 is available
xmlrpc-c-1.06.21 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xmlrpc-c (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Package...
:
: 231897 237820 239220 239871 248134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-27 14:04 EDT by FEver
Modified: 2008-01-02 20:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-01 19:46:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FEver 2007-10-27 14:04:08 EDT
xmlrpc-c-1.06.21 is already available. Repo version is 1.06.18.
Please update the package.

If you have any questions or suggestions related to Fever,
feel free to write them in this bug or have a look at
http://fedoraproject.org/wiki/PackageMaintainers/FEver

Don't send any messages to fevapp at o2.pl please.
Comment 1 Peter van Egdom 2007-11-14 15:05:08 EST
*** Bug 231897 has been marked as a duplicate of this bug. ***
Comment 2 Peter van Egdom 2007-11-14 15:06:23 EST
*** Bug 237820 has been marked as a duplicate of this bug. ***
Comment 3 Peter van Egdom 2007-11-14 15:07:27 EST
*** Bug 239220 has been marked as a duplicate of this bug. ***
Comment 4 Peter van Egdom 2007-11-14 15:08:13 EST
*** Bug 239871 has been marked as a duplicate of this bug. ***
Comment 5 Peter van Egdom 2007-11-14 15:09:18 EST
*** Bug 248134 has been marked as a duplicate of this bug. ***
Comment 6 Steve Underwood 2008-01-01 06:49:12 EST
As well as updating, it would be great of the pkgconfig stuff actually worked.
What is in the RPMs is different from what is in the upstream package, and seems
completely broken - e.g. "xmlrpc-c-config abyss-server --libs" responds with
"-lxmlrpc_abyss" rather than the list of several libraries which the upstream
xmlrpc-c-config gives.
Comment 7 Enrico Scholz 2008-01-01 07:53:58 EST
the upstream output is broken... or do you see problems when using the pkgconfig
stuff?
Comment 8 Steve Underwood 2008-01-01 18:40:08 EST
The upstream xmlrpc-c-config works correctly in all cases I have tried. For
example, several libraries really are required to use abyss-server, and the
upstream stuff produces the correct list. The xmlrpc-c-config in the RPM is
completely different, and produces bogus lists of libraries. This means packages
using xmlrpc-c do not generally build on a Fedora machine without some tweaking.
Comment 9 Enrico Scholz 2008-01-01 19:46:24 EST
thx; should be fixed in 1.06.23. There the xmlrpc_server_abyss pkgconfig module
is used instead of the plain xmlrpc_abyss one.
Comment 10 Fedora Update System 2008-01-02 20:39:13 EST
xmlrpc-c-1.06.23-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xmlrpc-c'
Comment 11 Fedora Update System 2008-01-02 20:45:13 EST
xmlrpc-c-1.06.23-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xmlrpc-c'

Note You need to log in before you can comment on or make changes to this bug.