Bug 452538 - Metadata checksum errors on updateinfo from rhel-i386-client-5
Metadata checksum errors on updateinfo from rhel-i386-client-5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
i386 Linux
low Severity high
: ---
: ---
Assigned To: Sebastian Skracic
:
: 454444 464058 466467 509025 509114 509175 509247 553294 582431 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-23 12:58 EDT by Andrew Barnes
Modified: 2013-01-10 05:24 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 13:45:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The full crash report (1.40 KB, text/plain)
2008-06-23 12:58 EDT, Andrew Barnes
no flags Details

  None (edit)
Description Andrew Barnes 2008-06-23 12:58:31 EDT
Description of problem:

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 265, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 867, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 299, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-client-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: None
self: rhel-i386-client-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at
0xa0335ec>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-i386-client-5/updateinfo.xml.gz


Version-Release number of selected component (if applicable):
1.3.28-13.el5

How reproducible:
Easily

Steps to Reproduce:
1. By starting the Software Update application
2.
3.
  
Actual results:
Application crashes with "Exception Occurred" Error.

Expected results:
Install software updates using Software Updater

Additional info:
Comment 1 Andrew Barnes 2008-06-23 12:58:31 EDT
Created attachment 310043 [details]
The full crash report
Comment 2 James Antill 2008-09-26 00:43:24 EDT
This shouldn't be happening, and although it'd be nice if we could put a nice message up ... I'm not sure how easy that'd be.
Comment 3 James Antill 2008-09-26 00:43:41 EDT
*** Bug 464058 has been marked as a duplicate of this bug. ***
Comment 5 James Antill 2009-07-07 11:15:15 EDT
*** Bug 509025 has been marked as a duplicate of this bug. ***
Comment 6 James Antill 2009-07-07 11:18:34 EDT
*** Bug 509175 has been marked as a duplicate of this bug. ***
Comment 7 James Antill 2009-07-07 11:19:19 EDT
*** Bug 509247 has been marked as a duplicate of this bug. ***
Comment 8 James Antill 2009-07-07 11:24:18 EDT
*** Bug 509114 has been marked as a duplicate of this bug. ***
Comment 9 Ran 2009-07-07 11:30:45 EDT
I could add that I believe this occurred after I ran yum update from the command line, then tried to open the GUI application. After a restart, the GUI application ran fine. It works now, anyways.
Comment 10 Sebastian Skracic 2010-08-26 13:45:04 EDT
The metadata generation code has been changed significantly recently, and now the checksums are embedded in repodata filenames.  Theoretically, you should not ever encounter the dreaded 'Metadata file does not match checksum', unless, of course, the file got corrupted in transfer due to network or local storage issues.
Comment 11 Sebastian Skracic 2010-08-26 13:47:06 EDT
*** Bug 454444 has been marked as a duplicate of this bug. ***
Comment 12 Sebastian Skracic 2010-10-07 04:15:25 EDT
*** Bug 582431 has been marked as a duplicate of this bug. ***
Comment 13 Sebastian Skracic 2010-10-07 04:29:57 EDT
*** Bug 466467 has been marked as a duplicate of this bug. ***
Comment 14 Sebastian Skracic 2010-10-07 05:17:50 EDT
*** Bug 553294 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.