Bug 550675 - [abrt] crash in SolarModel-2.1-5.fc12
Summary: [abrt] crash in SolarModel-2.1-5.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: SolarModel
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3e439972ddee010151a192b0358...
: 541499 585609 585670 592968 593222 594603 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-26 19:05 UTC by M8R-qx9aop
Modified: 2010-06-07 22:25 UTC (History)
18 users (show)

Fixed In Version: SolarModel-2.1-6.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-07 22:11:09 UTC


Attachments (Terms of Use)
File: backtrace (3.69 KB, text/plain)
2009-12-26 19:05 UTC, M8R-qx9aop
no flags Details

Description M8R-qx9aop 2009-12-26 19:05:38 UTC
abrt 1.0.2 detected a crash.

Attached file: backtrace
cmdline: SolarModel
component: SolarModel
executable: /usr/bin/SolarModel
kernel: 2.6.31.9-174.fc12.x86_64
package: SolarModel-2.1-5.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)

Comment 1 M8R-qx9aop 2009-12-26 19:05:41 UTC
Created attachment 380454 [details]
File: backtrace

Comment 2 Tom "spot" Callaway 2010-01-21 02:03:32 UTC
*** Bug 541499 has been marked as a duplicate of this bug. ***

Comment 3 Dag 2010-03-14 22:51:24 UTC

How to reproduce
-----
1. start the programm
2.it displays in the console:
ERROR: "config.dat" not found.
Irrlicht Engine version 1.5.1
Linux 2.6.32.9-70.fc12.x86_64 #1 SMP Wed Mar 3 04:40:41 UTC 2010 x86_64
Creating X window...
Visual chosen: : 39
Using renderer: OpenGL 3.2.0
GeForce GT 240M/PCI/SSE2: NVIDIA Corporation
OpenGL driver version is 1.2 or better.
GLSL version: 1.5
Erreur de segmentation (core dumped)

3. that's all


Comment
-----
NVidia driver:
nvidia-xconfig-1.0-2.fc12.x86_64
xorg-x11-drv-nvidia-190.53-2.fc12.x86_64
nvidia-settings-1.0-3.4.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.53-2.fc12.x86_64
kmod-nvidia-2.6.32.9-70.fc12.x86_64-190.53-3.fc12.x86_64
kmod-nvidia-190.53-3.fc12.x86_64

Comment 4 Tom "spot" Callaway 2010-03-15 13:16:13 UTC
Yeah. I'm not even going to try to troubleshoot any crashes related to GL with the NVIDIA binary only junk installed.

Please uninstall all of that mess and try with the nouveau driver.

Comment 5 Adam Deacon 2010-04-13 10:13:44 UTC

How to reproduce
-----
1. Start SolarModel
2.
3.


Comment
-----
When starting I always get the following seg fault: 

[adam@ajd-laptop ~]$ SolarModel 
ERROR: "config.dat" not found.
Irrlicht Engine version 1.5.1
Linux 2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64
Creating X window...
Visual chosen: : 39
Using renderer: OpenGL 3.2.0
GeForce 8600M GT/PCI/SSE2: NVIDIA Corporation
OpenGL driver version is 1.2 or better.
GLSL version: 1.5
Segmentation fault (core dumped)

Comment 6 Adam Deacon 2010-04-13 10:33:09 UTC

How to reproduce
-----
1. Type SolarModel
2. 
ERROR: "config.dat" not found.
Irrlicht Engine version 1.5.1
Linux 2.6.32.11-99.fc12.i686 #1 SMP Mon Apr 5 16:32:08 EDT 2010 i686
Creating X window...
Visual chosen: : 195
Using renderer: OpenGL 1.4
Mesa DRI Intel(R) 945GME GEM 20091221 2009Q4 : Tungsten Graphics, Inc
OpenGL driver version is 1.2 or better.
GLSL version: 1.2
Segmentation fault (core dumped)

3.


Comment
-----
Running on an intel 945GME - without the Nvida junk installed ;-)

Comment 7 Stephen F. Hess 2010-04-27 07:28:33 UTC

How to reproduce
-----
1. open application...
2. crash.
3.

Comment 8 Tom "spot" Callaway 2010-05-18 18:45:15 UTC
*** Bug 592968 has been marked as a duplicate of this bug. ***

Comment 9 Tom "spot" Callaway 2010-05-18 18:45:25 UTC
*** Bug 585670 has been marked as a duplicate of this bug. ***

Comment 10 Tom "spot" Callaway 2010-05-18 18:45:33 UTC
*** Bug 585609 has been marked as a duplicate of this bug. ***

Comment 11 Tom "spot" Callaway 2010-05-18 18:46:52 UTC
*** Bug 593222 has been marked as a duplicate of this bug. ***

Comment 12 Tom "spot" Callaway 2010-05-18 19:00:30 UTC
Well, this was embarrassingly easy to fix. The ERROR: "config.dat" not found tipped me off, and sure enough, the code was doing this:

    GameConfig::Load("config.dat", &Game);

I forgot to patch that line to point to /usr/share/SolarModel/config.dat, so it wasn't loading its config and spiraling downward to a segfault from there.

I also figured out why I had trouble reproducing this: I was doing most of my testing from my CVS checkout, which has... config.dat in the top level directory, so that line was always succeeding for me. :P

However, even with that, it doesn't seem to segfault for me on F-13. The only key difference there is a newer version of irrlicht, which might be handling this condition better... or it could be something entirely unrelated to the error message.

I'm building an update with the config.dat fix right now, I would appreciate it if people on this bug report could test it and let me know if it resolves the crashes or not.

Comment 13 Fedora Update System 2010-05-18 19:26:21 UTC
SolarModel-2.1-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/SolarModel-2.1-6.fc12

Comment 14 Fedora Update System 2010-05-18 19:26:27 UTC
SolarModel-2.1-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/SolarModel-2.1-7.fc13

Comment 15 Fedora Update System 2010-05-18 19:26:32 UTC
SolarModel-2.1-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/SolarModel-2.1-6.fc11

Comment 16 Adam Deacon 2010-05-19 07:55:02 UTC
Working fine using fc12 x86_64 and GeForce 8600M

Thanks for the fix

Comment 17 Felipe Hommen 2010-05-19 10:15:00 UTC
All right in fc13 after the fix. Thanks.

Comment 18 Fedora Update System 2010-05-19 19:14:06 UTC
SolarModel-2.1-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SolarModel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/SolarModel-2.1-6.fc11

Comment 19 Fedora Update System 2010-05-19 19:15:19 UTC
SolarModel-2.1-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SolarModel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/SolarModel-2.1-6.fc12

Comment 20 Fedora Update System 2010-05-19 19:16:22 UTC
SolarModel-2.1-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SolarModel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/SolarModel-2.1-7.fc13

Comment 21 Tom "spot" Callaway 2010-05-21 11:42:07 UTC
*** Bug 594603 has been marked as a duplicate of this bug. ***

Comment 22 Fedora Update System 2010-06-07 22:11:02 UTC
SolarModel-2.1-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2010-06-07 22:21:20 UTC
SolarModel-2.1-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2010-06-07 22:25:44 UTC
SolarModel-2.1-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.