Bug 552024 - [abrt] crash in tigervnc-1.0.0-3.fc12
[abrt] crash in tigervnc-1.0.0-3.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:b84a827300436b69322f266ac41...
:
: 541755 554503 571521 586169 588020 588363 589687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-03 12:32 EST by Dario Castellarin
Modified: 2013-04-30 19:44 EDT (History)
84 users (show)

See Also:
Fixed In Version: tigervnc-1.0.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 23:59:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (86.74 KB, text/plain)
2010-01-03 12:32 EST, Dario Castellarin
no flags Details

  None (edit)
Description Dario Castellarin 2010-01-03 12:32:16 EST
abrt 1.0.2 detected a crash.

How to reproduce
-----
1. open the viewer
2. change some options (I don't recall which, sorry)
3. confirm by clicking OK

Comment: I was just changing vnc options (I think I activated view only mode) and when I confirmed it, it crashed
Attached file: backtrace
cmdline: /usr/bin/vncviewer
component: tigervnc
executable: /usr/bin/vncviewer
kernel: 2.6.31.9-174.fc12.x86_64
package: tigervnc-1.0.0-3.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
Comment 1 Dario Castellarin 2010-01-03 12:32:49 EST
Created attachment 381406 [details]
File: backtrace
Comment 2 Ian Springer 2010-01-20 11:29:44 EST
I saw this under the same circumstances. I went to Options and enabled the view-only option. I then tried to connect and got the same crash.
Comment 3 Vladimir 2010-02-01 08:17:45 EST
The same problem. I clicked "Options" and then "Ok" even without any changes in options. The viewer crashes.
Comment 4 jey 2010-02-01 10:50:35 EST
Same problem. Options-> color settings-> OK then crash
Comment 5 Stefan Riemens 2010-02-16 15:24:06 EST
Let me confirm this, just clicking options->OK triggers the crash. No need to modify options.

GDB backtrace:
 
GNU gdb (GDB) Fedora (7.0.1-31.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/vncviewer...Reading symbols from /usr/lib/debug/usr/bin/vncviewer.debug...done.
done.
(gdb) run
Starting program: /usr/bin/vncviewer 
warning: .dynamic section for "/usr/lib/libSM.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libc.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations

TigerVNC Viewer for X version 1.0.0 - built Oct 26 2009 10:57:15
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 TightVNC Group
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.

Program received signal SIGSEGV, Segmentation fault.
CConn::getOptions (this=<value optimized out>) at CConn.cxx:698
698	  desktop->setNoCursor();
(gdb) bt
#0  0x08052fe8 in CConn::getOptions (this=<value optimized out>)
#1  0x08058b42 in OptionsDialog::buttonActivate (this=<value optimized out>, 
    b=<value optimized out>) at OptionsDialog.h:157
#2  0x08060e46 in TXWindow::handleXEvent (this=<value optimized out>, 
    ev=<value optimized out>) at TXWindow.cxx:468
#3  0x0806131b in TXWindow::handleXEvents (dpy=<value optimized out>)
    at TXWindow.cxx:114
#4  0x08058dab in TXDialog::show (this=<value optimized out>)
    at ../tx/TXDialog.h:63
#5  0x08056baa in CConn::CConn (this=<value optimized out>, 
    dpy_=<value optimized out>, argc_=<value optimized out>, 
    argv_=<value optimized out>, sock_=<value optimized out>, 
    vncServerName=<value optimized out>, reverse=<value optimized out>)
    at CConn.cxx:99
#6  0x0805e562 in main (argc=<value optimized out>, argv=<value optimized out>)
    at vncviewer.cxx:401

I'm pretty sure I have all debuginfo packages installed, even the ones pointed out by gdb (is this a seperate bug, it told me to "debuginfo-install libXau-1.0.5-1.fc12.i686 libXcursor-1.1.10-1.fc12.i686 libXfixes-4.0.4-1.fc12.i686 libXrender-0.9.5-1.fc12.i686 libuuid-2.16.2-5.fc12.i686 libxcb-1.5-1.fc12.i686"...)

Thanks,
Stefan
Comment 6 jey 2010-02-17 04:22:58 EST
That's correct, crash after I click OK
Comment 7 Jan Görig 2010-03-02 09:38:42 EST
*** Bug 554503 has been marked as a duplicate of this bug. ***
Comment 8 Jan Görig 2010-03-02 09:43:24 EST
*** Bug 541755 has been marked as a duplicate of this bug. ***
Comment 9 Jan Görig 2010-03-09 07:57:58 EST
*** Bug 571521 has been marked as a duplicate of this bug. ***
Comment 10 Scott Williams 2010-03-10 14:13:36 EST

How to reproduce
-----
1.  Open Tigver VNC's gui
2.  Click Options.
3.  Click Shared
4.  Click OK.

Comment
-----
Opening TigerVNC's gui.  Tried to set option for Shared session.  Crashes when OK is clicked.
Comment 11 Jordan Freeman 2010-03-10 20:05:30 EST

How to reproduce
-----
1.Launch TigerVNC Viewer.
2.Select "Options" button.
3.Deselect "Auto Select" check box.
4.Click "OK" button.


Comment
-----
I was trying to manually select a color depth for the VNC session.
Comment 12 u.giebeler 2010-03-11 03:13:49 EST

Comment
-----
I looked only for the options and clicked ok-button.
That's all.
Thank you
Comment 13 Bas Auer 2010-03-13 10:16:30 EST

Comment
-----
Unable to reproduce it hapens or not. It happens unpredictable. Opening tiger VNC viewer opens several screens with out a problem. Next time I need it, it crashes.
Comment 14 Massa 2010-03-16 10:13:36 EDT

How to reproduce
-----
1.Connect a remote PC via ssh tunneling vnc session over this connection
2.Start vncserver at remote PC
3.connect the vnc session using Tigervnc client
4.Start Ktorrent


Comment
-----
Think it is related to the traffic generated by ktorrent window reflash and sudden speed down cause by BT transmission
Comment 15 Jenya 2010-03-19 15:41:17 EDT

How to reproduce
-----
1. Click Options
2. change Encoding and color level to Very low, OK
3. Connect to a server
Comment 16 Naveen 2010-03-23 02:33:32 EDT

How to reproduce
-----
1. Open vnc viewer
2. Without specifying vnc-server address, click on option
3. Check the option for Shared mode and Press OK button. ----> CRASH
Comment 17 Louis van Dyk 2010-03-23 04:30:51 EDT

How to reproduce
-----
1. Run - vncviewer
2. Enter server IP (of device across a slow wan link)
3. Click options; uncheck Auto Select (tight is selected) and select Low (64 colors); click OK
Comment 18 Amram 2010-03-23 22:17:59 EDT

How to reproduce
-----
1. Changing config options without connecting yet.
2.
3.


Comment
-----
Changing config options without connecting yet.
Comment 19 Amram 2010-03-24 17:32:49 EDT

How to reproduce
-----
1. Changing the options before connecting
2.
3.


Comment
-----
Changing the options before connecting
Comment 20 Andrzej Olaszewski 2010-04-06 13:28:07 EDT

How to reproduce
-----
I run this program.
Comment 21 Woody Aichner 2010-04-06 23:13:37 EDT

How to reproduce
-----
1.Using Tiger VNC Client
2.
3.


Comment
-----
Using Tiger VNC Client
Comment 22 Berrehouc Nicolas 2010-04-08 12:28:03 EDT
I confirm this problem. If you don't change options TigerVNC works fine. But if you try to check or uncheck one or more options you have a crash when you click OK.

/var/log/messages after each crash :
kernel: vncviewer[8655]: segfault at 158 ip 000000000040bea8 sp 00007fffa37db350 error 4 in vncviewer[400000+81000]
kernel: vncviewer[31672]: segfault at 158 ip 000000000040bea8 sp 00007fff71ff6c40 error 4 in vncviewer[400000+81000]

Crash with tigervnc.x86_64 0:1.0.0-3.fc12

If you downgrade to tigervnc.x86_64 0:1.0.0-1.fc12 you can change options without crash.
Comment 23 Berrehouc Nicolas 2010-04-08 16:53:32 EDT
Bug tracker TigerVNC : http://sourceforge.net/tracker/index.php?func=detail&aid=2964429&group_id=254363&atid=1126848 

Release 1.0.1 is available ( http://sourceforge.net/projects/tigervnc/files/ ) and seems to fix this bug. When will it be available in repository testing or stable ?
Comment 24 Pavel Mezhuyev 2010-04-14 02:21:55 EDT

How to reproduce
-----
1. run tigervnc
2. show options
3. close
Comment 25 Fedora Update System 2010-04-14 08:16:19 EDT
tigervnc-1.0.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tigervnc-1.0.1-1.fc12
Comment 26 Fedora Update System 2010-04-14 23:11:06 EDT
tigervnc-1.0.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.1-1.fc12
Comment 27 John Watzke 2010-04-15 15:56:36 EDT

How to reproduce
-----
1. Start vncviewer
2. Go to "Options"
3. Under Misc: select "Shared (don't disconnect other viewers)"
4. Click OK *crash*


Comment
-----
This is easy to replicate 100% of the time on my box.
Comment 28 Josh Krupka 2010-04-21 10:48:38 EDT

How to reproduce
-----
1.Ran TigerVNC viewer
2.Tried to connect to an existing vnc session with "shared mode" (don't disconnect other users) enabled
3. It crashed when I tried connecting


Comment
-----
I was able to connect to the same vnc session fine from Tiger with shared mode disabled
Comment 29 John Watzke 2010-04-21 11:35:07 EDT
I noticed updates to X that had comments that several functions were being exported out for use by tigervnc.  I tested out the options panel after the update to X and I no longer have crashes.  Perhaps this has gone away with the X fix?
Comment 30 Louis van Dyk 2010-04-23 04:47:25 EDT
I upgraded to tigervnc-1.0.1-1.fc12.x86_64 but am still having the samecrash problem when changing to Low Colour option once a connection has been established.  It was filed as bug 584877.
Comment 31 Adam Tkac 2010-04-27 06:45:39 EDT
*** Bug 586169 has been marked as a duplicate of this bug. ***
Comment 32 Eric Hopper 2010-05-04 14:41:53 EDT

How to reproduce
-----
Not sure how to reproduce

Comment
-----
I pulled up TigerVNC Viewer from the 'Internet' menu, typed in the server name, pulled up the options dialog, selected 'shared', clicked 'OK', and then 'OK' again on the 'Connection Details' window.
Comment 33 Fedora Update System 2010-05-06 23:58:38 EDT
tigervnc-1.0.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Adam Tkac 2010-05-07 07:34:44 EDT
*** Bug 588363 has been marked as a duplicate of this bug. ***
Comment 35 Adam Tkac 2010-05-07 07:35:19 EDT
*** Bug 589687 has been marked as a duplicate of this bug. ***
Comment 36 Adam Tkac 2010-05-07 07:36:15 EDT
*** Bug 588020 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.