Bug 579851 - [abrt] crash in terminator-0.14-3.fc13: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in terminator-0.14-3.fc13: Process /usr/bin/python was killed by...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: terminator
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:05e6bf2f43560e99934bf01e738...
Keywords:
: 579132 580603 583687 584491 584626 584813 586714 587208 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-06 18:19 UTC by Sven Winkelmann
Modified: 2010-05-13 19:33 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-12 12:24:16 UTC


Attachments (Terms of Use)
File: backtrace (22.19 KB, text/plain)
2010-04-06 18:19 UTC, Sven Winkelmann
no flags Details
debug output from 'terminator -d' (42.09 KB, text/plain)
2010-04-11 19:48 UTC, David Nalley
no flags Details

Description Sven Winkelmann 2010-04-06 18:19:03 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/terminator --sm-client-id 1034dd73c03be7d55d126976381319000800000017220043 --screen 0 --geometry=1418x897+88+15 --sm-client-id 1034dd73c03be7d55d126976381319000800000017220043 --sm-client-id 1034dd73c03be7d55d126976381319000800000017220043 -x /bin/sh -c 'cd /home/pugnacity/Desktop && exec $SHELL'
component: terminator
executable: /usr/bin/python
kernel: 2.6.33-1.fc13.x86_64
package: terminator-0.14-3.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. start terminator
2. open an new tab or split window
3.

Comment 1 Sven Winkelmann 2010-04-06 18:19:07 UTC
Created attachment 404766 [details]
File: backtrace

Comment 2 Eric Lake 2010-04-08 16:09:34 UTC
*** Bug 580603 has been marked as a duplicate of this bug. ***

Comment 3 David Nalley 2010-04-11 19:48:42 UTC
Created attachment 405847 [details]
debug output from 'terminator -d'

ran terminator -d following the steps that were listed by reporter

Comment 4 David Nalley 2010-04-11 19:52:04 UTC
I should not that the problem still exists in 
terminator-0.14-4.fc13.noarch

Comment 5 Dominic Hopf 2010-04-21 23:08:03 UTC
*** Bug 584491 has been marked as a duplicate of this bug. ***

Comment 6 Dominic Hopf 2010-04-21 23:11:01 UTC
*** Bug 583687 has been marked as a duplicate of this bug. ***

Comment 7 Dominic Hopf 2010-04-21 23:21:59 UTC
*** Bug 579132 has been marked as a duplicate of this bug. ***

Comment 8 James Laska 2010-04-22 13:40:49 UTC
Package: terminator-0.14-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Attempt to open a new tab, or split

Comment 9 James Laska 2010-04-22 13:41:58 UTC
*** Bug 584813 has been marked as a duplicate of this bug. ***

Comment 10 Dominic Hopf 2010-04-23 13:31:46 UTC
*** Bug 584626 has been marked as a duplicate of this bug. ***

Comment 11 David Nalley 2010-04-23 14:06:16 UTC
Dominic: 

This problem appears to be fixed in the koji build for 0.93 that's in koji: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=167167

Comment 12 Dominic Hopf 2010-04-23 14:39:36 UTC
Yep. :) I'm going to build it for F-13, F-12 and F-11 this weekend. :)

Comment 13 Fedora Update System 2010-04-24 18:58:25 UTC
terminator-0.93-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/terminator-0.93-1.fc13

Comment 14 Fedora Update System 2010-04-24 18:58:35 UTC
terminator-0.93-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/terminator-0.93-1.fc12

Comment 15 Dominic Hopf 2010-04-24 19:10:26 UTC
Thanks very much to everyone who reported this issue. Thanks also to David for pointing out, that the issue seems to be fixed in Terminator 0.93.

Before you finally update to Terminator 0.93 as soon as it is available, please note that the format of the configuration file has changed and you may want to backup your ~/.config/terminator before installing and running Terminator 0.93.

Comment 16 Fedora Update System 2010-04-25 13:57:34 UTC
terminator-0.93-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update terminator'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/terminator-0.93-1.fc13

Comment 17 Fabian A. Scherschel 2010-04-25 19:22:25 UTC
I can confirm a fix.

Comment 18 Fedora Update System 2010-04-27 02:16:06 UTC
terminator-0.93-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update terminator'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/terminator-0.93-1.fc12

Comment 19 Dominic Hopf 2010-04-30 17:41:21 UTC
*** Bug 587208 has been marked as a duplicate of this bug. ***

Comment 20 Dominic Hopf 2010-04-30 17:42:37 UTC
*** Bug 586714 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2010-05-12 12:24:02 UTC
terminator-0.93-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2010-05-13 19:33:15 UTC
terminator-0.93-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.