Bug 61153 - Abiword segfault
Abiword segfault
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
: 59470 61643 61724 62168 62207 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-14 10:00 EST by Inger Karin Haarbye
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 05:32:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2002-03-14 10:00:44 EST
Description of Problem:

Hampton beta2

Version-Release number of selected component (if applicable):
abiword-0.99.2-1

How Reproducible:
always


Steps to Reproduce:
1. Running "AbiWord" from konsole in KDE
2. 
3. 

Actual Results:

[inger@localhost inger]$ AbiWord
/usr/bin/AbiWord: line 67:  1448 Minnesegmentsfeil       $ABISUITE_LIBEXEC/AbiWord_d "$@"
Comment 1 Bernhard Rosenkraenzer 2002-03-25 09:46:18 EST
*** Bug 61643 has been marked as a duplicate of this bug. ***
Comment 2 Jay Turner 2002-03-25 21:43:07 EST
*** Bug 61724 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2002-03-28 04:07:12 EST
*** Bug 59470 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2002-03-28 16:28:30 EST
*** Bug 62168 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2002-03-28 16:49:14 EST
*** Bug 62207 has been marked as a duplicate of this bug. ***
Comment 6 Aleksey Nogin 2002-03-28 18:58:34 EST
gdb shows:

(gdb) bt
#0  0x081325d8 in UT_Vector::setNthItem ()
#1  0x082315ec in XAP_DiskStringSet::setValue ()
#2  0x08231161 in XAP_DiskStringSet::XAP_DiskStringSet ()
#3  0x08111090 in AP_DiskStringSet::AP_DiskStringSet ()
#4  0x080e3241 in AP_UnixApp::initialize ()
#5  0x080e50b9 in AP_UnixApp::main ()
#6  0x080e2ec9 in main ()
#7  0x40455df9 in __libc_start_main () from /lib/i686/libc.so.6
Comment 7 Akira TAGOH 2002-04-01 05:32:15 EST
I think STL support has this problem. if abiword will be compiled without STL
support, we will not see this problem.
Comment 8 Bernhard Rosenkraenzer 2002-04-02 08:26:26 EST
Fixed in 0.99.4-1

Note You need to log in before you can comment on or make changes to this bug.