Bug 67992 - Evolution-mail segmentation fault
Evolution-mail segmentation fault
Product: Red Hat Public Beta
Classification: Retired
Component: evolution (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: 67968 70880 70968 72376 72550 72966 73872 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
Reported: 2002-07-04 23:36 EDT by Jim Hayward
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-03 02:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
backtrace, but no debugging info, unfortunately (2.00 KB, text/plain)
2002-07-04 23:37 EDT, Jim Hayward
no flags Details

  None (edit)
Description Jim Hayward 2002-07-04 23:36:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Evolution 1.0.7-2. Clean install limbo. 

When selecting "Mark as Unread" or "Mark as Important" from the popup menu
evolution-mail will seg fault.

Selecting "Mark as Unread" or "Mark as Important" from the "Edit" menu works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Right click on an already read message
2. In the popup menu click "Mark as Unread" or "Mark as Important"

Actual Results:  Evolution-mail will seg fault.

Additional info:

I compiled the Evolution-1.0.7-2 src rpm on my Red Hat 7.3 system and it did not
exhibit this problem.
Comment 1 Jim Hayward 2002-07-04 23:37:58 EDT
Created attachment 63704 [details]
backtrace, but no debugging info, unfortunately
Comment 2 Jeremy Katz 2002-07-05 01:14:07 EDT
Reproduced; I'll wait to debug it until after I'm finished catching up on my
e-mail :-)
Comment 3 Jeremy Katz 2002-07-06 13:19:22 EDT
*** Bug 67968 has been marked as a duplicate of this bug. ***
Comment 4 jeroen 2002-08-02 07:21:35 EDT
It still crashes with Limbo beta 2. I select a bunch of e-mails and right-click
and select "Mark as Read" and evolution segfaults. Backtrace available on
request if needed.
Comment 5 Warren Togami 2002-08-05 15:23:09 EDT
Aiee!!! Just died on me too.  Selected two messages in an IMAP folder, then
"Mark as Read".  Crash.

I too will submit backtrace upon request.

High severity and/or High Priority please.
Comment 6 Jeremy Katz 2002-08-11 15:52:34 EDT
*** Bug 70880 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2002-08-11 15:52:51 EDT
*** Bug 70968 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2002-08-11 16:10:57 EDT
This is also filed upstream at http://bugzilla.ximian.com/show_bug.cgi?id=28394
Comment 9 Warren Togami 2002-08-18 03:45:14 EDT
Mandrake 9.0 beta has Evolution 1.0.8 patch level 3mdk, which doesn't crash in
this fashion.  Could this bug have been caused by a Red Hat patch to 1.0.8?
Comment 10 Jeremy Katz 2002-08-23 12:07:24 EDT
*** Bug 72376 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2002-08-25 12:44:13 EDT
*** Bug 72550 has been marked as a duplicate of this bug. ***
Comment 12 Need Real Name 2002-08-25 12:46:22 EDT
version 1.0.8 of null

bug is still present for me
Comment 13 Jeremy Katz 2002-08-29 12:16:03 EDT
*** Bug 72966 has been marked as a duplicate of this bug. ***
Comment 14 J Mora 2002-08-30 14:31:21 EDT
I have the same bug in my install of null (1.0.8-6).
Comment 15 J Mora 2002-08-31 13:37:00 EDT
Can anyone recommend where I can get an RPM or SRPM of evolution (compat with
null) that doesn't suffer from this bug?
Comment 16 J Mora 2002-08-31 13:56:29 EDT
evolution-1.0.8-9.i386.rpm from rawhide exhibits this same problem.
Build Date: Thu 29 Aug 2002 01:05:35 AM CDT
Build Host: daffy.perf.redhat.com
Comment 17 Jeremy Katz 2002-09-03 00:12:00 EDT
Owen tracked down and fixed this -- will be in 1.0.8-10
Comment 18 J Mora 2002-09-03 01:56:36 EDT
1.0.8-10 corrected the problem! Thanks.
Comment 19 Jeremy Katz 2002-09-03 02:53:54 EDT
This is up at http://people.redhat.com/~katzj/evolution/ if anyone else wants to
grab it
Comment 20 Jay Turner 2002-09-03 15:47:52 EDT
Fix confirmed as stated above.
Comment 21 Jeremy Katz 2002-09-19 15:51:25 EDT
*** Bug 73872 has been marked as a duplicate of this bug. ***
Comment 22 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.