Bug 7319 - default route being set on all devices
default route being set on all devices
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 7320 7333 7345 7350 7386 7392 7411 7440 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-25 00:53 EST by Chris
Modified: 2014-03-16 22:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 16:15:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 1999-11-25 00:53:08 EST
after installing initscripts 4.68-1 the system would assign default routes
to all network devices. this behaviour causes total loss of network
connectivity under some circumstances (two ether devices, one for local
network with manual setup and no gateway, one for cable modem with dhcp
setup and gateway set with dhcp. system tries to use the local ether device
as default route)
Comment 1 Bradley 1999-11-28 02:45:59 EST
Its even worse than that :(

I've got an ethernet card in my machine. A default route is brought up for that
and the loopback interface. When I dial up using my modem, ifup-ppp does a route
-del default, which only removes *one* of the default routes (the eth0 one in my
case). pppd then doesn't add a default route for ppp (presumably becuase a
default route already exists, althouhg I haven't checked), and so I can't do
anything on the net, as I don't have a route via ppp0.

I can either disconnect and reconnect, which works because then the 2nd default
route is removed, leaving no more, or manually remove the default routes and add
a new default route to ppp0.

A clean solution for me to to set GATEWAYDEV in /etc/sysconfig/network to none.
There's no network device called none, so this avoids the default route adding
in ifup, and the ifup-ppp adds the defaultroute parameter because of my
ifcfg-ppp* settings.

I don't know what a good general, backwards compatable solution is though.
Requiring GATEWAYDEV to be non-null isn't a good solution. (I have 2 ppp dialups
I can use - ppp0 and ppp1. Also think of laptop users who could connect via
ethernet at work/uni or a modem at home).

Maybe remove all default routes in ifup-ppp, or maybe make pppd add a default
route regardless. Another thought - should he deleted routes be added again
after disconnecting? I can't think of a situation where is configuration is
valid, except possibly for laptops
Comment 2 Riley H Williams 1999-11-28 18:03:59 EST
{Wry smile}  Refer to bug 7392 for a patch to fix this, along with a duplicate
bug report that I submitted a few hours ago.
Comment 3 Bradley 1999-11-28 20:31:59 EST
Thanks. I've added myself to the cc list for that one. There are quite a few
similar reports though... See Bug 7392 for "comments" on the patch.
Comment 4 Bill Nottingham 1999-11-29 11:14:59 EST
*** Bug 7392 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 1999-11-29 11:15:59 EST
*** Bug 7320 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 1999-11-29 11:16:59 EST
*** Bug 7333 has been marked as a duplicate of this bug. ****** Bug 7350 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 1999-11-29 11:18:59 EST
*** Bug 7386 has been marked as a duplicate of this bug. ****** Bug 7411 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 1999-11-29 11:54:59 EST
This should be fixed in initscripts-4.69-1 in Raw Hide now.
Comment 9 orders1 1999-11-29 12:18:59 EST
The patch by rhv@memalpha.cx  is not the best solution. If there is a GATEWAY,
every device would still get a default route. The problem is that /sbin/ifup
adds a default route even when GATEWAYDEV = "". Instead ifup should add a
default route only when GATEWAYDEV = DEVICE. This is also how it worked in the
previous releases.

This is a pretty serious problem with things like DNS. I can't believe they have
not fixed this for a whole week.

ates@mail.utexas.edu
Comment 10 Riley H Williams 1999-11-29 13:53:59 EST
Quick comment to orders1@ibm.net - the patch wasn't from me, but from
linux@eridani.co.uk - I just commented on its being there. Unfortunately, I
phrased my comment rather badly...

Incidentally, linux@eridani.co.uk isn't me, but a friend of mine.
Comment 11 Bill Nottingham 1999-11-30 11:15:59 EST
*** Bug 7440 has been marked as a duplicate of this bug. ***
Comment 12 orders1 1999-11-30 15:02:59 EST
Please post the rawhide initscripts package also in the 6.1 errata section. This
is a pretty serious bug.
Comment 13 Bill Nottingham 1999-11-30 15:31:59 EST
*** Bug 7345 has been marked as a duplicate of this bug. ***
Comment 14 Bill Nottingham 1999-11-30 16:15:59 EST
initscripts-4.70 is now in the errata. Wheeee.

Note You need to log in before you can comment on or make changes to this bug.