Bug 7392 - DefaultRoute allocated on ALL network interfaces
Summary: DefaultRoute allocated on ALL network interfaces
Status: CLOSED DUPLICATE of bug 7319
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-28 17:32 UTC by Michael McConnell
Modified: 2014-03-17 02:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-29 16:14:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael McConnell 1999-11-28 17:32:34 UTC
With initscripts-4.68-1 the networking tries to attach a default route to
EVERY network interface as it brings it up. The following patch appears to
correct this, although I'm not sure whether this patch fixes the problem or
hides it...

===8<=== CUT ===>8===

--- /etc/sysconfig/network-scripts/ifup~	Tue Nov 16 17:25:41 1999
+++ /etc/sysconfig/network-scripts/ifup	Sun Nov 28 16:11:46 1999
@@ -130,8 +130,6 @@
 	if [ "${GATEWAY}" != "" ]; then
 	    route add default gw ${GATEWAY} ${DEVICE}
 	    DEFGW=${GATEWAY}
-	else
-	    route add default ${DEVICE}
 	fi
     fi
 fi

===8<=== CUT ===>8===

Any and all comments much appreciated...

Comment 1 Riley H Williams 1999-11-28 23:10:59 UTC
Bug 7345, 7355, 7365, 7366 and 7386 all appear to be duplicates of this one.

Comment 2 Riley H Williams 1999-11-28 23:11:59 UTC
Links: Bug 7345 - bug 7355 - bug 7365 - bug 7366 - bug 7386

Comment 3 Bradley 1999-11-29 01:28:59 UTC
See Bug 7319 for my additional comments.

Seriously though, there must have been a reason this was added. Does some
software package (DHCP?) rely on a default route being present?

Comment 4 Bill Nottingham 1999-11-29 16:14:59 UTC
*** This bug has been marked as a duplicate of 7319 ***


Note You need to log in before you can comment on or make changes to this bug.