Bug 758253 - [abrt] gedit-3.2.3-1.fc16: g_object_unref: Process /usr/bin/gedit was killed by signal 11 (SIGSEGV)
[abrt] gedit-3.2.3-1.fc16: g_object_unref: Process /usr/bin/gedit was killed ...
Status: CLOSED DUPLICATE of bug 767075
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:84f18ac80ba16c7b04045528dc1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 11:11 EST by Theodore Lee
Modified: 2012-03-20 15:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 15:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (15.13 KB, text/plain)
2011-11-29 11:11 EST, Theodore Lee
no flags Details
File: backtrace (32.77 KB, text/plain)
2011-11-29 11:11 EST, Theodore Lee
no flags Details
File: build_ids (4.92 KB, text/plain)
2011-11-29 11:11 EST, Theodore Lee
no flags Details
File: maps (60.12 KB, text/plain)
2011-11-29 11:11 EST, Theodore Lee
no flags Details

  None (edit)
Description Theodore Lee 2011-11-29 11:11:33 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        gedit /home/antiaircraft/Swinburne/C++/Assignment/Battleships/battleships.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/board.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/board.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/computer.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/computer.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/coordinate.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/coordinate.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/exceptions.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/human.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/human.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/menu.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/menu.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/player.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/ship.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/ship.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/square.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/square.h /home/antiaircraft/Swinburne/C++/Assignment/Battleships/util.cpp /home/antiaircraft/Swinburne/C++/Assignment/Battleships/util.h
crash_function: g_object_unref
executable:     /usr/bin/gedit
kernel:         3.1.2-1.fc16.x86_64
pid:            2522
pwd:            /home/antiaircraft
reason:         Process /usr/bin/gedit was killed by signal 11 (SIGSEGV)
time:           Tue 29 Nov 2011 11:23:55 PM MYT
uid:            1000
username:       antiaircraft

backtrace:      Text file, 33560 bytes
build_ids:      Text file, 5043 bytes
dso_list:       Text file, 15489 bytes
maps:           Text file, 61562 bytes

environ:
:GIT_PS1_SHOWDIRTYSTATE=true
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=aa-sk
:LC_MONETARY=en_US.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-DIALkc/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=47d171440f72634427f287550000000d-1322565685.8475-1722705033
:LC_NUMERIC=en_US.utf8
:GNOME_KEYRING_CONTROL=/tmp/keyring-DIALkc
:IMSETTINGS_MODULE=IBus
:USER=antiaircraft
:DESKTOP_AUTOSTART_ID=108b8deb4e25afee9f132256568680919900000013030003
:SSH_AUTH_SOCK=/tmp/keyring-DIALkc/ssh
:USERNAME=antiaircraft
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1303,unix/unix:/tmp/.ICE-unix/1303
:_WAPI_PROCESS_HANDLE_OFFSET=2
:MAIL=/var/spool/mail/antiaircraft
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/antiaircraft/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/antiaircraft
:XMODIFIERS=@im=ibus
:EDITOR=nano
:GNOME_KEYRING_PID=1295
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:LC_MEASUREMENT=en_US.utf8
:GIT_PS1_SHOWUNTRACKEDFILES=true
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/antiaircraft
:XDG_SEAT=seat0
:SHLVL=3
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=antiaircraft
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-wY7HiaUvYL,guid=286ce5bbfb6aa342f31d15040000004a
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/antiaircraft
:DISPLAY=:0.0
:LC_TIME=en_US.utf8
:XAUTHORITY=/var/run/gdm/auth-for-antiaircraft-inWYl9/database
:_=/usr/bin/gvfs-open
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gedit.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2522
:DESKTOP_STARTUP_ID=nautilus-2226-aa-sk-gedit-0_TIME266700

var_log_messages:
:Nov 28 16:20:53 aa-sk abrt: detected unhandled Python exception in 'gedit'
:Nov 29 12:15:56 aa-sk abrt: detected unhandled Python exception in 'gedit'
:Nov 29 23:23:55 aa-sk kernel: [14617.470728] gedit[2522]: segfault at 3 ip 0000003d6841131a sp 00007fff23e0f500 error 4 in libgobject-2.0.so.0.3000.1[3d68400000+4c000]
:Nov 29 23:23:57 aa-sk abrt[7489]: Saved core dump of pid 2522 (/usr/bin/gedit) to /var/spool/abrt/ccpp-2011-11-29-23:23:55-2522 (214958080 bytes)

xsession_errors:
:(gedit:2522): Gtk-WARNING **: Unable to retrieve the file info for `file:///home/antiaircraft/Swinburne/C++/Assignment/Battleships/fleet.h': Error stating file '/home/antiaircraft/Swinburne/C++/Assignment/Battleships/fleet.h': No such file or directory
:(gedit:2522): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(gedit:7549): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(gedit:7549): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(gedit:7549): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(gedit:7549): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Comment 1 Theodore Lee 2011-11-29 11:11:38 EST
Created attachment 538095 [details]
File: dso_list
Comment 2 Theodore Lee 2011-11-29 11:11:41 EST
Created attachment 538097 [details]
File: backtrace
Comment 3 Theodore Lee 2011-11-29 11:11:44 EST
Created attachment 538098 [details]
File: build_ids
Comment 4 Theodore Lee 2011-11-29 11:11:48 EST
Created attachment 538099 [details]
File: maps
Comment 5 François Kooman 2011-12-10 07:52:49 EST
Package: gedit-3.2.3-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
trying to go to a path in the file save dialog
Comment 6 gabe@codehaus.org 2011-12-13 03:42:21 EST
Package: gedit-3.2.3-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I was using the file dialog to browse files on a remote SFTP share. I double clicked a folder and gedit crashed.
Comment 7 Matthieu Pupat 2011-12-16 14:39:52 EST
Package: gedit-3.2.3-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Browsed for opening a file
Comment 8 abrt-bot 2012-03-20 15:33:39 EDT
Backtrace analysis found this bug to be similar to bug #767075, closing as duplicate.

Bugs which were found to be similar to this bug: 
  anjuta: bug #766225
  audacious: bug #766623
  control-center: bug #768544
  empathy: bug #759110
  evince: bug #767275
  evolution: bug #758402, bug #766874, bug #768103
  file-roller: bug #766407, bug #766990, bug #767040
  gedit: bug #761396, bug #766285, bug #767809, bug #768322, bug #768558
  gnome-tweak-tool: bug #766937
  gnome-utils: bug #767209
  gtk3: bug #766355, bug #766947
  rhythmbox: bug #766205, bug #768085, bug #769003
  totem: bug #766251, bug #766593
  transmission: bug #767075

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 767075 ***

Note You need to log in before you can comment on or make changes to this bug.