Bug 785476 (Horde_Serialize) - Review Request: php-horde-Horde-Serialize - Data Encapulation API
Summary: Review Request: php-horde-Horde-Serialize - Data Encapulation API
Keywords:
Status: CLOSED ERRATA
Alias: Horde_Serialize
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: horde-channel Horde_Exception Horde_Util
Blocks: Horde_Rpc Horde_Editor Horde_Core
TreeView+ depends on / blocked
 
Reported: 2012-01-29 03:17 UTC by Nick Bebout
Modified: 2013-03-21 15:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-28 06:59:20 UTC
fedora: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)
phpci.log (12.07 KB, text/x-log)
2013-02-06 10:41 UTC, Remi Collet
no flags Details
php-horde-Horde-Serialize-review.txt (6.95 KB, text/plain)
2013-02-06 10:41 UTC, Remi Collet
no flags Details

Description Nick Bebout 2012-01-29 03:17:42 UTC
Spec URL: http://nb.fedorapeople.org/horde-reviews/php-horde-Horde-Serialize.spec
SRPM URL: http://nb.fedorapeople.org/horde-reviews/php-horde-Horde-Serialize-1.0.2-1.fc16.src.rpm
Description: The Horde_Serialize library provides various methods of encapsulating data.

Comment 1 Shawn Iwinski 2012-07-04 23:39:57 UTC
I will review this package

Comment 2 Shawn Iwinski 2012-07-22 04:41:51 UTC
After a quick review:

[MUST] "Requires: php-common >= 5.2.0" to satisfy package.xml

[SHOULD] %check is present and all tests pass

[SHOULD] Localized php.ini not necessary (see https://bugzilla.redhat.com/show_bug.cgi?id=785471#c5)

Comment 3 Remi Collet 2012-12-17 10:35:58 UTC
Please update to 2.0.1

Comment 5 Remi Collet 2013-02-06 10:41:19 UTC
Created attachment 693871 [details]
phpci.log

Comment 6 Remi Collet 2013-02-06 10:41:50 UTC
Created attachment 693872 [details]
php-horde-Horde-Serialize-review.txt

Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 785476

Comment 7 Remi Collet 2013-02-06 10:43:21 UTC
[!]: Requires correct, justified where necessary.
	From phpci, Optional from package.xml
	Requires: php-bz2
	Requires: php-json
	Requires: php-wddx
	Requires: php-zlib
	Requires: php-pecl(LZF)

[!]: License field in the package spec file matches the actual license.
	LGPLv2 (not LGPLv2+)

Need to fix the License, else everything is ok.
(optional deps, is your choice)

Can you please replace my "private" email by my fp.o one ?

Comment 9 Remi Collet 2013-02-07 15:00:57 UTC
< License:        LGPLv2+
---
> License:        LGPLv2

[x]: License field in the package spec file matches the actual license.

> Requires:       php-bz2 php-json php-wddx php-zlib php-pecl(LZF)

[x]: Requires correct, justified where necessary.

No blocker

== APPROVED ==

Comment 10 Nick Bebout 2013-02-07 21:41:17 UTC
New Package SCM Request
=======================
Package Name: php-horde-Horde-Serialize
Short Description: Horde Data Encapsulation API
Owners: nb remi
Branches: el6 f18
InitialCC:

Comment 11 Gwyn Ciesla 2013-02-08 13:40:21 UTC
Git done (by process-git-requests).

Comment 12 Fedora Update System 2013-02-16 00:59:00 UTC
php-horde-Horde-Image-2.0.3-3.el6, php-horde-Horde-Alarm-2.0.3-3.el6, php-horde-Horde-Lock-2.0.1-3.el6, php-horde-Horde-Argv-2.0.4-4.el6, php-horde-Horde-Serialize-2.0.1-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-horde-Horde-Serialize-2.0.1-3.el6,php-horde-Horde-Argv-2.0.4-4.el6,php-horde-Horde-Lock-2.0.1-3.el6,php-horde-Horde-Image-2.0.3-3.el6,php-horde-Horde-Alarm-2.0.3-3.el6

Comment 13 Fedora Update System 2013-02-16 02:25:31 UTC
php-horde-Horde-Alarm-2.0.3-3.fc18, php-horde-Horde-Image-2.0.3-3.fc18, php-horde-Horde-Lock-2.0.1-3.fc18, php-horde-Horde-Text-Flowed-2.0.1-3.fc18, php-horde-Horde-Argv-2.0.4-4.fc18, php-horde-Horde-Serialize-2.0.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/php-horde-Horde-Argv-2.0.4-4.fc18,php-horde-Horde-Serialize-2.0.1-3.fc18,php-horde-Horde-Text-Flowed-2.0.1-3.fc18,php-horde-Horde-Lock-2.0.1-3.fc18,php-horde-Horde-Image-2.0.3-3.fc18,php-horde-Horde-Alarm-2.0.3-3.fc18

Comment 14 Fedora Update System 2013-02-17 03:32:34 UTC
Package php-horde-Horde-Alarm-2.0.3-3.fc18, php-horde-Horde-Image-2.0.3-3.fc18, php-horde-Horde-Lock-2.0.1-3.fc18, php-horde-Horde-Text-Flowed-2.0.1-3.fc18, php-horde-Horde-Argv-2.0.4-4.fc18, php-horde-Horde-Serialize-2.0.1-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-horde-Horde-Alarm-2.0.3-3.fc18 php-horde-Horde-Image-2.0.3-3.fc18 php-horde-Horde-Lock-2.0.1-3.fc18 php-horde-Horde-Text-Flowed-2.0.1-3.fc18 php-horde-Horde-Argv-2.0.4-4.fc18 php-horde-Horde-Serialize-2.0.1-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2619/php-horde-Horde-Argv-2.0.4-4.fc18,php-horde-Horde-Serialize-2.0.1-3.fc18,php-horde-Horde-Text-Flowed-2.0.1-3.fc18,php-horde-Horde-Lock-2.0.1-3.fc18,php-horde-Horde-Image-2.0.3-3.fc18,php-horde-Horde-Alarm-2.0.3-3.fc18
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2013-02-28 06:59:23 UTC
php-horde-Horde-Alarm-2.0.3-3.fc18, php-horde-Horde-Image-2.0.3-3.fc18, php-horde-Horde-Lock-2.0.1-3.fc18, php-horde-Horde-Argv-2.0.4-4.fc18, php-horde-Horde-Serialize-2.0.1-3.fc18, php-horde-Horde-Text-Flowed-2.0.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2013-03-09 19:16:33 UTC
php-horde-Horde-Image-2.0.3-3.el6, php-horde-Horde-Alarm-2.0.3-3.el6, php-horde-Horde-Lock-2.0.1-3.el6, php-horde-Horde-Argv-2.0.4-4.el6, php-horde-Horde-Serialize-2.0.1-3.el6, php-horde-Horde-Text-Flowed-2.0.1-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.