Bug 81215 - Menu editing does not work
Menu editing does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: Triaged
: 78179 83081 87771 88234 122175 125825 126762 137085 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-01-06 15:22 EST by Miloslav Trmac
Modified: 2007-04-18 12:49 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 10:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2003-01-06 15:22:54 EST
Description of problem:
Is menu editing supposed to work in Phoebe?
I have opened Start here, navigated to Applications/{,Extras}/Sound & Video,
and moved Rhythmbox from extras to base. The panel menu hasn't changed,
and the changes in Start here disappeared on next login.

Sorry, this may be misfiled (perhaps gnome-vfs2?)
Havoc, it is for you anyway ;-)
Thanks
Comment 1 Havoc Pennington 2003-01-06 16:27:58 EST
No, it's not supposed to work yet

I'm 99% sure this bug is a dup ;-)
Comment 2 Michael Knepher 2003-01-10 14:55:04 EST
Also, if you add an item directly to the menu (right click->Entire menu->Add new
item...), it will only be displayed for the current session. After logging out,
the item is not reloaded, though the desktop file created in
~/.gnome2/vfolders/applications remains.
Comment 3 Havoc Pennington 2003-01-12 17:38:55 EST
*** Bug 78179 has been marked as a duplicate of this bug. ***
Comment 4 Havoc Pennington 2003-01-14 15:58:40 EST
The menu code is reverted to the 8.0/GNOME2.0 code post-Phoebe, because 
the GNOME 2.2 code is uber-broken, even in read-only mode (if you never
edit it).

Things look bad at the moment.

Comment 5 Need Real Name 2003-01-22 09:41:52 EST
I am confused - what exactly are the issues with gnome-vfs and RH?

I know that in stock gnome, full menu editing has worked since 2.0.2 + 1 
release of gnome-panel

For info I am running phoebe1 + full g2 current build, with the menus config 
files symlinked to the files in /etc/gnome-vfs-2.0 (so I have the same menu 
layout), and everything just works.


Comment 6 Havoc Pennington 2003-01-22 10:06:59 EST
It hasn't worked in stock gnome, it's buggy as hell. It mostly works using the
menus that come with gnome, and if you don't need KDE to use the same menus.
With our vfolder files, the code gets confused and displays things in the wrong
place. The code modifies the vfolder files so KDE can't read them, even if you 
never edit your menus. The code does not properly update when new .desktop files 
are installed. The code does not support OnlyShowIn. The code does support 
some weird undocumented extensions. The code crashes. etc.

There's a lot of difference between "appears to work for me" and 
"will not result in deluge of bugzilla reports" ;-) I think it can appear to
work for a lot of people even when 20% of people are seeing serious bugs. 
And 20% of our users is at least tens of thousands of people...
Comment 7 Havoc Pennington 2003-01-29 19:27:14 EST
*** Bug 83081 has been marked as a duplicate of this bug. ***
Comment 8 Havoc Pennington 2003-01-29 19:29:51 EST
See https://listman.redhat.com/pipermail/phoebe-list/2003-January/001721.html

Bugs reported in followups to that include possible crashes, and 
submenu contents vanishing if you move the whole submenu.
Comment 9 Havoc Pennington 2003-04-02 10:50:33 EST
*** Bug 87771 has been marked as a duplicate of this bug. ***
Comment 10 Havoc Pennington 2003-04-07 22:58:10 EDT
*** Bug 88234 has been marked as a duplicate of this bug. ***
Comment 11 Calvin Webster 2004-03-03 15:26:06 EST
Has this problem been fixed yet?

I see it goes back more than a year. It was very disappointing to find
that menus cannot be changed. I'm surprised this still has "normal"
priority and severity. 

Is there a way to workaround this problem without breaking anything else?

The Navy purchased this system (and others) from Dell with RHL 9 and 3
yrs of RHN. We expected more stability. They are not going to want to
hear that they have to reach in their pocket again to upgrade to RHEL
workstation so we can have workable machines.
Comment 12 Edgar Arroyo 2004-07-05 17:40:28 EDT
Can someone please post a way of adding to the darn menu, this is
annoying, I have to click on the Hat and RUN and type my own symlinks
in /bin to get programs running, very annoying.
Comment 13 Mark McLoughlin 2004-07-27 05:07:28 EDT
*** Bug 125825 has been marked as a duplicate of this bug. ***
Comment 14 Mark McLoughlin 2004-08-11 04:32:39 EDT
*** Bug 122175 has been marked as a duplicate of this bug. ***
Comment 15 Mark McLoughlin 2004-08-11 04:33:35 EDT
*** Bug 126762 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thomsen Leth 2004-08-11 04:45:07 EDT
what about writning the status of the bug redhat?
Comment 17 Richard Stone Brooks II 2004-10-06 18:09:10 EDT
This example adds JEdit to the accessories menu. It assumes that
you're using the gnome desktop.
Do the following as root:
Open /usr/share/applications/gnome-gedit.desktop in a text editor.
Copy it's contents.
Paste in new file.
change lines:
...
Name=JEdit
...
Comment=Java Based IDE
...
Exec=java -jar /usr/local/share/jedit/4.2/jedit.jar
...
Icon=/usr/local/share/jedit/4.2/doc/jedit.png

I left the lines in between alone. I'm sure they're just translations.

Then remove lines:
X-GNOME-DocPath=gedit/gedit.xml
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gedit
X-GNOME-Bugzilla-Component=general
X-Desktop-File-Install-Version=0.4
*Note: Don't remove the Catagories or StarupNotify lines.

Save the new file in the same directory with the name gnome-jedit.desktop

JEdit should be in your accessories menu.
Comment 18 John Thacker 2006-04-23 10:39:18 EDT
*** Bug 137085 has been marked as a duplicate of this bug. ***
Comment 19 Bill Nottingham 2006-08-05 01:44:58 EDT
Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks.

Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
They are maintained by the Fedora Legacy project (http://www.fedoralegacy.org/)
for security updates only. If this is a security issue, please reassign to the
'Fedora Legacy' product in bugzilla. Please note that Legacy security update
support for these products will stop on December 31st, 2006.

If this is not a security issue, please check if this issue is still present
in a current Fedora Core release. If so, please change the product and version
to match, and check the box indicating that the requested information has been
provided.

If you are currently still running Red Hat Linux 7.3 or 9, please note that
Fedora Legacy security update support for these products will stop on December
31st, 2006. You are strongly advised to upgrade to a current Fedora Core release
or Red Hat Enterprise Linux or comparable. Some information on which option may
be right for you is available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Any bug still open against Red Hat Linux 7.3 or 9 at the end of 2006 will be
closed 'CANTFIX'. Again, if this bug still exists in a current release, or is a
security issue, please change the product as necessary. We thank you for your
help, and apologize again that we haven't handled these issues to this point.
Comment 20 Alexander Larsson 2006-09-01 10:25:48 EDT
Editing works differently now.

Note You need to log in before you can comment on or make changes to this bug.