Bug 854073 - [abrt] NetworkManager-0.9.4.0-9.git20120521.fc17: handle_ip_config_timeout: Process /usr/sbin/NetworkManager was killed by signal 6 (SIGABRT)
[abrt] NetworkManager-0.9.4.0-9.git20120521.fc17: handle_ip_config_timeout: P...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:9105387b145ded493f46c77981b...
:
: 891617 905148 906727 910828 922323 953599 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 19:07 EDT by Christoph Maser
Modified: 2013-11-08 17:54 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 04:52:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (16.33 KB, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: environ (155 bytes, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: dso_list (3.36 KB, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: open_fds (741 bytes, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: backtrace (17.55 KB, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: var_log_messages (10.65 KB, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: core_backtrace (800 bytes, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details
File: cgroup (174 bytes, text/plain)
2012-09-03 19:07 EDT, Christoph Maser
no flags Details

  None (edit)
Description Christoph Maser 2012-09-03 19:07:02 EDT
Version-Release number of selected component:
NetworkManager-0.9.4.0-9.git20120521.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: handle_ip_config_timeout
kernel:         3.5.2-3.fc17.x86_64

truncated backtrace:
:Thread no. 1 (3 frames)
: #4 handle_ip_config_timeout at nm-device-wifi.c
: #5 real_act_stage4_ip6_config_timeout at nm-device-wifi.c
: #6 nm_device_activate_ip6_config_timeout at nm-device.c
Comment 1 Christoph Maser 2012-09-03 19:07:06 EDT
Created attachment 609484 [details]
File: maps
Comment 2 Christoph Maser 2012-09-03 19:07:09 EDT
Created attachment 609485 [details]
File: environ
Comment 3 Christoph Maser 2012-09-03 19:07:11 EDT
Created attachment 609486 [details]
File: dso_list
Comment 4 Christoph Maser 2012-09-03 19:07:13 EDT
Created attachment 609487 [details]
File: open_fds
Comment 5 Christoph Maser 2012-09-03 19:07:15 EDT
Created attachment 609488 [details]
File: backtrace
Comment 6 Christoph Maser 2012-09-03 19:07:17 EDT
Created attachment 609489 [details]
File: var_log_messages
Comment 7 Christoph Maser 2012-09-03 19:07:19 EDT
Created attachment 609490 [details]
File: limits
Comment 8 Christoph Maser 2012-09-03 19:07:21 EDT
Created attachment 609491 [details]
File: core_backtrace
Comment 9 Christoph Maser 2012-09-03 19:07:23 EDT
Created attachment 609492 [details]
File: cgroup
Comment 10 Jirka Klimes 2013-01-08 07:35:09 EST
*** Bug 891617 has been marked as a duplicate of this bug. ***
Comment 11 Jirka Klimes 2013-01-08 07:39:47 EST
 ap = nm_device_wifi_get_activation_ap (self);
 g_assert (ap);

Hmm, we asserting there is always an AP, however it's not true. Either we should really ensure that an AP exists or check 'ap' here instead of g_assert.
Comment 12 Moez Roy 2013-01-12 02:59:27 EST
Please change Version from F17 to F18.

Thanks.
Comment 13 Jirka Klimes 2013-01-29 08:03:49 EST
*** Bug 905148 has been marked as a duplicate of this bug. ***
Comment 14 Reinout van Schouwen 2013-02-26 10:30:02 EST
Switching between wireless and cabled connections

backtrace_rating: 4
Package: NetworkManager-0.9.7.997-2.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 15 gregjo 2013-06-06 18:21:57 EDT
This crash hasn't happened previously. However, I had just installed NetworkManager-openvpn. Then I rebooted and this crash happened.

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
core_backtrace: 
crash_function: handle_ip_config_timeout
executable:     /usr/sbin/NetworkManager
kernel:         3.9.4-200.fc18.i686.PAE
package:        NetworkManager-0.9.8.1-3.git20130514.fc18
reason:         Process /usr/sbin/NetworkManager was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            0
Comment 16 Dan Williams 2013-06-07 11:39:39 EDT
*** Bug 953599 has been marked as a duplicate of this bug. ***
Comment 17 Dan Williams 2013-06-07 11:41:43 EDT
*** Bug 922323 has been marked as a duplicate of this bug. ***
Comment 18 Dan Williams 2013-06-07 11:42:32 EDT
*** Bug 906727 has been marked as a duplicate of this bug. ***
Comment 19 Dan Williams 2013-06-07 11:42:37 EDT
*** Bug 910828 has been marked as a duplicate of this bug. ***
Comment 20 Dan Williams 2013-06-07 11:44:00 EDT
Fixed upstream as 9c57277aeb4e0794780296adc329fa720c42a982
Comment 21 Jirka Klimes 2013-11-06 04:52:26 EST

*** This bug has been marked as a duplicate of bug 1025371 ***
Comment 22 Thomas Haller 2013-11-08 17:54:21 EST
(In reply to Jirka Klimes from comment #21)
> 
> *** This bug has been marked as a duplicate of bug 1025371 ***

Sorry, this is not a dupe of bug 1025371, it was never fixed in F17, but it's fixed in master and newer Fedora versions.

Note You need to log in before you can comment on or make changes to this bug.