This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 90054 - upgrade to rh9 gui problems led to rpm issues
upgrade to rh9 gui problems led to rpm issues
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-01 14:23 EDT by Brian Johnson
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-09 14:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from rpm -Va (398.75 KB, text/plain)
2003-05-09 13:52 EDT, Brian Johnson
no flags Details

  None (edit)
Description Brian Johnson 2003-05-01 14:23:36 EDT
Description of problem:
I updated from RH8 to RH9 and the desktop stopped working.

I checked the XFree log and got some stuff about fonts not set up correctly

I played with that for a while and then ran redhat-config-xfree86 and got 
errors about not finding glade

Installed glade2 and now I'm another person getting the rpm --rebuilddb -vv 
error:
D: adding "usbutils" to Providename index.
D: adding "hotplug" to Conflictname index.
D: adding 4 entries to Dirnames index.
D: adding 7 entries to Requireversion index.
D: adding "0.9-10" to Provideversion index.
D: adding 1 entries to Installtid index.
D: adding 1 entries to Sigmd5 index.
D: adding "df09a18d17b9a464e4e5c868a0dc3b67dc635f06" to Sha1header index.
D: adding 11 entries to Filemd5s index.
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
error: db4 error(16) from dbenv->remove: Device or resource busy
D: removed  db environment /var/lib/rpm/Packages
D: closed   db index       /var/lib/rpmrebuilddb.1319/Pubkeys
D: closed   db index       /var/lib/rpmrebuilddb.1319/Filemd5s
D: closed   db index       /var/lib/rpmrebuilddb.1319/Sha1header
D: closed   db index       /var/lib/rpmrebuilddb.1319/Sigmd5
D: closed   db index       /var/lib/rpmrebuilddb.1319/Installtid

I've looked at bugs 83281, 85868, 88273, 88416, 89717 and have tried adding 
nosysinfo to the kernel line in grub.conf and have also tried deleting the 
__db* files in /var/lib/rpm with no luck

This is supposed to be a harmless error but my system seems to be a bit more 
mangled since when I try to up2date -u -f I get:
# up2date -u -f

Fetching package list for channel: redhat-linux-i386-9...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
alsa-driver-2.4.19-1.ll-0.9.0-44         requires kernel-up = 2.4.19-1.ll

But I can't seem to rpm -e those two packages (it says that alsa-driver isn't 
installed)
# rpm -e alsa-driver
error: package alsa-driver is not installed

I then tried rpm -e alsa-driver-2.4.19-1.ll-0.9.0-44 and got a preun error so I 
redid it with the --noscripts option and it seems to have removed it

I was able to get an up2date -u -f to work and received a new kernel 2.4.20-9 
that was installed successfully (looking at grub.conf this kernel already uses 
the nosysinfo boot option)

Trying rpm --rebuilddb again seems to come up without errors

Same problem as I started with though, when I boot, it gets into X windows and 
I see the light blue screen and the rotating hourglass, but it flashes back to 
console 1 multiple times and then gives me a failed to start display server 
error

If I login and type startx I see the xwindows X cursor and the Redhat bitmap 
flash up and then back to text console with # startx

XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-3bigmem i686 [ELF]
Build Date: 27 February 2003
Build Host: porky.devel.redhat.com

        Before reporting problems, check http://www.XFree86.Org/
        to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.20-9 (bhcompile@stripples.devel.redhat.com) (gcc 
version 3.2.2 20030313 (Red Hat Linux 3.2.2-10)) #1 Wed Apr 2 13:42:50 EST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu May  1 14:23:25 2003
(==) Using config file: "/etc/X11/XF86Config"

SESSION_MANAGER=local/ou812.johnson-engineering.ca:/tmp/.ICE-unix/1410
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org

waiting for X server to shut down



Version-Release number of selected component (if applicable):
rpm-4.2-0.69.i386.rpm

How reproducible:
every time

Steps to Reproduce:
1. I'm sorry that I don't know.  Perhaps then I could backtrace my steps and 
solve it
2.
3.
    

Expected results:
Start shiney new, updated system and be amazed at the wonderful new features

Actual results:
Spent two days (so far) trying to get into gnome so I can get some work done

Additional info:
Comment 1 Brian Johnson 2003-05-01 16:14:32 EDT
I was reading /etc/X11/prefdm to see what happens when booting (found reference 
to it in the redhat reference docs at www.redhat/docs)

I manually set DISPLAYMANAGER="GNOME" in /etc/sysconfig/desktop and 
ran /etc/X11/prefdm from the command line and the same thing happened as whe I 
boot up

I changed to DISPLAYMANAGER="KDE" and again ran /etc/X11/prefdm from the 
command line and a login prompt appeared.  I logged in and got a KDE desktop

I went to /var/log/gdm but those log files don't say much (and certainly not 
any errors) so I don't know how to fix my system, but it seems that it is a 
gnome issue
Comment 2 Jeff Johnson 2003-05-02 11:03:39 EDT
The --rebuilddb error message is harmless.

Off to gdm to try to sort out the rest ...
Comment 3 Havoc Pennington 2003-05-02 12:03:32 EDT
There's no need to guess at where the issue is; the error message 
says:

No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org

it sounds like your system is badly hosed (missing files and such). 
I can't speculate on how it got that way, rpm --force and up2date -f may 
have contributed, but whatever got it that way seems to be the problem, the
software that relies on the files isn't broken.

Try "rpm -Va" to see what's wrong, assuming the rpm db isn't confused. I'd try
just reinstalling fontconfig for this immediate problem but with so 
many other problems I'm not sure it's going to help, you're going to 
get lots of instability.

redhat-config-xfree86 doesn't require glade2, it requires .glade data files
found in the r-c-xfree86 package... that one worries me.
Comment 4 Brian Johnson 2003-05-09 09:57:59 EDT
I'll try running rpm -Va

I've already tried reinstalling fontconfig with rpm -Uvh fontconfig --force 
with no apparant effect

I'll also try reinstalling redhat-config-xfree86 
Comment 5 Havoc Pennington 2003-05-09 11:31:48 EDT
Please try to avoid --force. If the rpm won't install without --force, you 
need to fix the error messages by addressing the dependency problems 
mentioned, not by adding --force. Otherwise all bets are off.
Comment 6 Brian Johnson 2003-05-09 12:04:00 EDT
If I don't use --force to install an rpm that is already installed, it just says that rpm is already 
up-to-date 
 
Is there another way to reinstall an rpm?  Or do I need to go through the dependancy dance to 
remove it prior to reinstalling it? 
Comment 7 Brian Johnson 2003-05-09 12:08:19 EDT
I reinstalled redhat-config-xfree86 with --force (I don't yet know of another way to reinstall a 
package that rpm thinks is already installed) 
 
When I run redhat-config-xfree86 I get: 
* ddcprobe returned bogus values: 
ID:   None 
Name: None 
HorizSync: None 
VertSync:  None 
 
Traceback (most recent call last): 
  File "/usr/share/redhat-config-xfree86/xconf.py", line 403, in ? 
    import gtk.glade 
ImportError: No module named glade 
 
 
I've been here before .. previously I reinstalled all the packages that included the words python 
and glade 
 
I did a rpm -Va > rpmsVa.txt and looked at that file, but I don't really know what to look for .. a 
search for error came up with nothing 
Comment 8 Brian Johnson 2003-05-09 12:34:18 EDT
Here is a list of things from rpm -Va that might be of interest (they are the only things that 
looked like error messages) 
 
missing    /usr/lib/mozilla/plugins/libflashplayer.so 
missing    /var/www/html/usage 
missing    /var/www/html/usage/msfree.png 
missing    /var/www/html/usage/webalizer.png 
missing    /usr/lib/libpq.so.2.0 
missing    /etc/rc.d/rc2.d/K10webmin 
missing    /etc/rc.d/rc2.d/S99webmin 
missing    /etc/rc.d/rc3.d/K10webmin 
missing    /etc/rc.d/rc3.d/S99webmin 
missing    /etc/rc.d/rc5.d/K10webmin 
missing    /etc/rc.d/rc5.d/S99webmin 
 
 
Comment 9 Havoc Pennington 2003-05-09 13:36:26 EDT
Can you just attach the rpm -Va output? There's a link on this page 
that says "Create a New Attachment", use that to attach the output.

"man rpm" says how to interpret the letter codes by each file:
       S file Size differs
       M Mode differs (includes permissions and file type)
       5 MD5 sum differs
       D Device major/minor number mis-match
       L readLink(2) path mis-match
       U User ownership differs
       G Group ownership differs
       T mTime differs

5 and S (md5sum or size differs) are bad news, for everything except 
configuration files.

You're right that to reinstall an already-installed package you may need
--force, I was concerned about broken dependencies.
Comment 10 Brian Johnson 2003-05-09 13:52:43 EDT
Created attachment 91595 [details]
output from rpm -Va
Comment 11 Brian Johnson 2003-05-09 13:55:33 EDT
You probably already knew that there would be S and 5 listings in this output 
 
Could you help me figure out what packages I should reinstall to get the gnome gui (and gdm) 
working? 
 
I can work on the other non-essential packages myself later 
 
 
Comment 12 Havoc Pennington 2003-05-09 14:11:20 EDT
I would describe your system as deeply hosed; in particular the C library has
all the md5sums wrong. At this point there's definitely not a GNOME bug. 
There may be a bug in whatever caused the system to be hosed, but that 
would need to be tracked down. There's a good chance it's a bad hard drive 
or something.

You could reinstall everything in the GNOME and X components (see 
/usr/share/comps/i386/comps.xml).

Personally, I would not do that, because your C library and many other things 
are messed up, which might mean the reinstall won't even work right.

I would suggest reinstalling from scratch after backing up your personal data
files. I'd also get some hardware test tools like memtest86 or 
if you can find something for disks, and run those.

For help with all this you should really go to the mailing lists, since it's 
more of a support issue than a bug.

Note You need to log in before you can comment on or make changes to this bug.