Bug 219218

Summary: Updated avahi package does not create group "netdev"
Product: [Fedora] Fedora Reporter: Anand Buddhdev <arb>
Component: avahiAssignee: Martin Bacovsky <mbacovsk>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: belfrancis2001, djuran, jantho, k3dzngrp8w2xtc9, petrosyan, rc040203, robatino, roffe.moshe, torsten.rausche
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: avahi-0.6.16-2.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-07 15:48:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Anand Buddhdev 2006-12-11 22:39:57 UTC
Description of problem:

dbus-daemon produces the error 'Unknown group "netdev" in message bus configuration file' upon 
startup.

Version-Release number of selected component (if applicable):

avahi-0.6.15-1.fc6

How reproducible:

Always

Steps to Reproduce:
1. Update an FC6 system to avahi 0.6.15-1.fc6
2. Restart messagebus, viz: service messagebus restart
  
Actual results:

An error message is produced, as stated in the description.

Expected results:

No error message should be produced.

Additional info:

Comment 1 Jan-Thomas Czornack 2006-12-12 09:09:53 UTC
I can confirm this bug. FC6, latest avahi update.

Comment 2 Bastien Nocera 2006-12-18 17:06:07 UTC
*** Bug 219764 has been marked as a duplicate of this bug. ***

Comment 3 Bastien Nocera 2006-12-18 17:07:55 UTC
*** Bug 219269 has been marked as a duplicate of this bug. ***

Comment 4 John (J5) Palmieri 2006-12-19 17:41:24 UTC
*** Bug 220204 has been marked as a duplicate of this bug. ***

Comment 5 John (J5) Palmieri 2006-12-19 17:45:05 UTC
*** Bug 219991 has been marked as a duplicate of this bug. ***

Comment 6 John (J5) Palmieri 2006-12-19 18:03:48 UTC
I can't find the bug I reassigned to avahi which describes the issue here. 
Basicly avahi's D-Bus security policy has a debianism which appeared in the
latest upstream tarballs.  The netdev user is part of debians way of restricting
user access.  In the future we will most likely use PolicyKit but for now
console user and root access seem the way to go.


Comment 7 Martin Bacovsky 2007-01-07 15:48:38 UTC
This bug should be fixed in avahi-0.6.16.

Comment 8 Torsten Rausche 2007-01-08 12:42:01 UTC
An update to avahi-0.6.16-1.fc6 does not seem to fix it for me.

Comment 9 Jérôme Benoit 2007-01-16 15:33:11 UTC
Latest update do not fix it for me too, only happens on my x86_64 box. My two
x86 do not seems do be "affected" anymore.

Thks

Comment 10 Martin Bacovsky 2007-01-16 16:08:49 UTC
Ok, now that really should be fixed (avahi-0.6.16-2.fc6). If you still have
troubles, let me know.

Comment 11 Michal Jaegermann 2007-01-17 21:11:35 UTC
What about bug 218140, which is really the same bug as this one but
for "devel", and still lingers as NEW and avahi there still not fixed?

Comment 12 Martin Bacovsky 2007-01-18 09:49:10 UTC
I know about that bug. I hope I will have a little time in the next few days to
fix that along with upgrade to upstream 0.6.16.

Comment 13 Martin Bacovsky 2007-01-18 16:14:47 UTC
*** Bug 222790 has been marked as a duplicate of this bug. ***