This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 512944

Summary: fast-user-switching locks up login screen
Product: [Fedora] Fedora Reporter: Edwin ten Brink <fedora>
Component: gdmAssignee: jmccann
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: andreas, aquarichy, awilliam, benjavalero, bruno, caiqian, craftjml, cschalle, drees76, dwmw2, evlyons, fedora, gene-redhat, jmccann, luinnar, mclasen, nate.tade, peterbloomfield, ploujj, rstrode, rxguyrx, theo148, tsalacinski
Target Milestone: ---Keywords: Desktop
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: NeedsRetesting
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-01 23:40:47 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
What the login screen looks like when fast-user-switching locks up none

Description Edwin ten Brink 2009-07-21 08:59:32 EDT
Description of problem:
When switching back and forth between two users, the login screen becomes locked-up.


Version-Release number of selected component (if applicable):
$ rpm -q --whatprovides fast-user-switch-applet
gdm-user-switch-applet-2.26.1-12.fc11.i586


How reproducible:
Always.


Steps to Reproduce:
1. Reboot
2. Log in as user A.
3. Switch to user B (new login).
4. Switch to user A.
5. Switch to user B.
6. Switch to... (locks up)


Actual results:
Login screen is locked up.


Expected results:
Possibility to login again as user A (or B, C, ...) again.


Additional info:
-
Comment 1 Jud Craft 2009-08-16 23:47:55 EDT
I'll second this bug.

F11, current updates.

I've made two accounts -- one for home and one for school -- and I've noticed this myself while switching back and forth between them.

Note that I can still switch between the accounts with the Virtual Terminal Shortcuts Ctrl-Alt-F7, F8, etc.  But directly clicking "Switch User" in the user-applet or switching to the GDM virtual terminal will both dump you to a frozen screen, where GDM sits braindead as the busy-cursor ticks.

This happens after about the fourth or fifth user-switch.  It doesn't take long.

Haven't worked out the exact steps to duplicate this, but the point is, fast-user-switching isn't very resilient at all, and for a casual "What the heck is a virtual terminal?" user, this means user-switching is essentially a ticking bomb to "my computer locked up."
Comment 2 David Rees 2009-08-30 22:13:55 EDT
This also affects me.  FWIW, I've got an ATI video card and am using the radeon driver.  Not sure what the other guys above are using.

Fast-user-switching was rock solid in Fedora 10.  Not sure what happened in Fedora 11, but after switching back and forth a couple times and/or logging out of one account and trying to then switch users, the login screen locks up as the others describe with the mouse cursor busy and the UI elements greyed out.

The only way I've found to get fast-user-switching again is to reboot.

If you log out of all sessions you can log in one user again, but can't fast-user-switch.

Very annoying to have to press one of the Ctrl-Alt-F keys to try to get back to a usable screen.  I agree that it would cause most users to think that the computer locked up.
Comment 3 David Rees 2009-08-30 22:15:57 EDT
Created attachment 359220 [details]
What the login screen looks like when fast-user-switching locks up
Comment 4 Jud Craft 2009-09-02 16:52:06 EDT
Yes, that's exactly what it looks like for me.

I'm running an Intel 965GM.

While testing this I also noticed bug #517772, which I also think is pretty bad.
Comment 5 David Rees 2009-09-02 18:24:08 EDT
Jud, have you hammered out a reproducible test case?  Edwin ten Brink's steps don't work for me.  I worked on it for a bit but haven't come up with a minimalist step-by-step test case yet.

Seems to be triggered by signing two people on, signing one out and signing on again and then switching users again, but ran out of patience before I had it down pat.  Will try again later...
Comment 6 Jud Craft 2009-09-02 18:35:52 EDT
I can try to get it down to a science, but need time.  Trying not to fail school at the moment.  Maybe this weekend.
Comment 7 Jud Craft 2009-09-02 18:47:59 EDT
I just tried it to procrastinate.

It actually works just like Edwin's steps.

1.  Log in A.
2.  Switch.  Go log in to B.
3.  Switch.  Go to A.
4.  Switch...

And then the screen freezes up.

No virtual-terminal switching required, just the "Switch User" menu from user-applet.  Works just about every darn time.

I did notice, however...

VT-switching back to A (using Ctrl-Alt-F1) hangs for a second, then suddenly I am dumped back to a working GDM, with User A logged out.

Logging back in to User A moves me to a new VT after User B.  (So if Ctrl-Alt-F1 was Old A, and Alt-F7 is B, and F7 is GDM, then after the GDM-freeze,VT 1,dump to good GDM, the new User A is placed on the next virtual terminal after GDM (F9, I guess).

The terminal on F1 is now abandoned with a black console screen.  Very odd

Not sure if the "auto-logging out of A" means anything to you.  At any rate, if you just loop-switch between two accounts, it inevitably happens for me after the third switch.
Comment 8 David Rees 2009-09-03 02:29:40 EDT
Hmm, I still can't reliably reproduce it.  I had this sequence do it a couple times, but not always:

1. Log in A.
2. Switch, log in B.
3. Switch to A.
4. Log out A.
5. Switch to B.
6. Switch, hang.

Confirmed that you never seem get back on VT1 after logging on there.

Confirmed that occasionally you'll get dumped to a blank VT after some logouts as well.
Comment 9 Adam Williamson 2009-10-21 13:35:33 EDT
*** Bug 522943 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2009-10-21 13:35:50 EDT
*** Bug 518792 has been marked as a duplicate of this bug. ***
Comment 11 Adam Williamson 2009-10-21 13:36:09 EDT
*** Bug 523208 has been marked as a duplicate of this bug. ***
Comment 12 Adam Williamson 2009-10-21 13:36:42 EDT
*** Bug 493492 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2009-10-21 13:36:51 EDT
*** Bug 522182 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2009-10-21 13:41:21 EDT
*** Bug 522550 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2009-10-21 13:43:44 EDT
as should be obvious from the dupe notifications, we have received quite a lot of reports of this problem. :) it appears to be a bug either in f-u-s-a or in gdm itself. it's been observed affecting all major graphics hardware types, intel nvidia *and* ati, so it doesn't seem to be hardware-related.

accepted as a blocker for f12. adding gdm maintainers to CC.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 nate 2009-10-21 17:19:06 EDT
I am unable to even login to another account using fast-user-switching. After GDM prompts for password I see the desktop background but both gnomepanels (top and bottom) fail to load and mouse clicks don't register (though I can see and move the mouse arrow). After switching back to my account using function keys and then attempting to switch to second account again I get a frozen unlock screen. 

Once I have logged out of any given account I can log in to any other account with problems, but the user switching issue remains.

I have this problem on a dell quad intel with radeon open source drivers installed from F11 DVD, but not on a dell intel Centrino with built in intel graphics.
Comment 17 Matthias Clasen 2009-10-21 18:51:48 EDT
If we accept this as an f12 blocker, we should fix up the bug a bit.
we are no longer using fast-user-switch-applet (and we haven't in F11 either...)
Comment 18 Jud Craft 2009-10-21 19:04:31 EDT
You mean user-switch-applet isn't the same as fast-user-switch-applet?

If so...when was someone gonna say something?  :)
Comment 19 Adam Williamson 2009-10-21 19:05:53 EDT
matthias: thanks, I'd managed to miss that change :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Matthias Clasen 2009-10-21 19:40:38 EDT
Yeah, sorry for not spotting this earlier. 

fast-user-switch-applet was a standalone package in the gnome 2.20-2.24 (?) era.
the user switch applet we are using in F11 and F12 is part of the gdm package.
Comment 21 Tomasz Sałaciński 2009-10-27 05:44:47 EDT
Usually, when GDM hangs, the window is gray. I've seen once when the window had it contents, that it's the same window just before user logs in (when you enter the password the password field collapse and all gtkwidgets go to insensitive state). So it seems it just have problems getting back to the user selection (the main login) screen. Hope this helps.
Comment 22 Dale Turner 2009-10-28 00:30:43 EDT
I am using Fedora 11. I have 2 user accounts: 1 for me and 1 for the kids. This problem has proven to be problematic. I have removed the user-switch-applet ( yum erase ) ans still get this problem when switching users. 

Here is what I do. I Ctrl-Alt-F2 and log in as root. Then type ' ps -A | grep tty ' to find the process associated with the problematic screen (usually tty8 and it is Xorg). I then kill the process, which allows me to switch users at least one more time. If you kill the gdm itself, you lose all GNOME sessions.

Asnoted above, this problem has been reported repeatedly. See bugs 484829, 518642, 527920, etc. Also this is reported in other distros, eg http://ubuntuforums.org/archive/index.php/t-806566.html

Some of these other bug reports are looking at Xorg logs etc. So what do we do to solve this? Is anyone looking at this? Is it a gdm problem, an Xorg problem, a video driver problem?? (NVIDIA for me) I find this to be terribly annoying. I'm not good enough with linux to know how to proceed. What can I do to help this??

Sorry for the rant. Just frustrated.

I would like to install SLIM to test the gdm theory, but i get trouble with SELinux.

I was hoping this was going to be resolved with 12 beta, but according to the bugzilla, this is not the case.
Comment 23 Ray Strode [halfline] 2009-10-28 12:58:18 EDT
Can you guys give -13 a go?
Comment 24 Adam Williamson 2009-10-28 16:37:13 EDT
that's gdm-2.28.1-13 . You can get 2.28.1-14 (with an extra, unrelated change) here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=138771

remember to update *all* of the gdm packages you have installed to the -14 versions from that page (so update at least both gdm and gdm-user-switch-applet , and the fingerprint and smartcard plugins if you have them installed).

please try it out and let us know how it goes.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Adam Williamson 2009-10-30 13:25:25 EDT
Ping - this is on the F12 blocker list and we need to have all blockers resolved by next Wednesday at the very latest, so it'd great if as many people as possible could test this soon.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Bruno Wolff III 2009-10-30 14:35:49 EDT
I have done a few user switches since the double free gdm fix and haven't seen it reoccur yet (though I did discover a bug with xguest I'll be reporting shortly).
I don't think I have done enough yet to feel confident it is gone.
Comment 27 Gene Stuckey 2009-10-30 14:43:43 EDT
I'm no longer seeing the issue since updating to 2.28.1-14.
Comment 28 David Rees 2009-10-30 14:48:40 EDT
Is there a patch/build for F-11 where the bug is also present?
Comment 29 Ray Strode [halfline] 2009-10-30 17:19:15 EDT
I threw one off here: 

Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=1779701
Comment 30 Ray Strode [halfline] 2009-10-30 17:23:51 EDT
(if you verify it i'll push an update)
Comment 31 David Rees 2009-10-30 17:41:49 EDT
Thanks - I'll give it a shot but it will take a while to verify as it's not easily reproducible.
Comment 32 Adam Williamson 2009-10-31 01:05:42 EDT
i'll keep monitoring this through mon/tues next week, so keep posting test results. thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 33 Dale Turner 2009-11-01 00:50:15 EDT
So far, so good. Seems to be working for me (Ferdora 11).
Comment 34 Edwin ten Brink 2009-11-01 14:15:16 EST
(In reply to comment #30)
> (if you verify it i'll push an update)  

My original case of comment #0 is no longer reproducible with
gdm-user-switch-applet-2.26.1-14.fc11.i586.rpm
It used to be 100% reproducible on my machine.

However, during many switch-overs between two users I managed, in various not-easy-to-reproduce circumstances, to get:
- user B logged off when only switching from B to A
- a black screen again (which could be recovered by ctr-alt-f7 and/or -f9)
- the user session crashing only to show bug-buddy for a second and then closing 
- a reproduction of bug 517772

IMHO, fast-user-switching is not all that stable or reliable, but at least this update does not seem to worsen the problem.
Comment 35 Jud Craft 2009-11-01 22:57:01 EST
I concur on #517772.  Somebody's gonna have to work that one out.  Glad they fixed this one, though.

For the moment, fast-user switching is a bit of a hassle.  It works decently [as a feature preview], but not flawlessly [production-level].
Comment 36 Adam Williamson 2009-11-01 23:40:47 EST
The feedback seems to suggest we should be able to close this now. Please if anyone still has trouble with this, let us know. Thanks for all the testing, guys.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 37 Earle Lyons 2010-06-06 15:59:28 EDT
This problem still seems to be in existence on Fedora 13. In fact, upgraded from Fedora 12 to Fedora 13 in hopes that this was problem was corrected. 

Is there a new case open on this issue to track?

Here is my information based on the original posting information.
--
I need to be able to switch between users because multiple people use the same computer.

Problem:
When switching back and forth between two users, the login screen becomes
locked-up (black screen, no response).


Version-Release number of selected component (if applicable):
$ rpm -q --whatprovides fast-user-switch-applet
gdm-user-switch-applet-2.30.2-1.fc13.i686

How reproducible:
Always.


Steps to Reproduce:
1. Reboot
2. Log in as user A.
3. Switch to user B (new login).
4. Switch to user A.
5. Switch to user B.
6. Switch to... (locks up)


Actual results:
Login screen is locked up (black screen, no response).


Expected results:
Possibility to login again as user A (or B, C, ...) again.
Comment 38 Earle Lyons 2010-06-27 18:42:50 EDT
Opened Bug 601444 - fast-user-switching locks up login screen for the same issue.