Bug 539768

Summary: KDE Launcher causes desktop to freeze for ~10 seconds (nouveau with UMS)
Product: [Fedora] Fedora Reporter: Mark Bidewell <mark.bidewell>
Component: xorg-x11-serverAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 12CC: airlied, alekcejk, aplattner, awilliam, cfeller, eqisow, fedora, george.seaton, gerwinkrist, jarin.franek, jlaska, jost, jreznik, kevin, laurent.rineau__fedora, lorenzo, ltinkl, luhe, martin.nad89, mathstuf, maxiberta, mefoster, mvanross, rdieter, redhat, rhel, richard.colley, rmj, ronin3510, serge, smparrish, speed47_redhat, than, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 533620 Environment:
Last Closed: 2009-11-24 15:44:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
one proposed fix from nvidia none

Description Mark Bidewell 2009-11-21 00:49:57 UTC
+++ This bug was initially created as a clone of Bug #533620 +++

Description of problem: When clicking the KDE launcher the entire screen freezes for about 10 seconds.


Version-Release number of selected component (if applicable): kdebase-workspace-4.3.2-1.fc12.x86_64


How reproducible: Problem should exists with a default KDE install, as far as I know.


Additional info: The issue was not present in Fedora 11 before upgrading. Additionally, the "classic" launcher seems to work fine.

--- Additional comment from kevin@tigcc.ticalc.org on 2009-11-07 17:38:25 EDT ---

What video driver?

--- Additional comment from eqisow@gmail.com on 2009-11-07 17:46:39 EDT ---

nvidia-190.42 (binary driver)

The problem also now seems to occur when I launch Konsole and at other odd moments. When i launch konsole from the console I get the following message:

"Undecodable sequence: \001b(hex)[?1034h"

--- Additional comment from kevin@tigcc.ticalc.org on 2009-11-07 18:11:40 EDT ---

Must be the same issue discussed on the mailing list then. It's a nvidia driver issue, as switching to Nouveau reportedly fixes it. Please report this issue to NVidia, they're the only ones who can fix it.

--- Additional comment from eqisow@gmail.com on 2009-11-07 20:00:07 EDT ---

I did some additional testing and the "undecodable sequence" error persists across drivers. However, the freezing does not.

Also, the freezing disappears from Konsole if compositing is disabled, but the launcher freezing persists whether compositing is on or off.

Since no other driver supports 3D on my system, I would appreciate it if somebody could report on their experience with KDE in this area with another driver that support 3D and compositing before the bug is dismissed as a driver issue.

--- Additional comment from rdieter@math.unl.edu on 2009-11-07 23:45:55 EDT ---

Seems not fedora-specific either,
http://bugs.archlinux.org/task/17037

xorg-1.7.1 + nvidia driver + kde = slow/badness.

--- Additional comment from eqisow@gmail.com on 2009-11-07 23:59:29 EDT ---

Hmm, there's this comment on that Arch bug report:

"Without the new fedora patch, it works OK.
WITH the fedora patch, huge lag on KDE4. It should be removed."

That is in reference to Xorg. Maybe this is actually an issue w/ a Fedora Xorg patch?

--- Additional comment from rdieter@math.unl.edu on 2009-11-08 00:23:34 EDT ---

Too bad the arch report doesn't mention what fedora patch they're talking about.

Anyway, here includes a possible workaround,
http://forums.fedoraforum.org/showthread.php?t=233443

--- Additional comment from eqisow@gmail.com on 2009-11-08 00:26:40 EDT ---

It sort of does:

"BUT - if I apply only the first part of the Patch - which is:
- pPixmap = (*pScreen->CreatePixmap) (pScreen, width, height, pDraw->depth, 0);
+ pPixmap = fbCreatePixmap (pScreen, width, height, pDraw->depth, 0);"

That may be enough to pinpoint the patch?

--- Additional comment from eqisow@gmail.com on 2009-11-08 00:37:59 EDT ---

Also, that workaround (Option "UseEvents") doesn't work for me as either "True" or "False".

--- Additional comment from rdieter@math.unl.edu on 2009-11-08 01:52:05 EDT ---

That's part of
xserver-1.7.1-window-pictures.patch

re-assigning for comment/triage from x maintainers.

--- Additional comment from rdieter@math.unl.edu on 2009-11-08 17:24:00 EDT ---

fwiw, the origin of that patch seems to come from bug #533236

--- Additional comment from richard.colley@rcolley.com on 2009-11-08 17:36:56 EDT ---

no problems on my 32bit system.  all reported cases seem to be on 64bit systems.

--- Additional comment from awilliam@redhat.com on 2009-11-08 18:17:39 EDT ---

xserver-1.7.1-window-pictures.patch is the only patch Arch took (I checked their RCS).

Dave Airlie is aware of this, he has forwarded the patch to NVIDIA so they can fix their driver. The patch doesn't do anything wrong, slowness indicates the NVIDIA driver is doing something bad (wouldn't be the first time).

If anyone can reproduce this with a *clean* Fedora 12 config using nouveau _not NVIDIA_, that would be a much higher priority issue.

I have a scratch build of xorg-x11-server which is exactly the same as -7 but drops the patch in question up here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1794560

anyone who really needs to use F12+KDE+NVIDIA can go with that X server build for now. I'll document this on CommonBugs before release.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from eqisow@gmail.com on 2009-11-08 19:40:50 EDT ---

I can confirm that the above package fixes the problem for me. Good stuff!

--- Additional comment from mcepl@redhat.com on 2009-11-09 06:07:02 EDT ---

Thank you for letting us know.

--- Additional comment from rdieter@math.unl.edu on 2009-11-09 08:40:08 EDT ---

*** Bug 533805 has been marked as a duplicate of this bug. ***

--- Additional comment from awilliam@redhat.com on 2009-11-09 12:09:09 EDT ---

matej: um. 'the above package' doesn't correspond to 'CLOSED RAWHIDE' because it's just a scratch build for NVIDIA users to work around this problem, it's never going to go into a repo anywhere. We could close this as CANTFIX since it's a bug in NVIDIA proprietary driver, but not RAWHIDE.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from kevin@tigcc.ticalc.org on 2009-11-09 14:21:41 EDT ---

Reopening as it's clearly not fixed in Rawhide. I'd go for CANTFIX.

--- Additional comment from mvanross@inf.ed.ac.uk on 2009-11-09 20:29:21 EDT ---

But with the updated rpms, 
ghostview and gwenview now bring down X on my system!

Can someone else check as well?

NVIDIA 190.42, FX570M, i686


(uninformative) Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e587c]
1: /usr/bin/Xorg (0x8048000+0x5eb66) [0x80a6b66]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0x78240c]
3: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x101a000+0x964d5) [0x10b04d5]
Segmentation fault at address 0xa8416248

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

--- Additional comment from mvanross@inf.ed.ac.uk on 2009-11-09 20:32:21 EDT ---

(In reply to comment #12)
> no problems on my 32bit system.  all reported cases seem to be on 64bit
> systems.  

My 32bit does show the bug....

--- Additional comment from eqisow@gmail.com on 2009-11-09 23:10:33 EDT ---

No problems with gwenview here. I just opened it and looked at a few pictures.

--- Additional comment from mvanross@inf.ed.ac.uk on 2009-11-10 06:30:18 EDT ---

(In reply to comment #19)
> But with the updated rpms, 
> ghostview and gwenview now bring down X on my system!
> 
> Can someone else check as well?
> 
> NVIDIA 190.42, FX570M, i686
> 
> 
> (uninformative) Backtrace:
> 0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e587c]
> 1: /usr/bin/Xorg (0x8048000+0x5eb66) [0x80a6b66]
> 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x78240c]
> 3: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x101a000+0x964d5) [0x10b04d5]
> Segmentation fault at address 0xa8416248
> 
> Fatal server error:
> Caught signal 11 (Segmentation fault). Server aborting  

TO be more precise: only happens when trying to view postscript.h

--- Additional comment from awilliam@redhat.com on 2009-11-10 11:10:43 EDT ---

It's not too helpful to discuss issues in the proprietary driver here, as we're not going to fix it. :) The best place would probably be the Linux forum at nvnews.net, which is a sort-of semi-official NVIDIA driver support forum, NVIDIA employees monitor it.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from jlaska@redhat.com on 2009-11-11 15:01:05 EDT ---

Tagging for addition to the CommonBugs page

--- Additional comment from rdieter@math.unl.edu on 2009-11-12 10:55:32 EDT ---

*** Bug 537008 has been marked as a duplicate of this bug. ***

--- Additional comment from rmj@ast.cam.ac.uk on 2009-11-16 07:15:59 EDT ---

Sorry, but I can't see how to get the rpms referred to in #13. Can someone tell me please?

--- Additional comment from mefoster@gmail.com on 2009-11-16 10:22:50 EDT ---

I'm also seeing similar symptoms on an Acer TravelMate 8100 laptop with an ATI X700 radeon mobility graphics card (using the free "radeon" driver), but seemingly only when a second monitor is plugged in. So it might not be just an nVidia problem ...

--- Additional comment from kevin@tigcc.ticalc.org on 2009-11-16 12:28:42 EDT ---

Scratch builds are automatically deleted after a week or two. The build output needs to be uploaded somewhere else if it should be permanent (and if nobody saved it, another scratch build has to be submitted first).

--- Additional comment from rmj@ast.cam.ac.uk on 2009-11-16 15:49:36 EDT ---

Kevin: Thanks for the explanation

Adam: Can you resubmit the build please or let me know where a copy was saved?

--- Additional comment from awilliam@redhat.com on 2009-11-16 21:14:24 EDT ---

will do in a bit.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from awilliam@redhat.com on 2009-11-16 21:15:18 EDT ---

mary, that's almost certainly an entirely different problem. please file a new bug if you can provide a concrete reproduction scenario.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from rdieter@math.unl.edu on 2009-11-17 14:54:13 EDT ---

Here's a fresh scratch build like in comment #13 (which got garbage collected).

http://koji.fedoraproject.org/koji/taskinfo?taskID=1812916

when it's done, I'll put it up in a repo somewhere for posterity.

--- Additional comment from rmj@ast.cam.ac.uk on 2009-11-17 15:28:45 EDT ---

Thanks Rex.

--- Additional comment from rdieter@math.unl.edu on 2009-11-17 15:31:14 EDT ---

OK, as threatened,
http://rdieter.fedorapeople.org/repo/

--- Additional comment from kevin@tigcc.ticalc.org on 2009-11-18 03:30:56 EDT ---

*** Bug 538275 has been marked as a duplicate of this bug. ***

--- Additional comment from mefoster@gmail.com on 2009-11-18 04:48:34 EDT ---

For future reference, here's the contents of my /etc/yum.repos.d/rdieter.repo -- I created this file, did a "yum update", restarted X, and now menus are opening as expected. Thanks, Rex! :)

[rdieter]
name=xorg-x11-server rebuilds for nvidia users
baseurl=http://rdieter.fedorapeople.org/repo/fedora/$releasever/$basearch/
enabled=1
gpgcheck=0

--- Additional comment from mefoster@gmail.com on 2009-11-18 05:20:12 EDT ---

(In reply to comment #31)
> mary, that's almost certainly an entirely different problem. please file a new
> bug if you can provide a concrete reproduction scenario.

["that" is the same symptoms on a laptop using the free ATI drivers, but only in dual-head mode]

No, actually, I think it is another manifestation of the same problem. At least, installing rdieter's Xorg packages on the laptop in question also fixed the issue there too.

--- Additional comment from mathstuf@gmail.com on 2009-11-18 09:26:03 EDT ---

*** Bug 538344 has been marked as a duplicate of this bug. ***

--- Additional comment from redhat@stefan-neufeind.de on 2009-11-18 13:28:23 EDT ---

Rex, your packages also solved that problem for me. But it's been mentioned the bugfix itself is okay that's only a preliminary solution until nvidia fixes their driver it seems :-(

--- Additional comment from awilliam@redhat.com on 2009-11-18 18:37:38 EDT ---

Mary, no, it really isn't. The bug here is that NVIDIA's proprietary driver does not work properly with a patch added to our X server package. It sounds like the driver you're running, on the system you're using, also has problems with the patch in question - but that STILL means it's a separate bug.

Please file it separately, against the radeon driver.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from awilliam@redhat.com on 2009-11-18 18:55:29 EDT ---

stefan, yes, this is a workaround not a fix. we can't ship the package with the disabled patch to everyone, as the patch is valid and fixes other problems.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from rdieter@math.unl.edu on 2009-11-19 10:15:47 EDT ---

(filed by nvidia,) documenting xorg upstream bug,
https://bugs.freedesktop.org/show_bug.cgi?id=25136

--- Additional comment from jarin.franek@post.cz on 2009-11-20 14:14:09 EDT ---

Sorry to spam closed bug, but I have kinda reproduced it on fresh installation of Fedora 12 with nouveau driver (having nvidia GT130 card with 768MB memory):

[franekj@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.31.6-134.fc12.x86_64 #1 SMP Mon Nov 16 20:38:45 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

[franekj@localhost ~]$ lsmod | grep nouveau
nouveau               544292  1
ttm                    41952  1 nouveau
drm_kms_helper         25376  1 nouveau
drm                   171296  4 nouveau,ttm,drm_kms_helper
i2c_algo_bit            6020  1 nouveau
i2c_core               28608  4 i2c_i801,nouveau,drm,i2c_algo_bit

When I e.g. click the (F) icon on the main panel, the desktop gets frozen for 4-5 seconds until the start menu appears.

Previously on Fedora 11 it was working without any such delay using nouveau as well. Now with Fedora 12, many operations regarding the KDE main panel exhibit the long waits (start menu, plazma button + settings bar, callendar, ...). On the other hand, the plazma button at the right-upper corner of the desktop works instantaneously.

--- Additional comment from awilliam@redhat.com on 2009-11-20 16:29:16 EDT ---

are you sure this is a clean installation? it's not an upgrade that has bits of the proprietary driver (e.g. NVIDIA's libgl stuff) lying around?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from jarin.franek@post.cz on 2009-11-20 16:43:49 EDT ---

Yes, very sure. I sacrificed Fedora 11 installation to perform a clean Fedora 12 installation, NO upgrade, the disk was reformatted. And definitely there never was proprietary nvidia driver installed, neither in Fedora 11, neither in Fedora 12.

Comment 1 Mark Bidewell 2009-11-21 00:51:55 UTC
I am cloning this bug to reopen the issue since I can reproduce it with the nouveau driver by disabling KMS.  Geforce 8600GTS

Comment 2 Adam Williamson 2009-11-21 16:23:15 UTC
then we don't care very much, as UMS is on the deprecation train. but this is therefore likely related to upstream https://bugs.freedesktop.org/show_bug.cgi?id=25136 ...

(next time you do this, please don't clone all the comments, it makes a horrible mess.)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Jaroslav Franek 2009-11-21 18:37:34 UTC
Sorry, but you should not tell your users (and free testers at the same time) that you do not care much about their problems. We are using UMS for a reason.

For a record, I use nomodeset (i.e. UMS), too, and only under UMS the KDE delay is experienced. But I have a little choice: The KMS on nouveau is not yet _there_. Under KMS the text on the screen is looking like distorted gibberish, beyond recognition. The only way for me to use F12 is to go with UMS for time being.

Comment 4 Adam Williamson 2009-11-21 18:55:55 UTC
we care about the problem you have with KMS more than the problem you have with UMS, is the point :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Rex Dieter 2009-11-21 20:05:29 UTC
Created attachment 372790 [details]
one proposed fix from nvidia

Here's a scratch build containing the aforementioned patch,
http://koji.fedoraproject.org/koji/taskinfo?taskID=1821848

Comment 6 Gerwin Krist 2009-11-21 20:31:02 UTC
The build of from #5 does work for me. The speeds are oke again (although desktop effects can't be enabled, which could be totally unrelated anyways).

Comment 7 Jaroslav Franek 2009-11-21 20:37:03 UTC
Tested the rpms from the scratch build:

xorg-x11-server-common-1.7.1-7.fc12.2.rex.x86_64.rpm
xorg-x11-server-Xorg-1.7.1-7.fc12.2.rex.x86_64.rpm

I am happy user again :-) The annoying delay under UMS is no more. F11 speed was restored. Thank you.

As for the image distortion under KMS, I have created another Bug #539975.

Comment 8 nucleo 2009-11-21 20:51:52 UTC
No delay with this builds of xorg-x11-server:

xorg-x11-server-common-1.7.1-7.fc12.2.rex.i686
xorg-x11-server-Xorg-1.7.1-7.fc12.2.rex.i686

I am using this nvidia drivers:

kmod-nvidia-2.6.31.5-127.fc12.i686.PAE-190.42-1.fc12.4.i686
kmod-nvidia-PAE-190.42-1.fc12.4.i686
xorg-x11-drv-nvidia-190.42-2.fc12.i686
xorg-x11-drv-nvidia-libs-190.42-2.fc12.i686

Comment 9 Adam Williamson 2009-11-23 19:48:51 UTC
anyone using the proprietary driver please post on the ORIGINAL bug, #533620, not here. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Adam Williamson 2009-11-23 19:53:49 UTC
To recap, for clarity (posting this to all three bugs): we have three bugs for this issue at present, as they manifested with different drivers and hardware.

Bug #533620 is the initial bug, considered to refer to using the NVIDIA proprietary driver. Bug #538836 is for a case affecting users of the 'radeon' driver for ATI/AMD cards in a dual-head configuration. And Bug #539768 is for a case affecting the free 'nouveau' driver for NVIDIA hardware with kernel modesetting disabled.

If the proposed scratch build appears to fix all three types, I'll re-combine them into bug 533620, as it would then be considered a bug in the X server addressed by the proposed patch in the scratch build (from NVIDIA).

Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Mark Bidewell 2009-11-23 20:53:35 UTC
I can confirm that the Koji builds seem to correct the nouveau+UMS case

Comment 12 Adam Williamson 2009-11-24 15:44:28 UTC
since the initial reporter of this offshoot says the scratch build works, let's merge this one back into 533620.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 533620 ***