Bug 563526

Summary: DeviceError: ('cannot replace active format', 'vda4')
Product: Red Hat Enterprise Linux 6 Reporter: Marian Ganisin <mganisin>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED CURRENTRELEASE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: alan.ernhart, atodorov, bdwheele, ckannan, felix.kuehling, frank.arnold, hoffmann, jburke, jfrieben, jstodola, luugi.marsan, mgordon, pholica, quintela, rdoty, tao, twoerner, vgoyal
Target Milestone: rc   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: anaconda_trace_hash:02b1138f15e8a5ac1f6e134bb9afaf4e05a7421d95027b8c1bfbc30735e8fe74
Fixed In Version: anaconda-13.21.24-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586985 (view as bug list) Environment:
Last Closed: 2010-11-10 19:39:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 582286, 586985    
Attachments:
Description Flags
Attached traceback automatically from anaconda.
none
Anaconda traceback none

Description Marian Ganisin 2010-02-10 14:13:48 UTC
The following was filed automatically by anaconda:
anaconda 13.21.10 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1170, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/__init__.py", line 782, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/anaconda/storage/partitioning.py", line 385, in removeEmptyExtendedPartitions
    storage.destroyDevice(extended)
  File "/usr/lib/anaconda/storage/partitioning.py", line 373, in clearPartitions
    removeEmptyExtendedPartitions(storage)
  File "/usr/lib/anaconda/storage/partitioning.py", line 184, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1396, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1309, in nextClicked
    self.setScreen ()
DeviceError: ('cannot replace active format', 'vda4')

Comment 1 Marian Ganisin 2010-02-10 14:13:51 UTC
Created attachment 389999 [details]
Attached traceback automatically from anaconda.

Comment 2 Marian Ganisin 2010-02-10 14:21:36 UTC
Reproducer: run default installation right after failure described in Bug 563523

Comment 3 RHEL Product and Program Management 2010-02-10 14:23:30 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Juan Quintela 2010-02-22 19:20:34 UTC
I have the same problem according to Dave.  attaching my anaconda-tb-* file.

The partitions on that machine are

Number  Start   End     Size   Type      File system  Flags
 1      32.3kB  206MB   206MB  primary   ext3         boot
 2      206MB   411MB   206MB  primary   ext3
 3      411MB   617MB   206MB  primary   ext3
 4      617MB   250GB   249GB  extended
 5      617MB   831MB   214MB  logical   ext3
 6      831MB   1036MB  206MB  logical   ext3
 7      1036MB  1242MB  206MB  logical   ext3
 8      1242MB  1448MB  206MB  logical   ext3
 9      1448MB  1653MB  206MB  logical   ext3
10      1653MB  1859MB  206MB  logical   ext3
11      1859MB  2065MB  206MB  logical   ext3
12      2065MB  2270MB  206MB  logical   ext3
13      2270MB  250GB   248GB  logical                lvm

And I am trying to install /boot on sda2 and / somewhere in the lvm.

Relevant part of kickstart:
part pv.15 --noformat --onpart sda13
volgroup mitica --noformat --useexisting pv.15
logvol /scratch --noformat --useexisting --fstype ext3 --name=scratch --vgname=mitica
logvol swap --noformat --useexisting --fstype swap --name=swap --vgname=mitica
logvol / --fstype ext4 --useexisting --name=root0 --vgname=mitica
part /boot --fstype ext4 --onpart sda2


I tried with both ext3/4, it makes no difference.

Comment 6 Juan Quintela 2010-02-22 19:22:57 UTC
Created attachment 395547 [details]
Anaconda traceback

Comment 7 Fedora Update System 2010-02-23 03:42:17 UTC
anaconda-13.29-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.29-1.fc13

Comment 8 Fedora Update System 2010-02-23 14:04:31 UTC
python-urlgrabber-3.9.1-5.fc13,anaconda-13.29-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-urlgrabber-3.9.1-5.fc13,anaconda-13.29-1.fc13

Comment 9 Juan Quintela 2010-02-23 17:42:41 UTC
Dlehman asked that I printed on the debugger:

(Pdb) print self.format.partedDisk
parted.Disk instance --
  type: msdos   primaryPartitionCount:0
  lastPartitionNumber: -1    maxPrymaryPartitionCount: 4
  partitions: []
  device: <parted.device.Device object at 0x7f748f763290>
  PedDisk: <_ped.Disk object at 0x7f748fb6fdd0>

(trace copied by hand)

Comment 10 Juan Quintela 2010-02-23 17:44:35 UTC
As a workaround, if you hit this error:

dd if=/dev/zero of=/dev/sda2 bs=1024 count=1000

fixed the issue for me (sda2 was the partition that was giving problems for me).

But issue is reproducible. You try to reinstall in the same partitions with the same kickstart file, and bug happens again.

Comment 11 Fedora Update System 2010-02-26 02:58:58 UTC
python-urlgrabber-3.9.1-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2688

Comment 12 Hans de Goede 2010-03-01 14:28:47 UTC
*** Bug 569357 has been marked as a duplicate of this bug. ***

Comment 13 Brock Organ 2010-03-12 20:12:22 UTC
*** Bug 572326 has been marked as a duplicate of this bug. ***

Comment 14 Alexander Todorov 2010-03-17 12:32:55 UTC
Same thing for me with the RAID10 test case:

05:53:40,965 CRITICAL: anaconda 13.21.20 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/partitioning.py", line 401, in removeEmptyExtendedPartitions
    destroy_action = ActionDestroyFormat(disk)
  File "/usr/lib/anaconda/storage/partitioning.py", line 373, in clearPartitions
    removeEmptyExtendedPartitions(storage)
  File "/usr/lib/anaconda/kickstart.py", line 301, in execute
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/kickstart.py", line 1086, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1035, in <module>
    ksdata.execute()
DeviceError: ('cannot replace active format', 'sdb')

Comment 16 David Lehman 2010-04-01 17:20:09 UTC
*** Bug 576829 has been marked as a duplicate of this bug. ***

Comment 18 David Lehman 2010-04-12 22:41:53 UTC
*** Bug 567312 has been marked as a duplicate of this bug. ***

Comment 19 David Lehman 2010-04-12 22:42:18 UTC
*** Bug 578588 has been marked as a duplicate of this bug. ***

Comment 20 David Lehman 2010-04-12 22:42:42 UTC
*** Bug 578748 has been marked as a duplicate of this bug. ***

Comment 21 Chris Lumens 2010-04-22 17:05:18 UTC
*** Bug 584817 has been marked as a duplicate of this bug. ***

Comment 22 Chris Lumens 2010-04-22 17:06:25 UTC
*** Bug 584839 has been marked as a duplicate of this bug. ***

Comment 23 Chris Lumens 2010-04-22 20:32:32 UTC
*** Bug 584973 has been marked as a duplicate of this bug. ***

Comment 25 Chris Lumens 2010-04-23 13:33:35 UTC
*** Bug 585103 has been marked as a duplicate of this bug. ***

Comment 26 Chris Lumens 2010-04-26 13:41:50 UTC
*** Bug 585909 has been marked as a duplicate of this bug. ***

Comment 30 Chris Lumens 2010-04-28 20:46:40 UTC
*** Bug 587090 has been marked as a duplicate of this bug. ***

Comment 33 David Cantrell 2010-06-16 18:42:52 UTC
*** Bug 595051 has been marked as a duplicate of this bug. ***

Comment 34 David Cantrell 2010-06-29 19:39:11 UTC
*** Bug 607795 has been marked as a duplicate of this bug. ***

Comment 37 releng-rhel@redhat.com 2010-11-10 19:39:34 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.