Bug 105767 - can't install any software from fedora CD's (test2)
can't install any software from fedora CD's (test2)
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: 100445 103556 105849 105947 107094 107397 108417 108925 109824 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
Reported: 2003-09-27 04:27 EDT by Henrik Lind
Modified: 2007-11-30 17:10 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-21 15:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Henrik Lind 2003-09-27 04:27:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After Installing Fedora test2 (new install) I can't install any software from
the 3 Fedora CDs.
The 'Add/remove program' can't find any of the CD's when I put them in my CD drive.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start the 'remove / add program' (danish 'Tilf�j eller fjern programmer'
2. Select something to install and push the install button.
3. The program now ask for a CD, put it in and push ok

Actual Results:  It ask me to put in the CD, even if it's allready in.

Expected Results:  Continue with the install of the software.

Additional info:

When you insert a CD, there comes a little CD icon on the desktop.
I can go into the CD and copy files and everything is fine.

But, if I push OK for the 'remove/add' program to try and read the CD, the icon
on the desktop disappear.
Comment 1 Bill Nottingham 2003-09-29 21:35:03 EDT
*** Bug 105849 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-09-29 21:35:29 EDT
*** Bug 105947 has been marked as a duplicate of this bug. ***
Comment 3 Jon Savage 2003-10-03 17:33:15 EDT
Installing add'l apps from CD using redhat-config-packages was working for me 
earlier this week.  It was not longer working for me yesterday (10-2-03) after 
I'd installed a plethora of updates from the Severn Beta 2 (i386) Updates 
channel. Wonder if there is a connection there?
Comment 4 Ossama Khayat 2003-10-06 04:45:53 EDT
Just to add a void here, this also doesn't work for me. It complains about not
finding the correct CD, although I insert it in the drive.
Also, NONE of the options work at all!
Comment 5 Christophe Jouny 2003-10-08 11:52:22 EDT
Same problem here. Unable to install anything from Severn CDs.

Plus, not sure if it is linked to it but when trying to start install from
command line (like autorun) it crashed :

/usr/bin/redhat-cdinstall-helper /mnt/cdrom/
* Arabic Support references package arabic-fonts which doesn't exist
* Base references package prctl which doesn't exist
* Core references package lilo which doesn't exist
* Core references package yaboot which doesn't exist
* Core references package efibootmgr which doesn't exist
* Core references package elilo which doesn't exist
* Core references package s390utils which doesn't exist
* Core references package ppc64-utils which doesn't exist
* SQL Database Server references package perl-DB_File which doesn't exist
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/InstallDruid.py", line 529, in ?
    druid.run ()
  File "/usr/share/redhat-config-packages/InstallDruid.py", line 464, in run
    self.do_system_info_state ()
  File "/usr/share/redhat-config-packages/InstallDruid.py", line 360, in
    self.screen = package_gui.PackageSelectionWindow()
TypeError: __init__() takes exactly 2 arguments (1 given)

Comment 6 Markku Kolkka 2003-10-14 11:44:56 EDT
The version in Fedora Core test3 is still broken in the same way.
Comment 7 Jeremy Katz 2003-10-14 11:56:09 EDT
What is the output of 'rpm -q redhat-config-packages comps'?
Comment 8 Braden McDaniel 2003-10-14 19:49:05 EDT
I'm seeing this, too. Output of 'rpm -q redhat-config-packages comps' is:

Comment 9 Mat 2003-10-15 15:38:15 EDT
I have noticed the following. When I insert a CD automount mounts the CD and
shows in the gnome desktop. If I then launch add/remove applications and choose
packages to install (in this case development tools) When it starts searchinf
for the required rpms the CD that I have inserted is unmounted despite been the
correct CD with the necessary rpm(s)! If I mount the CD manually with using
automount and click OK again it does the same thing. I guess it is not checking
what is already in the drive and when it does find a CD itis not checking it

Additionally the menu options dont seem to work. Such as Help - About, Help -
Manual, Edit - Preferences etc.. File _ Quit does work ;0)

rpm -qa | grep -i redhat-config-pa

Fedora Core release 0.95, Up2date as of now completely ;0)
Comment 10 Mat 2003-10-15 15:42:06 EDT
Sorry I meant mounting the CD manually without using automount as opposed to
with automount ;0)
Comment 11 Rick Wood 2003-10-20 16:01:15 EDT
Just loaded Fedora test 3, this bug is still present.
Comment 12 Jeremy Katz 2003-10-20 17:44:29 EDT
*** Bug 103556 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2003-10-20 17:44:43 EDT
*** Bug 100445 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2003-10-20 17:44:50 EDT
*** Bug 107397 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2003-10-20 17:45:24 EDT
*** Bug 107094 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2003-10-20 17:52:40 EDT
This should be fixed in 1.2.6, available from
http://people.redhat.com/~katzj/redhat-config-packages/ once the build finishes
and in rawhide tomorrow.
Comment 17 Jeremy Katz 2003-10-29 09:11:08 EST
*** Bug 108417 has been marked as a duplicate of this bug. ***
Comment 18 Jeremy Katz 2003-11-03 14:06:02 EST
*** Bug 108925 has been marked as a duplicate of this bug. ***
Comment 19 Ciobanu Alexander 2003-11-03 14:44:33 EST
Ok, 1.2.6 seemed to fix the problem  
Comment 20 Josiah Royse 2003-11-07 15:27:15 EST
This should be moved up to Fedora Core 1.0:

Running redhat-config-packages and selecting "vnc" to install, with
Fedora 1, disc 3 in the drive gives this error:

The file /mnt/cdrom/RedHat/RPMS/vnc-4.0-0.beta4.3.i386.rpm cannot be
opened. This is due to a missing file, a bad package, or bad media.
Press <return> to try again.

Here is the actual path on the CDROM:

Comment 21 Mariano Draghi 2003-11-12 09:25:18 EST
For me, the problem is in the /etc/fstab file. The function
getCdDevs() in method.py will ignore your device if the fstype field
in fstab is not one of ("iso9660", "udf,iso9660"). F.i. mine is set to
Y changed line 940 in method.py to something like

if fields[0] == "/dev/cdrom" or fields[0] == "/dev/dvd":

and it worked for me... but I know is not the best solution either...

There must be some better (i.e. GENERIC) way to do that... but I'm not
a "Python guru" ;)

Hope this help somebody else to come with a better solution.
Comment 22 Jeremy Katz 2003-11-12 09:39:06 EST
*** Bug 109824 has been marked as a duplicate of this bug. ***
Comment 23 Need Real Name 2003-11-17 16:30:38 EST
Problem still (again?) exists in redhat-config-packages-1.2.7-1

It will install from the CD which is currently in the drive, but 
after it asks you to change the disk, it will (I think) unmount the 
newly inserted disc and abort.
Comment 24 Sandip Bhattacharya 2003-11-18 16:05:45 EST
I found the problem in Red Hat 9. I updated redhat-config-packages to
1.2.7-1, and it crashed because of the dependency on a new module
"arch" in rhpl, updated rhpl to the one in fedora, and while the
dependency problem stopped the CD detection problem persisted.

WORKAROUND: I rummaged through the sources and found a work around:
Use this instead of redhat-config-packages:

python2 /usr/share/redhat-config-packages/InstallDruid.py


- Sandip

Comment 25 Sandip Bhattacharya 2003-11-18 17:12:01 EST
Ok. I found out the reason od my problem. Apparently the timestamp
line in the .discinfo file of the comps file is not matching the
timestamp of the .discinfo of my redhat-CDs. This is causing
redhat-config-packages to believe that the CDs are not the original ones.

So maybe the timestamp in comps should be updated if someone is using
some other build of redhat-9 or fedora or whatever. Or (a bad hack)
disable the line in methods.py which checks the timestamp in
redhatinstallmethod, if you are sure about the genuineness of the CD.

The second one worked for me.

- Sandip
Comment 26 Carmine 2004-06-04 15:11:33 EDT
a much easier way is to do the following:
insert the fedora core 2 cd disk 1

cd /
system-cdinstall-help /mnt/cdrom

the cd should now have launched
good luck
Comment 27 TehPropheT 2004-09-30 11:14:33 EDT
any fixes? i have fedora core 2 ... still have this problem

i find i have to install 1 package at a time :/
Comment 28 Ted Dargis 2004-10-22 13:48:21 EDT
Regarding #26 for Carmine:

Don't forget to spell it "helper":

cd /
system-cdinstall-helper /mnt/cdrom

The command is in /usr/bin

Comment 29 Marius Andreiana 2005-08-19 16:09:22 EDT
Does the version included in FC4 work?
Comment 30 Jeremy Katz 2005-09-21 15:14:02 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further information, feel free to
add to the report and reopen.

Note You need to log in before you can comment on or make changes to this bug.