Bug 115595 - (cpuspeed-error) cpuspeed message during system startup
cpuspeed message during system startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 115669 115720 116082 116130 117103 117356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 13:37 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 13:48:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpuspeed error message screen shot (64.35 KB, image/png)
2004-02-13 13:37 EST, Bernd Bartmann
no flags Details
cpuspeed initscript cleanup? (1.99 KB, patch)
2004-02-23 17:14 EST, Thomas M Steenholdt
no flags Details | Diff
patch2 (requires the first patch to be applied first) (763 bytes, patch)
2004-02-24 15:44 EST, Thomas M Steenholdt
no flags Details | Diff
last patch for the cpuspeed initscript (hopefully) (1.89 KB, patch)
2004-02-25 04:06 EST, Thomas M Steenholdt
no flags Details | Diff

  None (edit)
Description Bernd Bartmann 2004-02-13 13:37:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
During system startup I get get an error message referring to a
problem with cpuspeed. Please have a look at the attached screenshot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Watch the system startup messages
2.
3.
    

Additional info:
Comment 1 Bernd Bartmann 2004-02-13 13:37:33 EST
Created attachment 97659 [details]
cpuspeed error message screen shot
Comment 2 Ricky Ng-Adam 2004-02-14 04:41:03 EST
Kudzu needs to configure /etc/cpuspeed.conf with the correct module. 

On  a particular Dell and an IBM A22m, this was the change needed:

DRIVER=speedstep-smi

This should get rid of your error at boot, it also seems to set the
CPU to the lowest CPU speed (650Mhz on mine) even if the computer is
plugged in!
Comment 3 shrek-m 2004-02-14 07:01:12 EST
clean install fc2t1

cpuinfo
model name      : Celeron (Mendocino)
stepping        : 5
cpu MHz         : 300.747


# rpm -qf /etc/init.d/cpuspeed `which cpuspeed`
kernel-utils-2.4-9.1.115
kernel-utils-2.4-9.1.115


i could not find a working module under
  /lib/modules/2.6.1-1.65/kernel/arch/i386/kernel/cpu/cpufreq/*
which module should it be ?

# chkconfig --list cpuspeed
cpuspeed        0:Aus   1:Ein   2:Ein   3:Ein   4:Ein   5:Ein   6:Aus


# chkconfig cpuspeed off
solved for me the error while booting
Comment 4 Jason 2004-02-14 14:54:18 EST
I am seeing the same error message during boot.  I have a Tyan Tiger
1832DL (P3 850Mhz).
Comment 5 Pedro Fernandes Macedo 2004-02-14 20:34:19 EST
Same thing here. Athlon Xp 1800+ on a Asus A7n8x deluxe (nforce 2
chipset). 
Maybe adding some checks on kudzu to see if the processor supports
cpuspeed... 
Comment 6 Bill Nottingham 2004-02-15 23:20:42 EST
*** Bug 115720 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2004-02-15 23:20:46 EST
*** Bug 115669 has been marked as a duplicate of this bug. ***
Comment 8 Scott Sloan 2004-02-16 13:10:23 EST
I have the same problem with an Athlon XP 2000+ with kernel 2.6 on FC2
test 1
Comment 9 Thomas M Steenholdt 2004-02-17 02:31:17 EST
I had the same problem on my IBM ThinkPad T30 with P4 2.4GHz processor.
I edited /etc/cpuspeed.conf (uncommented driver and opts statements
and put p4-clockmod as driver. "service cpuspeed restart and
everything is working fine.

But I would like the ability to set a on_battery_policy as well as an
on_ac_policy(or something along those lines) in the
/etc/cpuspeed.conf, to allow be to specity to ALWAYS run full-throttle
when on AC and ALLWAYS run as-slow-as-possible when on battery or
whatever the user thinks is better for his system (hope i'm making
myself clear?!?)
Comment 10 Thomas M Steenholdt 2004-02-17 02:33:25 EST
Perhaps my idea for adding on_batt and on_ac policies should really be
added as a bug to acpid? if acpid could throw a signal to cpuspeed in
the event of going on AC or going on BATTERY, that could pretty easily
be implemented! Please advise me on this, I'll create the bugrepport
if you guys deem nessecery!
Comment 11 Bill Nottingham 2004-02-17 22:49:25 EST
*** Bug 116082 has been marked as a duplicate of this bug. ***
Comment 12 lupus 2004-02-18 11:22:31 EST
adding [ -f /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor ] ||
exit 0
to the cpuspeed init script
would this be a good way to fix it?
Comment 13 Bill Nottingham 2004-02-18 12:02:37 EST
*** Bug 116130 has been marked as a duplicate of this bug. ***
Comment 14 Thomas M Steenholdt 2004-02-18 15:50:44 EST
not really, no! since the error is not that the file is missing but
rather that the module that's responsible for putting the files there
are not loaded!
Comment 15 Chris Thomas 2004-02-18 19:30:28 EST
Not true. I have a laptop with a Athlon 2500+ mobile cpu in it. If I 
tell cpuspeed to load the powernow-k7 module, it says its already 
loaded and I still get 
the /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor error 
message.
Comment 16 Thomas M Steenholdt 2004-02-19 00:18:54 EST
that could be a problem with the k7 driver?!?
Anyways, the p4-clockmod driver is what did it for me. Ignoring that
important files are missing from the sys filesystem (indicating that
not all requirements are met) is not the way to go! There's a very
good chance that cpuspeed will not work properly if those files are
missing!
Comment 17 Thomas M Steenholdt 2004-02-23 17:14:33 EST
Created attachment 97967 [details]
cpuspeed initscript cleanup?

I've made a patch for the cpuspeed initscript from the kernel-utils-2.4.9.1.120
package.
 
This is an attempt to handle the running processes better, make sure multiple
cpuspeed daemons are not started and printing [ OK ] style messages correctly.
Also eliminates error-messages from attempting to reload an already inserted
module etc.
 
please try it out and let me know what you think.
Comment 18 Thomas M Steenholdt 2004-02-24 00:20:42 EST
the script might need to be a little more verbose in event of an
error, let me know what you think!
Comment 19 Joerg Skottke 2004-02-24 11:29:15 EST
[root@skotti init.d]# patch cpuspeed
/home/skotti/cpuspeed_initscript.patch
patching file cpuspeed
[root@skotti init.d]# ls -l | grep cpuspeed
-rwxr-xr-x  1 root root  1109 24. Feb 17:27 cpuspeed
[root@skotti init.d]# ./cpuspeed restart
Stopping cpuspeed:                                         [  OK  ]
Starting cpuspeed:                                        
[FEHLGESCHLAGEN]

I hopefully patched the file correctly (looking at it your changes
apparently are merged into the file).

Restarting cpuspeed right after patching ends with a failure to start
the module.

*suk* ;)
Comment 20 Joerg Skottke 2004-02-24 11:39:07 EST
After restart, the the "starting cpuspeed" message as well as
[FEHLGESCHLAGEN] are printed twice during bootup. However, the "no
such file or directory" warning is gone.
Comment 21 Thomas M Steenholdt 2004-02-24 14:15:57 EST
Please note that you still have to make sure /etc/cpuspeed.conf is
setup correctly for this to work. I know that you won't get any
indication right now, as to what's going on when it fails - that's
what I meant when I said that it should probably be more verbose. The
patching seems to have gone just fine. The "stop" command succeeds
because there's no cpuspeed processes left running. The "start"
command most likely fails because the proper module has not been loaded!
Please note that this patch has nothing to do with the errors returned
from cpuspeed. If it wouldn't start before, it won't start now! What
it will do, is make sure that things are started/stopped correctly
before returning success, and also makes sure that the cpuspeed daemon
is never started twice!
I'll see what I can do about the messages!
Comment 22 Thomas M Steenholdt 2004-02-24 15:44:02 EST
Created attachment 98010 [details]
patch2 (requires the first patch to be applied first)

output from cpuspeed are put in /var/log/messages as well as any module errors.

currently this will mean some Module xxx is already in the kernel messages will
go in there (could be removed if required)

however i'm a little uncertain if there's a "policy" for when a service should
"fail" and when it should "succeed" 

this cpuspeed script will return "success" for start as long as the cpuspeed
process is left running. On the other hand it will return success for stop as
long as there is no cpuspeed process left running. I find that this makes sence
- however given httpd as example it will return "success" when it successfully
launches httpd... Any attempt to start again will return "failed". This kinda
makes sense too. So what is the policy on this?
Comment 23 Jack Aboutboul 2004-02-24 19:08:51 EST
I also have this error. I'm on a dell laptop an Insprion 5000e to be
exact. Heres my /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 547.597
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca
cmov pat pse36 mmx fxsr sse
bogomips        : 1081.34

It seems like you guys got this one down packed. Just wanted to add a
comment about the specific machine im using.
Comment 24 Thomas M Steenholdt 2004-02-25 04:06:25 EST
Created attachment 98031 [details]
last patch for the cpuspeed initscript (hopefully)

this patch follows the feel of most of the other initscripts in that it will
fail upon start if already started and fail upon stop if already stopped. In
addition to this, output from cpuspeed an modprobe is removed from stdout and
put into /var/log/messages. (patch against original cpuspeed initscript). out!
Comment 25 Bill Nottingham 2004-03-01 22:48:56 EST
*** Bug 117103 has been marked as a duplicate of this bug. ***
Comment 26 Bill Nottingham 2004-03-04 00:10:24 EST
*** Bug 117356 has been marked as a duplicate of this bug. ***
Comment 27 Stewart Smith 2004-03-08 08:58:59 EST
same on FC2test1 on Athlon XP 2500
Comment 28 Martin A. Boegelund 2004-03-14 08:06:45 EST
Same on FC2test1 on Celeron 2.0 GHz
Comment 29 Miloslav Trmac 2004-04-07 13:48:25 EDT
The change from comment #12 seems to have been applied.

Note You need to log in before you can comment on or make changes to this bug.