Bug 177469 - duplicate microcode device nodes in /dev/cpu/
duplicate microcode device nodes in /dev/cpu/
Status: CLOSED DUPLICATE of bug 168417
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: MAKEDEV (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On: 63928
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 16:55 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 21:14:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-01-10 16:55:20 EST
+++ This bug was initially created as a clone of Bug #63928 +++

It seems wrong to have multiple aliases (/dev/cpu/0..15/microcode) for the same
device node (major 10, minor 184).  Why is it done this way?  Would it be better
to have unique microcode device nodes for each processor instead of just using
/dev/cpu/microcode?  Is this something I should change in the official devices.txt?

Thanks,
John Cagle
(wearing my LANANA hat)

-- Additional comment from nalin@redhat.com on 2004-08-25 20:36 EST --
I couldn't hazard a guess.  The init script which calls microcode_ctl
on my system is in kernel-utils, maybe there's some idea there.

-- Additional comment from davej@redhat.com on 2004-10-25 23:20 EST --
I've never figured out why we deviated away from upstream here.
Our microcode_ctl has a patch to change reading the file from /dev/cpu/microcode
to /dev/cpu/0/microcode.  It makes no sense to me as

a) We only do it for cpu #0
b) The driver patches every CPU in the system, so multiple nodes don't make sense.

We could drop that patch and fix up udev in FC4 / RHEL4.


-- Additional comment from davej@redhat.com on 2005-01-10 19:51 EST --
as of tomorrow, microcode_ctl in rawhide will use the upstream /dev/cpu/microcode.
Harald, please adjust udev accordingly.


-- Additional comment from yekkim@pacbell.net on 2005-01-12 14:21 EST --
If udev-050-1 was the 'adjusted' udev for this bug, then the commented
line in /etc/makedev.d/linux-2.6.x:

#c $ROOT                 10 184  1   1 cpu/microcode

should be uncommented. 

Likewise, the uncommented line in /etc/makedev.d/redhat:

c $ROOT                 10 184  0  16 cpu/%d/microcode

should be commented.

-- Additional comment from harald@redhat.com on 2005-01-20 11:17 EST --
*** Bug 144915 has been marked as a duplicate of this bug. ***

-- Additional comment from nalin@redhat.com on 2005-01-20 18:57 EST --
*** Bug 144887 has been marked as a duplicate of this bug. ***

-- Additional comment from harald@redhat.com on 2005-02-10 06:20 EST --
*** Bug 147657 has been marked as a duplicate of this bug. ***

-- Additional comment from harald@redhat.com on 2005-02-10 06:20 EST --
*** Bug 145861 has been marked as a duplicate of this bug. ***

-- Additional comment from harald@redhat.com on 2005-02-10 06:21 EST --
*** Bug 146292 has been marked as a duplicate of this bug. ***

-- Additional comment from gordon.jin@intel.com on 2005-04-06 22:25 EST --
This fix is not in RHEL4-U1-beta.

In RHEL4-U1-beta:
microcode_ctl has been changed to use /dev/cpu/microcode,
but shipped MAKEDEV-3.15-2 doesn't contain the corresponding fix in Comment#4.

Can you get this fixed in RHEL4-U1?
Comment 2 Daniel Riek 2006-01-10 21:14:47 EST

*** This bug has been marked as a duplicate of 168417 ***

Note You need to log in before you can comment on or make changes to this bug.