This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 63928 - duplicate microcode device nodes in /dev/cpu/
duplicate microcode device nodes in /dev/cpu/
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
: 144887 144915 145861 146292 147657 (view as bug list)
Depends On:
Blocks: 168417 177469
  Show dependency treegraph
 
Reported: 2002-04-22 01:36 EDT by John Cagle
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version: 3.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 18:57:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Cagle 2002-04-22 01:36:16 EDT
It seems wrong to have multiple aliases (/dev/cpu/0..15/microcode) for the same
device node (major 10, minor 184).  Why is it done this way?  Would it be better
to have unique microcode device nodes for each processor instead of just using
/dev/cpu/microcode?  Is this something I should change in the official devices.txt?

Thanks,
John Cagle
(wearing my LANANA hat)
Comment 1 Nalin Dahyabhai 2004-08-25 20:36:14 EDT
I couldn't hazard a guess.  The init script which calls microcode_ctl
on my system is in kernel-utils, maybe there's some idea there.
Comment 2 Dave Jones 2004-10-25 23:20:31 EDT
I've never figured out why we deviated away from upstream here.
Our microcode_ctl has a patch to change reading the file from /dev/cpu/microcode
to /dev/cpu/0/microcode.  It makes no sense to me as

a) We only do it for cpu #0
b) The driver patches every CPU in the system, so multiple nodes don't make sense.

We could drop that patch and fix up udev in FC4 / RHEL4.
Comment 3 Dave Jones 2005-01-10 19:51:06 EST
as of tomorrow, microcode_ctl in rawhide will use the upstream /dev/cpu/microcode.
Harald, please adjust udev accordingly.
Comment 4 Mickey Stein 2005-01-12 14:21:34 EST
If udev-050-1 was the 'adjusted' udev for this bug, then the commented
line in /etc/makedev.d/linux-2.6.x:

#c $ROOT                 10 184  1   1 cpu/microcode

should be uncommented. 

Likewise, the uncommented line in /etc/makedev.d/redhat:

c $ROOT                 10 184  0  16 cpu/%d/microcode

should be commented.
Comment 5 Harald Hoyer 2005-01-20 11:17:37 EST
*** Bug 144915 has been marked as a duplicate of this bug. ***
Comment 6 Nalin Dahyabhai 2005-01-20 18:57:02 EST
*** Bug 144887 has been marked as a duplicate of this bug. ***
Comment 7 Harald Hoyer 2005-02-10 06:20:11 EST
*** Bug 147657 has been marked as a duplicate of this bug. ***
Comment 8 Harald Hoyer 2005-02-10 06:20:16 EST
*** Bug 145861 has been marked as a duplicate of this bug. ***
Comment 9 Harald Hoyer 2005-02-10 06:21:12 EST
*** Bug 146292 has been marked as a duplicate of this bug. ***
Comment 10 Gordon Jin 2005-04-06 22:25:48 EDT
This fix is not in RHEL4-U1-beta.

In RHEL4-U1-beta:
microcode_ctl has been changed to use /dev/cpu/microcode,
but shipped MAKEDEV-3.15-2 doesn't contain the corresponding fix in Comment#4.

Can you get this fixed in RHEL4-U1?

Note You need to log in before you can comment on or make changes to this bug.