Bug 18793 - RH 7.0 hangs on boot after the text 'Enabling swap space'
RH 7.0 hangs on boot after the text 'Enabling swap space'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
: 18761 19228 20356 21489 22779 23064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 06:42 EDT by Matthew Seddon
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 02:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Seddon 2000-10-10 06:42:54 EDT
This does not appear to occur on all systems, but during the boot 
sequence, the system hangs after printing the text, 'Enabling swap space'.

I have a work around which involves booting the rescue image, and editing 
rc.sysinit and commenting out the 'Load agpgart here' section.

Once that section is commented out, the system boots normally and 
everything appears to function normally.

I would assume that this problem only occurs on systems with an AGP card, 
but to be specific, I have heard of the problem occuring on HP Netserver 
E60's.
Comment 1 Marc Luuk 2000-10-10 15:20:29 EDT
Hi!
I've got just the same problem. I've got a laptop (HP Omnibook XE-2 DD) with an
onboard AGP card (Silicon Motion LynxEM 4MB). I'll try your workaround and
report the result to you.

Thanks!
Comment 2 Marc Luuk 2000-10-10 18:03:07 EDT
Hi again!

I' ve just reinstalled RH 7.0 on my machine. Your workaround works fine. But you
should know that a RH Rescue floppy disk or CD isn't able to boot the system. It
hangs at the same point ("enabling swap space"). The boot under aid of a well
known rescue disk (tomsrtbt) worked fine. So I was able to mount the
root-file-sytem and to edit the rc.sysinit.

Thanks!
Comment 3 Matthew Seddon 2000-10-11 00:53:57 EDT
Quoted from Denis Hruza on the Support Forum:

-- BEGIN QUOTE
Don't know if it will work with the SCSI setups, but you can also try
At the graphical lilo screen hit ctrl-x
At the lilo boot prompt type:
linux init=/bin/bash rw

It will load the kernel and pop up a bash shell without running any of the init 
stuff. You can then go edit what you need to. 
-- END QUOTE

I honestly haven't tried this.
Comment 4 Marc Luuk 2000-10-11 06:29:23 EDT
Thanks for your tip. I'll try it.
Comment 5 cjcarr 2000-10-12 22:54:34 EDT
Same problem and same resolution on an HP Omnibook 4150 with a NeoMagic 128 2MB 
AGP card.
Comment 6 Bill Nottingham 2000-10-16 12:46:41 EDT
OK, it appears the agpgart module hangs some systems. Any ideas from the kernel 
folks?
Comment 7 Bill Nottingham 2000-10-17 00:56:23 EDT
*** Bug 19228 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2000-11-04 02:36:10 EST
*** Bug 18761 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2000-11-13 02:33:37 EST
*** Bug 20356 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2000-11-29 15:53:20 EST
*** Bug 21489 has been marked as a duplicate of this bug. ***
Comment 11 Need Real Name 2000-12-21 23:18:42 EST
I can't get my E60 (SCSI) past the swap line no matter what I do.  Even 
reformatting the drive and doing a clean install didn't work.  I was able to get 
into bash and edit rc.sysinit in pico, which is easier than the rescue CD route, 
but it still didn't help.  My next step, I suppose, is to replace the AGP video 
card with a PCI type and reinstall 7.0.
Comment 12 Bill Nottingham 2000-12-23 13:08:56 EST
*** Bug 22779 has been marked as a duplicate of this bug. ***
Comment 13 Bill Nottingham 2001-01-02 01:13:05 EST
*** Bug 23064 has been marked as a duplicate of this bug. ***
Comment 14 Jonathon Evans 2001-01-02 02:03:47 EST
I found if I delete /etc/sysinfo/hwconf everytime I can then boot my machine.  
I think its related to Kudzu.  They marked my bug report as a duplicate.
Comment 15 Bill Nottingham 2001-01-02 09:29:20 EST
Because it *is* a duplicate. It's only related to kudzu because that's
where it looks for the configuration information to load the agpgart
module. It's the agpgart module that's hanging your system.
Comment 16 Need Real Name 2001-01-16 14:15:05 EST
The hang on boot problem also occurs on my Gateway 8200 Servers.  The published
fix (edit agp line from rc.sysinit) corrects the problem.
Comment 17 Need Real Name 2001-01-16 14:15:21 EST
The hang on boot problem also occurs on my Gateway 8200 Servers.  The published
fix (edit agp line from rc.sysinit) corrects the problem.
Comment 18 Need Real Name 2001-01-21 05:57:33 EST
The bug also occurs on the Toshiba Satellite Pro 4270ZDVD laptop computer.
I have been having exactly this problem after installing RedHat Linux 7.0.
Comment 19 Need Real Name 2001-01-21 07:40:34 EST
commenting out those lines of code does not seem to work on my Toshiba 
SatellitePro 4270ZDVD laptop.  It still hangs either just after Enabling swap 
space or just before it (after a message about turning on quotas or something)
Comment 20 Bob Caz 2001-03-17 11:11:59 EST
HP NETSERVER 60 W/32MB AGP ATI VIDEO.HAVING SAME PROBLEM. I HAVE NO LINUX 
EXPERIENCE AND TRIED THE LINUX SINGLE INIT COMMAND. MACHINE BOOTS TO INIT-
2.04#. ANYONE GOT THE TIME TO SEND ME DIRECTIONS ON HOW TO EDIT THESE LINES 583-
585? I AM STARING AT INIT-2.04# _ AND NEED HELP PLEASE. THANK YOU!!
Comment 21 Bill Nottingham 2001-04-03 00:29:19 EDT
FWIW, the current initscripts do *not* automatically load agpgart.
Comment 22 Need Real Name 2001-06-25 02:26:52 EDT
Same problem happened with me with redhat 7.1. I have a pentium 166 MMX. PCI 
video card here though! If I boot from the floppy it works fine, but not 
othewise! I tried re-installing with several different configurations (size of 
swap or even different hard-drives!) I'll try this fix, hopefully it'll work!
Comment 23 Matthew Seddon 2001-06-25 02:53:00 EDT
Latest release 7.1 works fine.
Comment 24 Michael 2004-07-07 23:07:10 EDT
I'm unable to boot the system using and edit the files (either 
rc.sysinit or inittab) either way the file system is mounted in read-
only mode, any suggestions?

-MDH
mdhouse@hotmail.com

Note You need to log in before you can comment on or make changes to this bug.