Bug 190575 - rhgb does not work anymore after kernel upgrade to 2.6.16-1.2107_FC5
rhgb does not work anymore after kernel upgrade to 2.6.16-1.2107_FC5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 190626 190689 190738 190744 190811 190855 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 13:42 EDT by Christian Nolte
Modified: 2015-01-04 17:26 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-06 20:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2006-05-03 13:42:22 EDT
Description of problem:
The latest upgrade to kernel 2.6.16-1.2107_FC5 breaks rhgb. Starting rhgb on
boot yields to a black screen with only the X-mouse cursor displayed (which can
be moved) and the booting stops. Doing a CTRL-ALT-BACKSPACE the X-server is
killed and booting continues.

Version-Release number of selected component (if applicable):
rhgb-0.16.3-1
kernel-2.6.16-1.2107_FC5

How reproducible:
Everytime

Steps to Reproduce:
1. Upgrade from kernel 2.6.16-1.2096_FC5 to 2.6.16-1.2107_FC5
2. Reboot
  
Actual results:
X-server spawned for rhbg locks up.

Expected results:
The graphical boot should run through

Additional info:

[root@ravine temp]# head /etc/rhgb/temp/xorg.log
_XSERVTransmkdir: ERROR: Cannot create /tmp/.X11-unix
_XSERVTransSocketUNIXCreateListener: mkdir(/tmp/.X11-unix) failed, errno = 30
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for local

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
Current Operating System: Linux (none) 2.6.16-1.2107_FC5 #1 Tue May 2 19:01:05
EDT 2006 i686
Build Date: 02 May 2006
Comment 1 TJ Hoye 2006-05-03 16:41:08 EDT
Same here.
Removing rhgb from grub command line allows smooth boot
but process no longer hidden from view. 
Comment 2 Izaac Zavaleta 2006-05-03 17:04:33 EDT
Here too, on x86 with a smp kernel.
Comment 3 Brian G. Anderson 2006-05-03 17:12:28 EDT
After doing the Ctl-Shigt-Backspace to continue, gnome seems to work, but the I
have problems with logout, shutdown, or restart from gnome.  Once I select this
option, the entire desktop semi-responsive:
1) the original selection dialog for logout, etc. won't go away
2) terminals stop accepting input
3) Ctl-Shift backspace is unresponsive

however Ctl-Shift F1 pulls down the Applications menu and I can navigate around
using the cursor keys, but any selection just results in a spinner cursor.
Comment 4 Peter Gordon 2006-05-03 19:45:11 EDT
This happens to me as well.

xorg-x11-drv-ati-6.5.8.0-1 (Radeon 9200)
xorg-x11-server-Xorg-1.0.1-9.fc5.1.1
rhgb-0.16.3-1
kernel-2.6.16-1.2107_FC5

Comment 5 Dave Jones 2006-05-03 20:33:04 EDT
Christian,

_XSERVTransSocketUNIXCreateListener: mkdir(/tmp/.X11-unix) failed, errno = 30

That error is 'read only file system'.
What fs type does /tmp live on ?
Comment 6 Dave Jones 2006-05-04 00:13:44 EDT
Actually, that option is also broken in this kernel (sigh).

2108, available from http://people.redhat.com/davej/kernels/Fedora/FC5/
has this disabled by default. Give that a try ?
Comment 7 Christian Nolte 2006-05-04 02:53:37 EDT
> That error is 'read only file system'.
> What fs type does /tmp live on ?

It is on an ext3 fs. I'll try 2108 later on.
Comment 8 J.Jansen 2006-05-04 03:03:12 EDT
Same problem with me on 3 systems with complete different hardware/graphical
drivers. I'll try the 2108 later

          
Comment 9 Martin 2006-05-04 03:26:08 EDT
still the same problem with the 2108 kernel on my vmware.
Only the X-Cursur appears, but Ctrl-Shift-Backspace continue the boot process.
Comment 10 J.Jansen 2006-05-04 05:24:51 EDT
No improvements for me either with the 2108 kernel.

Comment 11 renke 2006-05-04 05:57:05 EDT
with kernel 2107 I see similar problems (only X-cursor). Without the option rhgb
the booutup stucks while starting cups.
Comment 12 David Kahn 2006-05-04 09:19:05 EDT
Same here, on a Dell Dimension 2400 with onboard intel
graphics. (2107, remove "rhgb, quiet" and system boots.)
Comment 13 TJ Hoye 2006-05-04 09:21:47 EDT
davej

FWIW, rhgb has a Feb date on it.
The command 'yum deplist rhgb' shows a couple of dozen dependencies, many libs.
Checking out which of the deps have changed since Feb might give a clue.

I have not tried 2108 yet, but if rhgb itself isn't tweaked, I'd be surprised if
the problem goes away.

best regards
TJH
Comment 14 TJ Hoye 2006-05-04 09:50:02 EDT
davej

Amend comment #13 to 'changed since Apr 19'.
That's the date on kernel 2096 which wasn't giving any problem with rhgb

TJH
Comment 15 Tore H. Larsen 2006-05-04 15:57:30 EDT
cc
Comment 16 TJ Hoye 2006-05-04 18:55:00 EDT
Red Hat

Please see if problems at 190338 and 187312, or their solutions have any effect
on this issue (190575).

Thanks.
TJH
Comment 17 David Kahn 2006-05-04 21:44:07 EDT
Actually, I think the first comment points to the problem
where the socket couldn't be created.

Apparently, a lot of people are having network/socket related
problems with 2107.
Comment 18 David Kahn 2006-05-05 04:21:59 EDT
Looks like the 2107 kernel has been pulled from the mirrors.
Revert back to 2096. I really don't think that there's anything
wrong with rhgb. It was just the first symptom of the problem.

Comment 19 Vedran Miletić 2006-05-05 06:04:23 EDT
Well, it seems that it would be a lot better if 2107 was first in
updates-testing, instead of updates.
Did anyone try 2111 from davej's repo?
Comment 20 John Thacker 2006-05-05 08:47:26 EDT
*** Bug 190744 has been marked as a duplicate of this bug. ***
Comment 21 John Thacker 2006-05-05 09:05:51 EDT
*** Bug 190626 has been marked as a duplicate of this bug. ***
Comment 22 John Thacker 2006-05-05 09:07:33 EDT
*** Bug 190738 has been marked as a duplicate of this bug. ***
Comment 23 John Thacker 2006-05-05 09:08:11 EDT
*** Bug 190689 has been marked as a duplicate of this bug. ***
Comment 24 TJ Hoye 2006-05-05 10:40:07 EDT
RedHat
FWIW, there are three dozen *other* bug reports on rhgb.
TJH
Comment 25 David Kahn 2006-05-06 00:05:54 EDT
No problems with kernel 2111 so far.
Installed and booted up fine on my Dell Dim. 2400.

Comment 26 Richard Valstar 2006-05-06 00:25:04 EDT
Just chiming in as a Core 5 newbie.  The base Core 5 install worked on my 2 
target machines.  Running "Software Updater" downloaded this version of the 
kernel which worked on my newer machine yet produced the X problems noted here 
on my older one.  Both machine have similar CPU, memory, disk capacities and 
same LCD DVI displays.  Older is running a Radeon 92x0 (tried 2 different 
boards) on a GA-8KNXP m'board.  Newer is running a Radeon X1300 on a GA-8I955X 
Royal.  Both have 2 GB RAM and identical drive layouts (less differences in 
ICHnR and SiL versions).

Will provide additional info as requested.

Ctrl-Alt-Backspace and removig rhgb from GRUB is working for me with no side 
effects.
Comment 27 Peter Gordon 2006-05-06 00:59:43 EDT
The 2.6.16-1.2111_FC5 build fixes everything for me. Thanks, Dave. :)
Comment 28 TJ Hoye 2006-05-06 08:07:34 EDT
2111 works ok here, as well.
No rhgb or dmesg complaints.
Thanks
Comment 29 Dave Pawson 2006-05-06 09:11:42 EDT
Same problem after yum update to 2107.

How do I remove rhgb from GRUB please?
Comment 30 Luya Tshimbalanga 2006-05-06 14:34:25 EDT
*** Bug 190811 has been marked as a duplicate of this bug. ***
Comment 31 Luya Tshimbalanga 2006-05-06 14:42:34 EDT
*** Bug 190855 has been marked as a duplicate of this bug. ***
Comment 32 TJ Hoye 2006-05-06 19:49:37 EDT
(In reply to comment #29)
> Same problem after yum update to 2107.
> 
> How do I remove rhgb from GRUB please?
> 
Dave Pawson:

1. either ...
In /boot/grub/grub.conf,
take rhgb out of the line that begins with 'kernel',

2. or...
Upgrade to kernel 2111 which no longer has the rhgb problem,
at least for some of us, that is.

Good luck,
TJH

Note You need to log in before you can comment on or make changes to this bug.