Bug 233760 - /etc/logrotate.d/setroubleshoot points to '/usr/local/var/log/setroubleshoot/*.log '
/etc/logrotate.d/setroubleshoot points to '/usr/local/var/log/setroubleshoot/...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Ben Levenson
: EasyFix, Patch
: 234555 237148 238539 238546 238850 239552 239641 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-24 14:51 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 14:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-03-24 14:51:37 EDT
Description of problem:
/etc/logrotate.d/setroubleshoot contains:

/usr/local/var/log/setroubleshoot/*.log {
    weekly
    rotate 2
    missingok
    sharedscripts
#    postrotate
#    endscript
}

/usr/local/var should be /var/log, no?

Version-Release number of selected component (if applicable):
setroubleshoot-1.9.4-1.fc7

How reproducible:
yup

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kenneth A. Redler 2007-03-30 07:15:48 EDT
*** Bug 234555 has been marked as a duplicate of this bug. ***
Comment 2 John Dennis 2007-04-19 14:08:00 EDT
*** Bug 237148 has been marked as a duplicate of this bug. ***
Comment 3 Orion Poplawski 2007-04-25 11:30:50 EDT
Index: setroubleshoot.logrotate
===================================================================
RCS file: /cvs/dist/rpms/setroubleshoot/devel/setroubleshoot.logrotate,v
retrieving revision 1.4
diff -u -r1.4 setroubleshoot.logrotate
--- setroubleshoot.logrotate    20 Mar 2007 15:25:50 -0000      1.4
+++ setroubleshoot.logrotate    25 Apr 2007 15:28:22 -0000
@@ -1,4 +1,4 @@
-/usr/local/var/log/setroubleshoot/*.log {
+/var/log/setroubleshoot/*.log {
     weekly
     rotate 2
     missingok
Comment 4 Gilles Detillieux 2007-04-30 14:04:20 EDT
This is still not fixed in Fedora 7 Test 4.  I know it seems like a trivial
matter, but the fix should also be equally trivial, and it's the sort of
unpolished thing that makes new users go "whaaaaat?".  I hope you'll fix it
before final release.
Comment 5 John Dennis 2007-04-30 14:26:12 EDT
fixed in 1.9.5
Comment 6 John Dennis 2007-05-01 13:58:02 EDT
*** Bug 238539 has been marked as a duplicate of this bug. ***
Comment 7 John Dennis 2007-05-01 13:59:33 EDT
*** Bug 238546 has been marked as a duplicate of this bug. ***
Comment 8 John Dennis 2007-05-03 10:49:33 EDT
*** Bug 238850 has been marked as a duplicate of this bug. ***
Comment 9 Gilles Detillieux 2007-05-03 12:13:15 EDT
What a lot of duplicates!  When is 1.9.5 going to get pushed out to the development repository?  
That might cut down on the repeat reports.
Comment 10 John Dennis 2007-05-09 09:23:26 EDT
FYI: it is also fixed in 1.9.4-2 (the current F7 version)
Comment 11 John Dennis 2007-05-09 09:25:04 EDT
*** Bug 239552 has been marked as a duplicate of this bug. ***
Comment 12 Gilles Detillieux 2007-05-09 11:34:40 EDT
Ah, you must be talking about the current *internal* F7 version.  Us mere
mortals on the outside have only F7 Test 4 and rawhide to try out, and rawhide
hasn't had any updates pushed out in just over a week.  Is it customary to stop
updating rawhide during a pre-release feature freeze?  Seems it would be useful
to get the bug fix updates out to rawhide for testing by the community.
Comment 13 John Dennis 2007-05-09 12:41:13 EDT
Re comment #12: no, it is not normal for rawhide to be unavailable. The Fedora
Project is the middle of merging "core" and "extras" into a single unified
Fedora release, during this one time merge process rawhide was suspended. There
have been volumes of mail concerning the process on various Fedora mailing
lists. The release engineering team is working very hard to bring rawhide back
online as soon as possible.
Comment 14 John Dennis 2007-05-10 10:03:09 EDT
*** Bug 239641 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.