Bug 2504 - hard disk install fails from fs listed in fstab
hard disk install fails from fs listed in fstab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-03 10:21 EDT by Jürgen Botz
Modified: 2008-05-01 11:37 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 18:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jürgen Botz 1999-05-03 10:21:47 EDT
Trying to install 6.0 from hard disk, with the dist sitting
on a filesystem which is regularly mounted as /u2 in my
fstab, the install failed while trying to mount all the
filesystems listed in my fstab.  The error was (approx):
"device is already mounted -- using symlink", followed by
"file or directory exists".  I then unmounted everything and
gave up.

It presented a re-try button which incidentally did nothing
worthwhile at all, since it didn't even try to re-mount the
filesystems that had been unmounted after the error, but
that should be a separate bug if at all.

I worked around this fairly easily by removing the
filesystem containing the 6.0 dist from my fstab and
restarting the install.
Comment 1 Bill Nottingham 1999-05-03 11:42:59 EDT
*** Bug 2505 has been marked as a duplicate of this bug. ***

Trying to install 6.0 from hard disk, with the dist sitting
on a filesystem which is regularly mounted as /u2 in my
fstab, the install failed while trying to mount all the
filesystems listed in my fstab.  The error was (approx):
"device is already mounted -- using symlink", followed by
"file or directory exists".  It then unmounted everything
and
gave up.

It presented a re-try button which incidentally did nothing
worthwhile at all, since it didn't even try to re-mount the
filesystems that had been unmounted after the error, but
that should be a separate bug if at all.

I worked around this fairly easily by removing the
filesystem containing the 6.0 dist from my fstab and
restarting the install.
Comment 2 Bill Nottingham 1999-05-03 11:43:59 EDT
*** Bug 2499 has been marked as a duplicate of this bug. ***

If you have a RedHat 5.2, and perform an upgrade on the HD
medium (HD install), and the drive is already mounted
through /etc/fstab, then the install failes.

Temporary solution : remove the drive where the install is
located from /etc/fstab before doing the upgrade.

                Regards,

                       Igmar
Comment 3 Bill Nottingham 1999-05-03 11:47:59 EDT
*** Bug 2440 has been marked as a duplicate of this bug. ***

I downloaded all of the Red Hat packages for 6.0 to my hard
drive and set up the directory correctly.  During the
install, everything went just fine until I got to the point
just before the system starts installing the packages.  I
believe this is the point where it mounts all of the drives
you specified to be mounted when you boot the system.  If
you happen to have the partition that contains all of the
packages in the list of drives you want to be mounted, the
program gives a "mount failed - device or resource may be
busy" error message, and won't let you proceed with the
install.  Generally, I have my system set up so that I have
a 4 GB partiton for /, a 4 GB partition for the /home, and
a 4GB partion for /home/ftp.  I usually keep all of my
files that I download for the distributions on my ftp
partition.  This was how I set these 3 partitions up in the
disk configuration section of the program.  In order to
work around this, I had to make sure that /home/ftp was not
a partion that automatically got mounted, go through the
normal install, and then manually edit the fstab file after
the system came up.
Comment 4 Bill Nottingham 1999-05-04 15:22:59 EDT
*** Bug 2540 has been marked as a duplicate of this bug. ***

I have seen this also on the mailing list, but with no
answer: the hard disk upgrade hangs when rebuilding the rpm
database; it says something about not being able to create a
symlink to a partition that had already been mounted.

If it matters, the files were on /usr/local/redhat, with
/usr under a separate partition, and I tried to give both
local/redhat and /local/redhat as paths. I tried with /var
as a separate partition and as part of /

If you are interested, I can retest and give you all the
details.


BTW The installer *really* doesn't like finding an
unformatted ext2 partition: I admit it's not common to add a
partition while upgrading the OS, but I never felt like
breaking the uptime record just for adding some space...
Comment 5 Bill Nottingham 1999-05-10 10:09:59 EDT
*** Bug 2663 has been marked as a duplicate of this bug. ***

I installed redhat 6.0 from a partition on the same hard
disk.

Things were smooth until I specified that the partition
from where I was installing would be mounted as a given
directory on my final installation (disk druid, when
it shows the different partitions and we can specify
the mounting point). Apparently, redhat tried to remount
the same partition again and this generated an error.

I assumed that the data I was typing was going to be
used primarily to create the fstab
file rather than to mount the partitions at that point.

Anyways, once I noticed that it was trying to mount the
partition again, I decided not to specify it as mountable
in disk druid and things worked out (so later I modified
fstab by hand).

Thanks for all the good work.


daniel german
dmg@csg.uwaterloo.ca
Comment 6 Bill Nottingham 1999-05-10 11:59:59 EDT
*** Bug 2694 has been marked as a duplicate of this bug. ***

I tried originally to upgrade Redhat 6.0 using files in the
root partition to upgrade the same partition.  It failed
with a couldn't find RPM database error on the main screen.
I rebooted and tried rpm --rebuild after upgrading to the
Redhat 6.0 version of rpm.  This did not help.  Then I
noticed on the other screen the error regarding a mount on
/tmp/hdimage.  So I copied all the files to another
partition and got much further (till the problem I worked
around in bugid 2506.  Has anyone been able to use the same
partition to upgrade itself?

I only have a single root partition, no other partitions.

Another note:  bugid 2142 seems to mention this problem in
the last comment but I think their other primary issue was
resolved and so it was closed.
Comment 7 Bill Nottingham 1999-05-25 09:54:59 EDT
*** Bug 3022 has been marked as a duplicate of this bug. ***

I DL'ed RH 6.0.  My RH 5.2 setup had
/dev/hda5 as /
/dev/hda7 as /u1
and the RH6.0 directory was /u1/public/ul/redhat-6.0/i386.
I first used this directory to successfully NFS-install
a 2nd machine on my home lan.

When I attempted to use this directory to install on the
machine which contains those files (i.e. a local install,
not over NFS), the following stuff happened:
it found the directory & ran the 2nd stage install OK.
it found the packages and asked me if I wanted to confirm
the individual packages OK.
I spent a few minutes adding some packages to those which
had been automatically selected OK.
It then told me about the future /tmp/install.log OK.
(so far so good)
It then gave an error message about a symlink failure.
But crap, wouldn't you know it, I didn't write it down.
But the Alt-f3 console had some messages like:
"filesystem already mounted, making symbolic link", and
"/mnt/u1: file exists".  (not exact quotes, sorry).

Second [related] bug:
After this error occurs, all the /dev/hda* filesystems get
unmounted and any "Retry" or "Previous" or "Menu" things
I tried resulted in a "text mode popup":
"Unable to rebuild RPM database: Perhaps the disk is full?"
(again, not exact quote).

Anyway, I had to copy the entire directory to my 2nd
machine and use the NFS install diskette instead.  Good
thing I got tons of space!

Perhaps inappropriate here, but nice job all around on 6.0.

		-rb
Comment 8 Jay Turner 1999-07-07 11:15:59 EDT
*** Bug 2761 has been marked as a duplicate of this bug. ***

The installer couldn't mount my hard disk filesystems, so I
had to do them by hand.

The root filesystem is on hda1, and most of the other
filesystems are one sda1 (/usr, /usr/lib, /usr/src, /opt,
and /opt).

I have some additional partitions on my SCSI drive that are
not currently in use, but the installer tried to mount them,
and didn't like the fact they did not have any file system
yet.

I was running RedHat GNU/Linux 5.2 before with kernel-2.2.7
that I compiled and installed by hand, along with the
requisite RPM's for the 2.2.x kernel family. I can provide a
list of the before and after RPM list, the upgrade.log file,
and my fstab if you'd like.

I upgraded via a local CD-ROM drive (hdc), which I know from
previous upgrades that I have to mention as a boot param
(expert hdc=cdrom). The new system version is "Linux version
2.2.5-15 (root@porky.devel.redhat.com) (gcc version
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Mon Apr
19 22:21:09 EDT 1999"


I've been hacking *nix for going on 15 years, and I do
sometimes working directly on admin files with command
prompts or by hand. This might be the source of the
problems. I did replace the fstab file with a copy without
my commented out entries, but it made no difference.)

I did finally get the upgrade done by mknod, fsck and
mounting all the partitions by hand and skipping the "Find
current installation" step.

I apologize for not providing full details. Validation is my
day job, and I need to get back to that rather than play
around with my O/S.
Comment 9 Jay Turner 1999-07-07 11:30:59 EDT
*** Bug 2920 has been marked as a duplicate of this bug. ***

This bug, reported as a comment by noah@ecn.purdue.edu to
bug #2142, has occurred to me as well.


------- Additional Comments From jbucata@erols.com  05/18/99 23:05 -------
I tried removing my /boot partition from /etc/fstab altogether,
placing boot files in the boot directory under / (where the partition
had once been mounted).  This didn't change anything; I still get the
error.  I have a *lot* of other partitions; I don't want to have to
somehow remove all of them to get this upgrade to work (if it came to
that, I'd take the opportunity to repartition anyhow, and do a
complete reinstall).


------- Additional Comments From jturner@redhat.com  05/19/99 10:24 -------
It is not possible to perform a hard drive installation/upgrade to the
same partition that the source files are located in, otherwise you
will receive the error that is described in this posting.

------- Additional Comments From jbucata@erols.com  06/02/99 00:39 -------
If by "source files" you mean the RPMs, I'm upgrading from a Linux
Central CD-ROM with a boot floppy.  I'm not doing a hard drive
install.


------- Additional Comments From jbucata@erols.com  06/02/99 01:22 -------
I looked back at the original comment, and yes, it appears that that
problem was from a hard drive install (and therefore yet another
duplicate of bug 2504, reported several times here).  This one isn't,
however.


------- Additional Comments From jbucata@erols.com  06/10/99 01:30 -------
I tried it again, and when I got to the point where it complained, I
went over to bash, and I simply ran "umount /mnt" (where /dev/hda6 had
been mounted), and it worked fine after that.
Comment 10 Jay Turner 1999-07-07 12:29:59 EDT
*** Bug 3118 has been marked as a duplicate of this bug. ***

Hi,
  I have RH Alpha (5.2) which I upgraded to 6.0; I've
also seen this in previous RH versions.

  I have a set of discs mounted under /discs - i.e.
/dev/sd??  /discs/deskapps
/dev/sd??  /discs/cross

etc.

When upgrading the system the installer fails at the point
where it tries to find the system to upgrade; it appears it
is screwing up when it has to try and mount discs other than
on the system root directory.

I had to edit my /etc/fstab and take those out during the
upgrade.

Dave

------- Additional Comments From dkl@redhat.com  06/02/99 18:44 -------
It would be more helpful if we had a dump of your partition
information of your system so that we can try to recreate the problem
in our lab. Thanks.

------- Email Received From  "Dr . David Alan Gilbert" <dg@px.uk.com> 06/07/99 04:36 -------
Comment 11 Bill Nottingham 1999-07-15 18:14:59 EDT
this was fixed in the errata images, IIRC.

Note You need to log in before you can comment on or make changes to this bug.