Bug 262461 - Public key for elfutils-libelf-0.129-1.fc7.i386.rpm is not installed
Summary: Public key for elfutils-libelf-0.129-1.fc7.i386.rpm is not installed
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All All
medium
urgent
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
: 262821 263781 264201 264361 265741 265981 266161 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-29 04:59 UTC by The Source
Modified: 2014-03-17 03:08 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 23:44:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description The Source 2007-08-29 04:59:27 UTC
Description of problem:
Can't update!!!!!
Public key for elfutils-libelf-0.129-1.fc7.i386.rpm is not installed

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Eric Sandeen 2007-08-29 05:10:52 UTC
no idea why this went to me, I don't own elfutils...

though honestly doubt if it's even an elfutils (packaging) bug.  Over to you
anyway, Roland :)

Comment 2 Roland McGrath 2007-08-29 07:01:18 UTC
This lacks all necessary details about the problem.  But whatever it is, it
cannot be a problem inside the rpm itself.  Signatures are part of the
updates-release process.

Comment 3 Susi Lehtola 2007-08-29 07:28:51 UTC
I have the same problem on 20+ F7 machines. The output of yum is:

warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Error: Public key for elfutils-libelf-0.129-1.fc7.i386.rpm is not installed

which of course stops the update.

Comment 4 Susi Lehtola 2007-08-29 07:29:55 UTC
The problem occurs on both i386 and x86_64.

Comment 5 Mamoru TASAKA 2007-08-29 07:53:58 UTC
It seems that this eltutils is signed with testing key.

https://www.redhat.com/archives/fedora-list/2007-August/msg04472.html

Comment 6 Nicola Soranzo 2007-08-29 10:05:28 UTC
This bug is a duplicate of bug #262821.

Comment 7 Roland McGrath 2007-08-29 10:20:15 UTC
*** Bug 262821 has been marked as a duplicate of this bug. ***

Comment 8 Bukovansky Richard 2007-08-29 12:05:15 UTC
I'm getting same error.

Comment 9 Dennis Gilmore 2007-08-29 15:59:54 UTC
*** Bug 263781 has been marked as a duplicate of this bug. ***

Comment 10 Ed Hill 2007-08-29 16:54:27 UTC
Perhaps someone else has already suggested it, but it seems that the 
signing process really ought to include a quick "sanity-check" or 
"repo lint" sort of script/tool that catches errors like this before 
they get mirrored and hit by so many users.

Is there a planned feature or could we please open an RFE for some sort 
of "repo lint" tool?

[And yes, a number of my machines also ran into this problem.]

Comment 11 David Juran 2007-08-29 17:32:55 UTC
*** Bug 264201 has been marked as a duplicate of this bug. ***

Comment 12 Jesse Keating 2007-08-29 18:03:59 UTC
The just finished update push should solve this issue.

As to a repo lint, the repo production tool is supposed to only allow packages
signed with the given signature into the repo.  There may have been a
configuration foul up that I'm investigating.  Ongoing work into repo sanity is
being discussed and tracked in bodhi's Trac instance,
https://hosted.fedoraproject.org/projects/bodhi

Please confirm that with an updated mirror or the Fedora master mirror that the
correctly signed packages are in place.

Comment 13 Ryan Cavicchioni 2007-08-29 22:39:26 UTC
The updates installed successfully when I ran: yum clean all && yum -y update

Comment 14 Roland McGrath 2007-08-29 22:40:38 UTC
*** Bug 265741 has been marked as a duplicate of this bug. ***

Comment 15 Roland McGrath 2007-08-30 02:02:08 UTC
*** Bug 265981 has been marked as a duplicate of this bug. ***

Comment 16 Roland McGrath 2007-08-30 07:51:43 UTC
*** Bug 266161 has been marked as a duplicate of this bug. ***

Comment 17 Jesse Keating 2007-08-30 20:09:30 UTC
*** Bug 264361 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.