Bug 451519 - NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386.rpm missing
Summary: NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386.rpm missing
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: x86_64
OS: Linux
high
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 454853 455037 455178 455282 455464 455587 455937 455994 456693 457532 459697 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 09:49 UTC by Péter Sulyok
Modified: 2008-09-28 18:45 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-28 18:45:47 UTC


Attachments (Terms of Use)
Transcript showing the result of applying the suggested yum command. (2.45 KB, application/octet-stream)
2008-07-31 01:31 UTC, Ray Redd
no flags Details

Description Péter Sulyok 2008-06-15 09:49:32 UTC
Apparently >>>NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386.rpm<<< is missing from
the updates repositories. The other parts of this version are present.


[root@sutty ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * livna: rpm.livna.org
 * fedora: gd.tuwien.ac.at
 * updates: gd.tuwien.ac.at
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager-gnome.x86_64 1:0.7.0-0.9.4.svn3675.fc9 set to be updated
--> Processing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 for
package: NetworkManager
---> Package NetworkManager-glib.x86_64 1:0.7.0-0.9.4.svn3675.fc9 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-0.9.4.svn3675.fc9 set to be updated
--> Processing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 for
package: NetworkManager
---> Package NetworkManager.x86_64 1:0.7.0-0.9.4.svn3675.fc9 set to be updated
--> Finished Dependency Resolution
1:NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 is
needed by package 1:NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 (installed)
1:NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 is
needed by package 1:NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 (installed)
Error: Missing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 is
needed by package 1:NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 (installed)
[root@sutty ~]#

Comment 1 Jim Radford 2008-06-16 14:34:08 UTC
This error causes an error dialog in a user's face every time they try to update
their system!  This is hardly a low priority bug as it affects normal operation
of the system for every user (use use x86_64 NetworkManager and who has the i386
version installed), even if the user doesn't actually use NetworkManager.

Comment 2 Alan MacLennan 2008-06-19 18:29:20 UTC
SELinux is preventing nm-system-setti (NetworkManager_t) "getattr" to /dev/root
(fixed_disk_device_t). Detailed DescriptionSELinux denied access requested by
nm-system-setti. It is not expected that this access is required by
nm-system-setti and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access. Allowing AccessSometimes labeling
problems can cause SELinux denials. You could try to restore the default system
file context for /dev/root, restorecon -v '/dev/root' If this does not work,
there is currently no automatic way to allow this access. Instead, you can
generate a local policy module to allow this access - see FAQ Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report against this package. Additional InformationSource
Context:  system_u:system_r:NetworkManager_t:SystemLow-SystemHighTarget
Context:  system_u:object_r:fixed_disk_device_tTarget Objects:  /dev/root [
blk_file ]Source:  nm-system-settiSource
Path:  /usr/sbin/nm-system-settingsPort:  <Unknown>Host:  localhost.localdomainSource
RPM Packages:  NetworkManager-0.7.0-0.9.4.svn3675.fc9Target RPM
Packages:  Policy RPM:  selinux-policy-3.3.1-64.fc9Selinux Enabled:  TruePolicy
Type:  targetedMLS Enabled:  TrueEnforcing Mode:  EnforcingPlugin
Name:  catchall_fileHost Name:  localhost.localdomainPlatform:  Linux
localhost.localdomain 2.6.25.6-55.fc9.x86_64 #1 SMP Tue Jun 10 16:05:21 EDT 2008
x86_64 x86_64Alert Count:  1First Seen:  Thu 19 Jun 2008 08:14:47 PM BSTLast
Seen:  Thu 19 Jun 2008 08:14:47 PM BSTLocal
ID:  ddf745d1-b090-4de6-8f76-f4e8480917b3Line Numbers:  Raw Audit Messages
:host=localhost.localdomain type=AVC msg=audit(1213902887.3:12): avc: denied {
getattr } for pid=3078 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=308
scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023
tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
host=localhost.localdomain type=SYSCALL msg=audit(1213902887.3:12):
arch=c000003e syscall=4 success=no exit=-13 a0=38e405bce5 a1=7fff48beb7f0
a2=7fff48beb7f0 a3=38d4f67a70 items=0 ppid=1 pid=3078 auid=4294967295 uid=0
gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295
comm="nm-system-setti" exe="/usr/sbin/nm-system-settings"
subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null) 

Comment 3 Dan Williams 2008-06-23 14:46:12 UTC
Hmm, I see:

http://download.fedora.redhat.com/pub/fedora/linux/updates/9/i386/NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386.rpm

and it should be in other mirrors as well.  Can you check again to ensure that
the update still is missing for you?

Comment 4 Péter Sulyok 2008-06-23 17:39:00 UTC
Look at the architecture: x86_64
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/x86_64/NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386.rpm
This is missing.



Comment 5 Dan Williams 2008-06-23 18:01:35 UTC
Ok, so the issue is that NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 is
installed, and the base libraries are now split out into -libs so that it's
easier to remove NM itself without yum removing the entire desktop stack.  But
since -libs can't obsolete the main RPM, we'll need to figure out some way of
making it do the right thing.  Manually removing
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386 would work but that's obviously not
the real fix.

Comment 6 Péter Sulyok 2008-06-24 04:13:01 UTC
Hm. I see: from version 0.7.0-0.9.4 there is no i386 part for x86_64. 
After forcing the update to the new release it does not complain about removing
the .i386 package of the previous release. It was not possible to simply remove
NetworkManager package, because then other dependencies popped up. I think this
problem could be resolved at the dependency check of RPM. It should figure out
this situation and handle it in a single step.
My workaround was the following:

$ rpm -U --nodeps --force
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/x86_64/NetworkManager-0.7.0-0.9.4.svn3675.fc9.x86_64.rpm
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/x86_64/NetworkManager-glib-0.7.0-0.9.4.svn3675.fc9.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/x86_64/NetworkManager-glib-0.7.0-0.9.4.svn3675.fc9.x86_64.rpm
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/x86_64/NetworkManager-gnome-0.7.0-0.9.4.svn3675.fc9.x86_64.rpm
and then
$ rpm -e NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386


Comment 7 Dan Williams 2008-07-18 17:40:38 UTC
*** Bug 454853 has been marked as a duplicate of this bug. ***

Comment 8 Dan Williams 2008-07-18 17:41:07 UTC
*** Bug 455037 has been marked as a duplicate of this bug. ***

Comment 9 Dan Williams 2008-07-18 17:41:24 UTC
*** Bug 455178 has been marked as a duplicate of this bug. ***

Comment 10 Dan Williams 2008-07-18 17:41:37 UTC
*** Bug 455282 has been marked as a duplicate of this bug. ***

Comment 11 Dan Williams 2008-07-18 17:41:50 UTC
*** Bug 455464 has been marked as a duplicate of this bug. ***

Comment 12 Dan Williams 2008-07-18 17:42:14 UTC
*** Bug 455587 has been marked as a duplicate of this bug. ***

Comment 13 Dan Williams 2008-07-18 17:42:32 UTC
*** Bug 455632 has been marked as a duplicate of this bug. ***

Comment 14 Dan Williams 2008-07-24 22:37:56 UTC
*** Bug 455937 has been marked as a duplicate of this bug. ***

Comment 15 Dan Williams 2008-07-24 22:38:22 UTC
*** Bug 455994 has been marked as a duplicate of this bug. ***

Comment 16 Dan Williams 2008-07-24 22:38:50 UTC
*** Bug 455178 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2008-07-24 22:41:43 UTC
NetworkManager-vpnc-0.7.0-0.10.svn3846.fc9,NetworkManager-openvpn-0.7.0-15.svn3846.fc9,NetworkManager-0.7.0-0.11.svn3846.fc9 has been submitted as an update for Fedora 9

Comment 18 Michael de Mare 2008-07-24 23:17:45 UTC
This still doesn't work in FC-8.

ERROR with rpm_check_debug vs depsolve:
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8, 
this is not available.
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8, 
this is not available.
Complete!


Comment 19 Dan Williams 2008-07-25 16:14:46 UTC
Builds for F8 have just been built in Koji.

Comment 20 Dan Williams 2008-07-27 16:24:26 UTC
*** Bug 456693 has been marked as a duplicate of this bug. ***

Comment 21 Chuck Lasher 2008-07-27 21:43:55 UTC
Also, this is related to / cascaded in 455037 (marked as low priority).  
Comment #18 (above) and 455632 (which I submitted).  I have removed the VPN
features from my machine until this is resolved so I don't have to see this
being shoved in my face every time I try to do an update.

So this is broken in both FC8 and FC9 ???????



Comment 22 Dan Williams 2008-07-28 11:33:07 UTC
Chuck: it's the same problem and there are updates pending to fix this.  F8 got
hit because the update passed 3 karma and got auto-pushed to updates, which
shows that nobody with an x86-64 is using updates-testing, apparently...

Comment 23 Fedora Update System 2008-07-30 19:59:51 UTC
NetworkManager-0.7.0-0.11.svn3846.fc9, NetworkManager-vpnc-0.7.0-0.10.svn3846.fc9, NetworkManager-openvpn-0.7.0-15.svn3846.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-vpnc NetworkManager-openvpn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6761

Comment 24 Ray Redd 2008-07-31 01:31:10 UTC
Created attachment 313062 [details]
Transcript showing the result of applying the suggested yum command.  

The command was copied and pasted to prevent any typing errors.

Comment 25 Dan Williams 2008-08-01 14:04:19 UTC
*** Bug 457532 has been marked as a duplicate of this bug. ***

Comment 26 Fedora Update System 2008-08-12 02:29:43 UTC
NetworkManager-openvpn-0.7.0-15.svn3930.fc9,NetworkManager-vpnc-0.7.0-0.10.svn3928.fc9,NetworkManager-0.7.0-0.11.svn3930.fc9 has been submitted as an update for Fedora 9

Comment 27 Fedora Update System 2008-08-12 02:34:36 UTC
NetworkManager-openvpn-0.7.0-15.svn3930.fc8,NetworkManager-vpnc-0.7.0-0.10.svn3928.fc8,NetworkManager-0.7.0-0.11.svn3930.fc8 has been submitted as an update for Fedora 8

Comment 28 Dan Williams 2008-08-21 14:38:23 UTC
*** Bug 459697 has been marked as a duplicate of this bug. ***

Comment 29 Fedora Update System 2008-08-29 14:56:17 UTC
NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9

Comment 30 Fedora Update System 2008-09-02 20:41:27 UTC
NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8

Comment 31 Fedora Update System 2008-09-10 06:36:23 UTC
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7375

Comment 32 Fedora Update System 2008-09-10 06:54:26 UTC
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openvpn NetworkManager-vpnc NetworkManager-pptp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7484

Comment 33 Jaroslav Franek 2008-09-10 19:26:26 UTC
You ask for it ;-) I did a check of updates-testing on x86_64.
Seems like the bug survived all efforts:

# yum --enablerepo=updates-testing-newkey update NetworkManager*

Loaded plugins: basearchonly
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager-gnome.x86_64 1:0.7.0-0.11.svn4022.fc8 set to be updated
--> Processing Dependency: NetworkManager = 1:0.7.0-0.11.svn4022.fc8 for package: NetworkManager-gnome
---> Package NetworkManager-vpnc.x86_64 1:0.7.0-0.10.svn4024.fc8 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-0.11.svn4022.fc8 set to be updated
---> Package NetworkManager-openvpn.x86_64 1:0.7.0-15.svn4027.fc8 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0-0.11.svn4022.fc8 set to be updated
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.7.0-0.11.svn4022.fc8 set to be updated
--> Processing Dependency: dnsmasq for package: NetworkManager
--> Processing Dependency: avahi-autoipd for package: NetworkManager
--> Running transaction check
---> Package avahi-autoipd.x86_64 0:0.6.21-8.fc8 set to be updated
---> Package dnsmasq.x86_64 0:2.40-1.fc8 set to be updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0-0.10.svn4022
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0-15.svn4022
--> Finished Dependency Resolution
1:NetworkManager-0.7.0-0.11.svn4022.fc8.x86_64 from updates-testing-newkey has depsolving problems
 --> NetworkManager conflicts with NetworkManager-openvpn
1:NetworkManager-0.7.0-0.11.svn4022.fc8.x86_64 from updates-testing-newkey has depsolving problems
 --> NetworkManager conflicts with NetworkManager-vpnc
Error: NetworkManager conflicts with NetworkManager-vpnc
Error: NetworkManager conflicts with NetworkManager-openvpn

having both x86_64 and i386 packages installed:

# rpm -qa | grep NetworkManager
NetworkManager-0.7.0-0.6.7.svn3370.fc8
NetworkManager-glib-0.7.0-0.6.7.svn3370.fc8
NetworkManager-openvpn-0.7.0-8.svn3302.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8
NetworkManager-glib-0.7.0-0.6.7.svn3370.fc8
NetworkManager-0.7.0-0.6.7.svn3370.fc8
NetworkManager-openvpn-0.7.0-8.svn3302.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8

Comment 34 Fedora Update System 2008-09-28 18:42:46 UTC
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2008-09-28 18:44:38 UTC
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.