Bug 531151 - [abrt] crash detected in gnome-screensaver-2.28.0-5.fc12
[abrt] crash detected in gnome-screensaver-2.28.0-5.fc12
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
abrt_hash:8fada48eafe69a632eb01d00869...
:
: 539657 539919 540246 546802 547068 547268 547512 549202 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 21:29 EDT by ROMAN
Modified: 2015-01-14 18:23 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 15:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (8.89 KB, text/plain)
2009-10-26 21:29 EDT, ROMAN
no flags Details

  None (edit)
Description ROMAN 2009-10-26 21:29:03 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
popsquares -root 


component
-----
gnome-screensaver


executable
-----
/usr/libexec/gnome-screensaver/popsquares


kernel
-----
2.6.31.5-96.fc12.i686.PAE


package
-----
gnome-screensaver-2.28.0-5.fc12


reason
-----
Process was terminated by signal 11
Comment 1 ROMAN 2009-10-26 21:29:07 EDT
Created attachment 366190 [details]
File: backtrace
Comment 2 Bug Zapper 2009-11-16 09:23:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Ray Strode [halfline] 2009-12-02 13:13:26 EST
*** Bug 539657 has been marked as a duplicate of this bug. ***
Comment 4 Ray Strode [halfline] 2009-12-02 13:13:39 EST
*** Bug 539919 has been marked as a duplicate of this bug. ***
Comment 5 Ray Strode [halfline] 2009-12-02 13:14:42 EST
*** Bug 540246 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2009-12-12 22:49:59 EST
*** Bug 546656 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Clasen 2009-12-12 22:51:46 EST
*** Bug 546802 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Clasen 2009-12-20 21:49:18 EST
*** Bug 549202 has been marked as a duplicate of this bug. ***
Comment 9 Matthias Clasen 2009-12-20 21:50:31 EST
*** Bug 547068 has been marked as a duplicate of this bug. ***
Comment 10 Matthias Clasen 2009-12-20 21:51:20 EST
*** Bug 547268 has been marked as a duplicate of this bug. ***
Comment 11 Matthias Clasen 2009-12-20 21:52:10 EST
*** Bug 547512 has been marked as a duplicate of this bug. ***
Comment 12 Tim Taiwanese Liim 2010-05-01 00:45:50 EDT
ROMAN,
Do you still see this issue?  Now that g-ss has changed quite a bit
since Comment #0.  It (g-ss) has been working fine on my several F12
for a few months now.
Comment 13 jmccann 2010-06-07 14:46:15 EDT
Ok, so what seems to have happened here is this.

The xscreensaver-extras-gss package installs desktop files to allow gnome-screensaver to use xscreensaver "hacks".  One of these hacks has a gnome-screensaver theme with the same name: popsquares.  The xscreensaver-extras-gss desktop files apparently do not use the full path to the executable file and caused gnome-screensaver to try to execute the GNOME built-in version instead with the command line arguments meant for the xscreensaver version "-root".  The GNOME version didn't handle that argument, wouldn't properly initialize gtk, and would eventually crash.

GNOME screensaver has been patched to perform error checking on arguments.  However, xscreensaver should be changed to use full paths in its gnome-screensaver .desktop files.
Comment 14 Mamoru TASAKA 2010-06-07 15:13:36 EDT
Switching back to gnome-screensaver.

This bug is for detection of crash for gnome-screensaver popsquares,
so anyway it must be fixed in gnome-screensaver side. If you think
desktop files provided by xscreensaver-XXXX-gss should be fixed,
please file a seperated bug.
Comment 15 jmccann 2010-06-07 15:59:04 EDT
Whatever.  You should fix the code anyway.
Comment 16 Fedora Update System 2010-06-24 14:18:28 EDT
xscreensaver-5.11-5.fc13.respin1 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xscreensaver-5.11-5.fc13.respin1
Comment 17 Fedora Update System 2010-06-24 14:19:11 EDT
xscreensaver-5.11-5.fc12.respin1 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xscreensaver-5.11-5.fc12.respin1
Comment 18 Fedora Update System 2010-07-25 04:09:44 EDT
xscreensaver-5.11-8.fc13.respin1 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xscreensaver-5.11-8.fc13.respin1
Comment 19 Fedora Update System 2010-07-25 04:10:11 EDT
xscreensaver-5.11-8.fc12.respin1 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xscreensaver-5.11-8.fc12.respin1

Note You need to log in before you can comment on or make changes to this bug.