Bug 568389 - [abrt] crash in kdemultimedia-6:4.4.0-1.fc12: Process /usr/bin/kmix was killed by signal 7 (SIGBUS)
[abrt] crash in kdemultimedia-6:4.4.0-1.fc12: Process /usr/bin/kmix was kille...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
abrt_hash:f5a03f5191fd4e8ea543ae2e214...
: Triaged
: 568393 568399 568400 568401 568402 568403 568451 568479 568494 568632 568634 569916 569940 569979 570730 570740 570855 571016 571047 571182 571619 571934 572628 572830 572869 572936 573047 573103 573455 573631 573778 573913 573985 574688 574917 575213 575321 575354 575436 575554 575628 576113 576889 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-25 10:59 EST by Łukasz Łucka
Modified: 2015-07-13 13:35 EDT (History)
51 users (show)

See Also:
Fixed In Version: kdelibs-4.4.1-6.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 21:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.63 KB, text/plain)
2010-02-25 10:59 EST, Łukasz Łucka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 182026 None None None Never

  None (edit)
Description Łukasz Łucka 2010-02-25 10:59:11 EST
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: kmix -session 101b81b71b517b000126416445100000020040008_1267043423_358415
component: kdemultimedia
executable: /usr/bin/kmix
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: kdemultimedia-6:4.4.0-1.fc12
rating: 4
reason: Process /usr/bin/kmix was killed by signal 7 (SIGBUS)
release: Fedora release 12 (Constantine)
Comment 1 Łukasz Łucka 2010-02-25 10:59:14 EST
Created attachment 396309 [details]
File: backtrace
Comment 2 Kevin Kofler 2010-02-26 04:40:09 EST
*** Bug 568393 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Kofler 2010-02-26 04:46:12 EST
*** Bug 568399 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Kofler 2010-02-26 04:47:10 EST
*** Bug 568400 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Kofler 2010-02-26 04:47:34 EST
*** Bug 568401 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Kofler 2010-02-26 04:48:14 EST
*** Bug 568634 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Kofler 2010-02-26 04:48:55 EST
*** Bug 568402 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Kofler 2010-02-26 04:49:20 EST
*** Bug 568403 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Kofler 2010-02-26 04:49:49 EST
*** Bug 568451 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Kofler 2010-02-26 04:50:34 EST
*** Bug 568632 has been marked as a duplicate of this bug. ***
Comment 11 Kevin Kofler 2010-02-26 04:51:07 EST
*** Bug 568494 has been marked as a duplicate of this bug. ***
Comment 12 Kevin Kofler 2010-02-26 04:59:31 EST
*** Bug 568479 has been marked as a duplicate of this bug. ***
Comment 13 Kevin Kofler 2010-02-27 04:40:09 EST
So we got a flood of those "SIGBUS in KPixmapCache" type reports, and now no more? Is this an issue related to the upgrade process which goes away after a restart?
Comment 14 Nikolas Moraitis 2010-02-27 06:05:02 EST
i think it happened after the upgrade but i'm not 100% positive
Comment 15 prower2000 2010-02-27 08:14:47 EST
Well, I just tried installing all of the available updates for F12 and rebooting. I re-enabled the weather applet and nm-applet, enabled and disabled networking through that -- plasma-desktop crashed again in the exact same way. I don't think it's something that goes away after a restart, not in my case anyway!
Comment 16 Steven M. Parrish 2010-02-27 22:28:10 EST
Thank you for taking the time to report this issue to us.  This is an issue which is best addressed by the upstream developers.

Please file a report at bugs.kde.org , and when done add the upstream report info to this report.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Kevin Kofler 2010-03-02 12:44:18 EST
*** Bug 569916 has been marked as a duplicate of this bug. ***
Comment 18 Kevin Kofler 2010-03-02 15:45:06 EST
*** Bug 569940 has been marked as a duplicate of this bug. ***
Comment 19 Kevin Kofler 2010-03-02 16:21:18 EST
*** Bug 569979 has been marked as a duplicate of this bug. ***
Comment 20 Kevin Kofler 2010-03-05 04:07:22 EST
*** Bug 570730 has been marked as a duplicate of this bug. ***
Comment 21 Kevin Kofler 2010-03-05 05:32:03 EST
*** Bug 570740 has been marked as a duplicate of this bug. ***
Comment 22 prower2000 2010-03-05 09:49:42 EST
Is there anyone that can provide information on when this might be fixed, or if upstream knows about it at all? I had heard it mentioned somewhere that the problem is resolved in KDE 4.4.1 but that was second-hand information. :>
Comment 23 Kevin Kofler 2010-03-05 12:33:26 EST
*** Bug 570855 has been marked as a duplicate of this bug. ***
Comment 24 Kevin Kofler 2010-03-06 11:05:09 EST
*** Bug 571016 has been marked as a duplicate of this bug. ***
Comment 25 nucleo 2010-03-06 16:57:37 EST
*** Bug 571047 has been marked as a duplicate of this bug. ***
Comment 26 Kevin Kofler 2010-03-07 09:05:53 EST
*** Bug 571182 has been marked as a duplicate of this bug. ***
Comment 27 Jaroslav Reznik 2010-03-09 06:18:05 EST
*** Bug 571619 has been marked as a duplicate of this bug. ***
Comment 28 Kevin Kofler 2010-03-09 17:42:14 EST
*** Bug 571934 has been marked as a duplicate of this bug. ***
Comment 29 Kevin Kofler 2010-03-11 14:55:48 EST
*** Bug 572628 has been marked as a duplicate of this bug. ***
Comment 30 Diego 2010-03-12 03:07:59 EST

How to reproduce
-----
Don't know

Comment
-----
Crash after login.
Comment 31 Rex Dieter 2010-03-12 09:21:51 EST
Maybe some additional information from folks experiencing this would help:
0. make sure you have 
kde-settings-4.3-17
(or newer) installed.

1.  how reproducible is it?  how often does it happen?  (comment #30 thanks, that's one data point).

2.  upstream reporting has been requested already per comment #16 . to date, I'm aware of no one who is experienced this that has reported it upstream.  hint, hint. :)   (we usually request folks experiencing problems to report it directly instead of us acting as a proxy, in case upstream has any follow-up questions)
Comment 32 Kevin Kofler 2010-03-12 09:31:40 EST
*** Bug 572830 has been marked as a duplicate of this bug. ***
Comment 33 Kevin Kofler 2010-03-12 09:31:47 EST
*** Bug 572869 has been marked as a duplicate of this bug. ***
Comment 34 Kevin Kofler 2010-03-12 09:31:51 EST
*** Bug 572936 has been marked as a duplicate of this bug. ***
Comment 35 Kevin Kofler 2010-03-12 12:55:44 EST
*** Bug 573047 has been marked as a duplicate of this bug. ***
Comment 36 Kevin Kofler 2010-03-12 16:55:25 EST
*** Bug 573103 has been marked as a duplicate of this bug. ***
Comment 37 Evgeny 2010-03-14 09:38:18 EDT

How to reproduce
-----
1. open application "system settings" -> "Look & Feel" -> "Appearance" -> "Style" -> "Workplace"
2. Change theme and apply
3.
Comment 38 Kevin Kofler 2010-03-14 18:26:18 EDT
*** Bug 573455 has been marked as a duplicate of this bug. ***
Comment 39 Kevin Kofler 2010-03-15 12:40:02 EDT
*** Bug 573631 has been marked as a duplicate of this bug. ***
Comment 40 Kevin Kofler 2010-03-15 14:58:06 EDT
*** Bug 573778 has been marked as a duplicate of this bug. ***
Comment 41 Karel Volný 2010-03-15 15:12:56 EDT

How to reproduce
-----
1. resize screen on secondary display
(not a 100% reproducer, just what I did right before the crash ...)
Comment 42 haas.benjamin 2010-03-15 18:42:11 EDT

How to reproduce
-----
1. juste change the workspace theme
2. plasma seems to shutdown. I can relaunch plasma-desktop by hand, by some features are missing
3. If I reboot, i get everything working, and the workspace theme is the one I chose in 1.
Comment 43 haas.benjamin 2010-03-15 18:44:51 EDT
(In reply to comment #42)
> 
> How to reproduce
> -----
> 1. juste change the workspace theme
> 2. plasma seems to shutdown. I can relaunch plasma-desktop by hand, by some
> features are missing
> 3. If I reboot, i get everything working, and the workspace theme is the one I
> chose in 1.    

And I confirm that it does kill kmix. I can relaunch it by hand.
Comment 44 Chris R 2010-03-16 05:40:01 EDT

How to reproduce
-----
1. was changing desktop settings via the control panel....
2.
3.
Comment 45 Chris R 2010-03-16 05:42:39 EDT

How to reproduce
-----
1. no idea, i think it crashed along with KDE Base when the desktop died....
2.
3.
Comment 46 Kevin Kofler 2010-03-16 07:46:36 EDT
*** Bug 573913 has been marked as a duplicate of this bug. ***
Comment 47 Kevin Kofler 2010-03-16 07:46:49 EDT
*** Bug 573985 has been marked as a duplicate of this bug. ***
Comment 48 ozit 2010-03-16 10:15:15 EDT

How to reproduce
-----
I just reboot my PC
Comment 49 haas.benjamin 2010-03-16 13:30:25 EDT
(In reply to comment #31)
> Maybe some additional information from folks experiencing this would help:
> 0. make sure you have 
> kde-settings-4.3-17
> (or newer) installed.
> 
> 1.  how reproducible is it?  how often does it happen?  (comment #30 thanks,
> that's one data point).
> 
> 2.  upstream reporting has been requested already per comment #16 . to date,
> I'm aware of no one who is experienced this that has reported it upstream. 
> hint, hint. :)   (we usually request folks experiencing problems to report it
> directly instead of us acting as a proxy, in case upstream has any follow-up
> questions)    

 FWIW : 0.  I have kde-settings-4.3-17 installer. 
        1.  It is completely reproducible : I just have to choose the 'Air' workspace theme, and plasma crashes. It does that with some other themes, for not all of them. (so maybe a problem with some themes themselves ?)
        2. I will report it upstream.
Comment 50 Jaroslav Reznik 2010-03-17 07:30:10 EDT
KDE SVN commit 1104231 by mpyne should fix this issue - do we want test it in Rawhide?
Comment 51 Rex Dieter 2010-03-17 07:54:46 EDT
Yes, looks like upstream wants some feedback on this possible stop-gap fix, so let's give it.
Comment 52 Jaroslav Reznik 2010-03-17 08:06:09 EDT
Probably scratch F11/F12 build would be best for brave people who are willing to test it ;-)
Comment 54 Jaroslav Reznik 2010-03-17 12:51:54 EDT
I was able to reproduce this issue by changing Plasma desktop theme. I can't reproduce it now with kdelibs-4.4.1-6.fc12.x86_64.rpm. At least - there are no visible regressions. Anyone else can confirm it's not crashing any more?
Comment 55 Fedora Update System 2010-03-17 14:50:36 EDT
kdelibs-4.4.1-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kdelibs-4.4.1-6.fc13
Comment 56 Fedora Update System 2010-03-17 14:51:34 EDT
kdelibs-4.4.1-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kdelibs-4.4.1-6.fc12
Comment 57 Fedora Update System 2010-03-17 14:52:43 EDT
kdelibs-4.4.1-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kdelibs-4.4.1-6.fc11
Comment 58 Kevin Kofler 2010-03-18 04:44:15 EDT
*** Bug 574688 has been marked as a duplicate of this bug. ***
Comment 59 Kevin Kofler 2010-03-18 16:13:46 EDT
*** Bug 574917 has been marked as a duplicate of this bug. ***
Comment 60 Kevin Kofler 2010-03-19 15:02:15 EDT
*** Bug 575213 has been marked as a duplicate of this bug. ***
Comment 61 Fedora Update System 2010-03-19 23:27:36 EDT
kdelibs-4.4.1-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kdelibs-4.4.1-6.fc12
Comment 62 Kevin Kofler 2010-03-20 00:10:09 EDT
*** Bug 575321 has been marked as a duplicate of this bug. ***
Comment 63 Kevin Kofler 2010-03-20 12:21:08 EDT
*** Bug 575354 has been marked as a duplicate of this bug. ***
Comment 64 Kevin Kofler 2010-03-21 16:55:09 EDT
*** Bug 575628 has been marked as a duplicate of this bug. ***
Comment 65 Kevin Kofler 2010-03-21 16:55:20 EDT
*** Bug 575554 has been marked as a duplicate of this bug. ***
Comment 66 Fedora Update System 2010-03-22 21:57:11 EDT
kdelibs-4.4.1-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 67 Fedora Update System 2010-03-22 21:57:33 EDT
kdelibs-4.4.1-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 68 Fedora Update System 2010-03-22 22:22:58 EDT
kdelibs-4.4.1-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 69 Kevin Kofler 2010-03-23 09:28:53 EDT
*** Bug 576113 has been marked as a duplicate of this bug. ***
Comment 70 Rex Dieter 2010-03-25 11:24:23 EDT
*** Bug 576889 has been marked as a duplicate of this bug. ***
Comment 71 Kevin Kofler 2010-06-03 07:00:21 EDT
*** Bug 575436 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.