Bug 802111 - [abrt] kernel: WARNING: at net/ipv4/tcp_input.c:1951 tcp_sacktag_write_queue+0xbe4/0xbf0()
[abrt] kernel: WARNING: at net/ipv4/tcp_input.c:1951 tcp_sacktag_write_queue+...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:a765b0d5acb310b5b24e89ece3f...
:
: 802112 802660 802843 803555 803678 804355 804356 804486 804488 804928 805739 806021 806022 (view as bug list)
Depends On:
Blocks: 958243
  Show dependency treegraph
 
Reported: 2012-03-11 07:47 EDT by hristo ivanov
Modified: 2013-04-30 12:57 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 958243 (view as bug list)
Environment:
Last Closed: 2012-03-22 13:51:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description hristo ivanov 2012-03-11 07:47:38 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.2.9-1.fc16.x86_64 root=UUID=2f510ebe-fd8f-4d58-9908-c6291c5a21aa ro quiet rhgb pcie_gen2=1 SYSFONT=latarcyrheb-sun16 LANG=bg_BG.UTF-8 KEYTABLE=us-acentos
kernel:         3.2.9-1.fc16.x86_64
reason:         WARNING: at net/ipv4/tcp_input.c:1951 tcp_sacktag_write_queue+0xbe4/0xbf0()
time:           10.03.2012 (сб) 20,15,52 EET

backtrace:
:WARNING: at net/ipv4/tcp_input.c:1951 tcp_sacktag_write_queue+0xbe4/0xbf0()
:Hardware name: System Product Name
:Modules linked in: tcp_lp fuse lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables xt_physdev xt_state ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec hid_logitech_dj arc4 joydev snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer rt2800pci rt2800lib crc_ccitt rt2x00pci rt2x00lib ath5k sp5100_tco ath snd edac_core edac_mce_amd serio_raw sky2 mac80211 i2c_piix4 cfg80211 k10temp asus_atk0110 uinput soundcore eeprom_93cx6 rfkill microcode snd_page_alloc binfmt_misc sunrpc btrfs zlib_deflate libcrc32c firewire_ohci firewire_core pata_acpi ata_generic crc_itu_t pata_atiixp wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 9871, comm: vlc Tainted: G        W    3.2.9-1.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff8106e53f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106e59a>] warn_slowpath_null+0x1a/0x20
: [<ffffffff8151d824>] tcp_sacktag_write_queue+0xbe4/0xbf0
: [<ffffffff815e2b05>] ? _raw_spin_unlock_bh+0x15/0x20
: [<ffffffffa0466487>] ? tcp_packet+0x4a7/0x14e0 [nf_conntrack]
: [<ffffffff8152113e>] tcp_ack+0xc8e/0x2260
: [<ffffffff8155444a>] ? ipt_do_table+0x21a/0x680
: [<ffffffff8151e2b0>] ? tcp_validate_incoming+0x110/0x370
: [<ffffffff815234ea>] tcp_rcv_established+0x1ca/0x8b0
: [<ffffffff8152b6bf>] tcp_v4_do_rcv+0x27f/0x430
: [<ffffffff8152d490>] tcp_v4_rcv+0x610/0x8e0
: [<ffffffff81509310>] ? ip_rcv_finish+0x380/0x380
: [<ffffffff81509310>] ? ip_rcv_finish+0x380/0x380
: [<ffffffff815093ed>] ip_local_deliver_finish+0xdd/0x280
: [<ffffffff81509758>] ip_local_deliver+0x88/0x90
: [<ffffffff815090c1>] ip_rcv_finish+0x131/0x380
: [<ffffffff81509995>] ip_rcv+0x235/0x300
: [<ffffffff814d3463>] __netif_receive_skb+0x523/0x5c0
: [<ffffffff814d4060>] netif_receive_skb+0x80/0x90
: [<ffffffff814d4429>] ? dev_gro_receive+0x1b9/0x2c0
: [<ffffffff814d4170>] napi_skb_finish+0x50/0x70
: [<ffffffff814d4775>] napi_gro_receive+0xf5/0x140
: [<ffffffffa02e1833>] sky2_poll+0x6a3/0xd20 [sky2]
: [<ffffffff81065c35>] ? wake_up_process+0x15/0x20
: [<ffffffff814d49bb>] net_rx_action+0x12b/0x270
: [<ffffffff81096cc8>] ? sched_clock_cpu+0xa8/0x110
: [<ffffffff81075b68>] __do_softirq+0xb8/0x230
: [<ffffffff8101b953>] ? native_sched_clock+0x13/0x80
: [<ffffffff8101b9c9>] ? sched_clock+0x9/0x10
: [<ffffffff81096b35>] ? sched_clock_local+0x25/0x90
: [<ffffffff815ecd2c>] call_softirq+0x1c/0x30
: [<ffffffff810162f5>] do_softirq+0x65/0xa0
: [<ffffffff81075f7e>] irq_exit+0x9e/0xc0
: [<ffffffff815ed5e3>] do_IRQ+0x63/0xe0
: [<ffffffff815e2f2e>] common_interrupt+0x6e/0x6e
: <EOI>
Comment 1 Josh Boyer 2012-03-12 09:46:41 EDT
*** Bug 802112 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2012-03-15 00:37:47 EDT
*** Bug 803555 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2012-03-15 00:38:04 EDT
*** Bug 802660 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2012-03-15 00:38:09 EDT
*** Bug 802843 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2012-03-19 10:36:01 EDT
*** Bug 803678 has been marked as a duplicate of this bug. ***
Comment 6 Dave Jones 2012-03-19 10:36:07 EDT
*** Bug 804355 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2012-03-19 10:36:13 EDT
*** Bug 804356 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2012-03-19 10:36:17 EDT
*** Bug 804486 has been marked as a duplicate of this bug. ***
Comment 9 Dave Jones 2012-03-19 10:36:22 EDT
*** Bug 804488 has been marked as a duplicate of this bug. ***
Comment 10 kotofos 2012-03-19 14:50:08 EDT
do not nothing special, just watch movie in vlc. Also transmission share torrents, firefox windows open.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 11 kotofos 2012-03-20 01:27:15 EDT
when i return to my PC i see 13 notifications about problem in kernel package

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 12 Dave Jones 2012-03-20 11:13:36 EDT
*** Bug 804928 has been marked as a duplicate of this bug. ***
Comment 13 chris schoenknecht 2012-03-21 19:59:38 EDT
unknown, maybe it caused my hang?

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 14 Dave Jones 2012-03-22 10:49:00 EDT
*** Bug 805739 has been marked as a duplicate of this bug. ***
Comment 15 Dave Jones 2012-03-22 12:58:26 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 16 Dave Jones 2012-03-22 13:02:39 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 17 Dave Jones 2012-03-22 13:13:36 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 18 Dave Jones 2012-03-22 13:50:20 EDT
*** Bug 806021 has been marked as a duplicate of this bug. ***
Comment 19 Dave Jones 2012-03-22 13:50:28 EDT
*** Bug 806022 has been marked as a duplicate of this bug. ***
Comment 20 Dave Jones 2012-03-22 13:51:04 EDT
this is fixed in 3.3
Comment 21 chris schoenknecht 2012-03-22 20:36:26 EDT
just upgraded to 3.3, also changed transmission settings to allow fewer connections, (read something about that causing it) this only happened on my server, not the laptop, will keep an eye on for a while and change transmission settings back to see if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.