Bug 840149 - (MATE-DE-tracker) Tracker for MATE packages
Tracker for MATE packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Bill Nottingham
: FutureFeature, Tracking
Depends On: mate-common mate-doc-utils libmatewnck mate-corba mate-conf libmatecomponent mate-desktop mate-file-manager 844154 mate-keyring mate-vfs mate-mime-data mate-dialogs libmatenotify libmatecanvas mate-polkit mate-icon-theme libmatekbd libmateweather mate-notification-da mate-backgrounds mate-menus libmate mate-window-manager libmatecomponentui 853689 mate-settings-daemon mate-control-center mate-themes mate-panel mate-session-manager mate-comps mate-imsettings mate-power-manager
Blocks: mate-display-manager mate-terminal mate-text-editor/pluma mate-conf-editor mate-system-monitor mate-screensaver 873454 875308 python-corba python-mate mate-calc mfm-sendto mate-netspeed mfm-image-converter 882561 mate-applets
  Show dependency treegraph
 
Reported: 2012-07-13 17:38 EDT by Mario Blättermann
Modified: 2014-03-16 23:31 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 05:55:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Blättermann 2012-07-13 17:38:30 EDT
This is a tracker for handling dependencies for MATE packages in Fedora.
Comment 1 Dan Mashal 2012-07-13 17:58:07 EDT
Thanks, I'll be creating a yum repo on my FP account this weekend.
Comment 2 Mario Blättermann 2012-07-13 18:05:31 EDT
There are already MATE packages in a Yum repo at Dropbox:
http://fedoraforum.de/viewtopic.php?f=31&t=22094&p=126613&hilit=mate+16+17#p125721
Sorry, the board is in German only, but you can use the commands anyway to get access to the repo. Just a hint to avoid double work.
Comment 3 Dan Mashal 2012-07-13 18:09:49 EDT
Mario,

This is old and antiquated. Please disregard it.

http://vicodan.fedorapeople.org 

These packages were built last night.

I have spoken with Nice&Gently and he would make a great comaintainer.

Please see:

http://forums.mate-desktop.org/viewforum.php?f=8&sid=26aaf9aae7931f42612c38584886777d

and

http://forums.mate-desktop.org/viewtopic.php?f=8&t=391

Thanks,
Dan
Comment 4 Dan Mashal 2012-07-13 18:18:48 EDT
http://wiki.mate-desktop.org/buildscript

RPMs should be built in the following order:

mate-common
mate-doc-utils
mate-corba
mate-conf
libmatecomponent
mate-mime-data
mate-vfs
libmate
libmatecanvas
libmatecomponentui
libmatekeyring
mate-keyring
libmateui
libmatenotify
libmatekbd
libmateweather
mate-icon-theme
mate-dialogs
mate-desktop
mate-file-manager
mate-notification-daemon
mate-backgrounds
mate-menus
mate-window-manager
mate-polkit
mate-settings-daemon
mate-control-center
mate-panel
mate-session-manager
Comment 5 Nelson Marques 2012-07-14 11:49:48 EDT
Dan,

Before we take time to start looking at the packages (I did already looked at those I know that require a lot of attention, for example mate-conf, which is a fork of gconf2) it would be my suggestion that you do the following:

 1) install rpmlint (# yum install rpmlint);
 2) pass rpmlint on all .spec files, for example:

     for i in *.spec; do rpmlint -i $i > $i.log ; done

 3) If you install your packages, MATE won't work (I haven't installed them personally, but I'm pretty sure it won't just from looking at mate-conf).
 4) Just like in GNOME2, MATE depends heavily on it's schemas; the upstream resolution adviced to handle them (as they in debian or arch) is poor, unreliable and chaotic. RPM based distribution can do a lot better.

Generally speaking about the majority of spec I've seen:

 1) poor and innacurate descriptions (this doesn't require technical knowledge to fix)
 2) some mandatory splitting is required (ex: development packages);
 3) many of your packages are owning system directories; this can't happen. A quick example would be:
    %files
    %defattr(-,root,root,-)
    %{_bindir}
    (...)

    this should be replaced for:
    %files
    %defattr(-,root,root,-)
    %{_bindir}/*
 4) Changelog entries are not correctly generated;
 5) Packages installing public shared objected (libs) are missing the linker entries, example:
    %post FOOLIB -p /sbin/ldconfig
    %postun FOOLIB -p /sbin/ldconfig
 6) Packages with MATE schemas are not properly installing the MATE schemas (which will prevent MATE from strating up). You should consider studying the old GNOME2 packages with gconf2 schemas and see how they are implemented. In fact you should see gconf2 package from GNOME2 and build mate-conf based on the existing work of that package, since it's the most special package from a packaging point of view; while that package isn't properly fixed none of the others will work, or MATE itself.
 7) There far many more issues.

Like I said yesterday on the IRC, you should look at the work that has been previously done; I have the base from MATE all building for openSUSE[1]; take a look at my packages and you can port them all with not much trouble to Fedora (as there are tiny things that are different between SUSE and Fedora, like the shlibs/multilib policies and how they are implemented, this mainly affects package naming).

If you want an advice:

 1) Use the packages up to mate-conf to learn and to improve yourself; mate-conf is a very demanding package, so I will help you out on that one with more attention, but you will be on your own for fixing the most common issues.

 2) Take your time; the number of packages and how they are currently will make this a very long review and it might take months given the ammount of work that needs to be done. Make you understand the process.

 3) Ask for help when you need help. Even from a 'Portuguese n00b' like myself.

 4) See my packages on [1]; They will help you, and I can explain anything you don't understand. This will most likely make jump in faster.

 5) Release sources require you to run autogen.sh (to change in the future); this means you will require for most packages this:
    a) automake and autoconf
    b) libtool
    c) pkgconfig
    d) mate-common.
    I advice you to add as 'Requires' to mate-common the required packages to be able to bootstrap autogen.sh; so that in real packages when you build require mate-common it will already pulls all the stuff for ya, so you don't have to 'polute' the other spec files with it (as currently they are always required). This will be changed in 1.5.0.


There's a lot to do... just start with rpmlint on .spec's and rpm/srpm packages and start fixing things. And keep asking here what you don't understand.

I'm available to co-maintain only the packages wich involve schemas; I don't have much free and the one I have I want to have it available for my own packages on Fedora, but I'll make an effort to help you with them since errors on those packages will create huge negative impact.

[1] - https://build.opensuse.org/project/show?project=GNOME%3ACinnamon%3AMATE

PS: You can't use most of the macros I use on SUSE because they don't exist in Fedora, and even those packages provide a working MATE install on openSUSE, it needs still a few more tens of ours of work.

As additional information, I've spoken to Stefano a few days ago, and from 1.5.0 onwards we will provide source releases already with 'make dist'; We are introducing this to help you ;)
Comment 6 Dan Mashal 2012-07-16 18:41:13 EDT
Adding spot's comments here so they don't get lost in the other bug:

"Tom "spot" Callaway 2012-07-15 14:53:30 EDT

We probably cannot distribute "nyan cat" in source format either, without permission from the copyright holder. I have not looked at the source code at all, however, if only the image of "pop tart cat" is being used here, you may wish you ask the copyright holder (prguitarman <pr@prguitarman.com>) for permission.

The alternative would be to simply remove the "nyan cat" content from the source tarball entirely and make a "clean" tarball."
Comment 7 Wolfgang Ulbrich 2012-07-19 11:53:18 EDT
@ nyan cat
I patched this cat away today!
A test build from mate-desktop is working well.

patch:
https://dl.dropbox.com/u/49862637/Mate-desktop/mate-desktop_remove_nyan-cat.patch

mate-about:
https://dl.dropbox.com/u/49862637/Mate-desktop/mate-about.png
Comment 8 Nelson Marques 2012-07-19 15:34:38 EDT
The nyan-cat is going to be dropped from MATE soon.
Comment 9 Steve Zesch 2012-07-19 19:57:43 EDT
nyan-cat has been removed and a new version of mate-desktop (1.4.1) has been uploaded to http://pub.mate-desktop.org/releases/1.4
Comment 10 Wolfgang Ulbrich 2012-07-19 20:07:32 EDT
thx Steve for quick response :)
Comment 11 Dan Mashal 2012-07-19 22:34:46 EDT
cool, thanks, one less blocker to worry about!
Comment 12 Tom "spot" Callaway 2012-07-27 13:05:47 EDT
Are there any other Legal concerns here except for Nyan Cat (already nuked)?
Comment 13 Dan Mashal 2012-07-27 14:00:01 EDT
Not that I know of right now spot. Maybe you can do a final review after the group is completed? Otherwise feel free to clear the legal blocker. Thanks.
Comment 14 Tom "spot" Callaway 2012-07-27 14:16:52 EDT
Lifting FE-Legal. Feel free to block any specific component which has any concerns.
Comment 15 Mario Blättermann 2012-08-21 13:21:38 EDT
Due to continuing problems within the packagers group which maintains the MATE packages, I stop working on this. Well, I'm the reporter of this bug, and actually I'm willing to close it, but I keep it open anyway. Maybe we get a second chance in the future. For now, I don't expect to get a working MATE in Fedora within a reasonable time.
Comment 16 Michael Scherer 2012-08-24 06:55:00 EDT
Since there is lots of packages who are not ready on the feature page, and since lots of them were closed as "won't fix", I am wondering how we can really say that the feature is ready to 85%, especially since the (IMHO) main package, ie mate-windows-manager is not ready ( so that's quite hard to test without having this one properly packaged ).

I counted around 30 rpms, and 10 are not ready, so the number would surely be more closer to 60% than 85%.

This would mean the feature would be dropped, according to http://fedoraproject.org/wiki/Features/Policy/Dropping
Comment 17 Dan Mashal 2012-08-24 06:56:15 EDT
Excuse me but, there are 4 packages left to be packaged. Please reread the wiki page, Michael.
Comment 18 Dan Mashal 2012-08-24 06:57:19 EDT
In addition to my last comment the delay was caused by dependencies being pushed to testing and buildroot overrides, the branch to Alpha for Fedora 18. Mate Notification Daemon is currently being built and pushed to updates-testing. Thank you for your concern Michael.
Comment 19 Dan Mashal 2012-08-24 07:35:12 EDT
Please also note that testing of MATE-Desktop on Fedora 18 is impossible since Fedora 18 is unstable, and anaconda does not work so you cannot install Fedora 18, nor boot it properly, thus proper testing is impossible.


As of 08-24-2012 4:32AM PST the following packages are in the Fedora 17 STABLE repo:

libmatecanvas.i686 : MateCanvas widget
libmatecanvas.x86_64 : MateCanvas widget
libmatecanvas-devel.i686 : Libraries and headers for libmatecanvas
libmatecanvas-devel.x86_64 : Libraries and headers for libmatecanvas
libmatekeyring-devel.i686 : Development files for libmate-keyring
libmatekeyring-devel.x86_64 : Development files for libmate-keyring
libmatenotify.i686 : Libraries for mate notify
libmatenotify.x86_64 : Libraries for mate notify
libmatenotify-devel.i686 : Development libraries for libmatenotify
libmatenotify-devel.x86_64 : Development libraries for libmatenotify
libmatewnck.i686 : MATE Desktop Window Navigator Construction Kit libraries
libmatewnck.x86_64 : MATE Desktop Window Navigator Construction Kit libraries
libmatewnck-devel.i686 : Development libraries and headers for libmatewnck
libmatewnck-devel.x86_64 : Development libraries and headers for libmatewnck
mate-backgrounds.noarch : MATE Desktop backgrounds
mate-common.noarch : mate common build files
mate-conf-devel.i686 : Headers and libraries for mate-conf development
mate-conf-devel.x86_64 : Headers and libraries for mate-conf development
mate-conf-gtk.x86_64 : Graphical mate-conf utilities
mate-corba.i686 : CORBA Object Request Broker for MATE Desktop
mate-corba.x86_64 : CORBA Object Request Broker for MATE Desktop
mate-corba-devel.i686 : Development libraries, header files and utilities for
                      : mate-corba
mate-corba-devel.x86_64 : Development libraries, header files and utilities for
                        : mate-corba
mate-doc-utils.noarch : MATE Desktop doc utils
mate-icon-theme.noarch : Icon theme for MATE Desktop
mate-icon-theme-devel.noarch : Development files for mate-icon-theme
mate-menus.i686 : Displays menus for MATE Desktop
mate-menus.x86_64 : Displays menus for MATE Desktop
mate-menus-devel.i686 : Development files for mate-menus
mate-menus-devel.x86_64 : Development files for mate-menus
mate-menus-libs.i686 : Shared libraries for mate-menus
mate-menus-libs.x86_64 : Shared libraries for mate-menus
mate-backgrounds.noarch : MATE Desktop backgrounds
mate-common.noarch : mate common build files
mate-conf-devel.i686 : Headers and libraries for mate-conf development
mate-conf-devel.x86_64 : Headers and libraries for mate-conf development
mate-conf-gtk.x86_64 : Graphical mate-conf utilities
mate-corba.i686 : CORBA Object Request Broker for MATE Desktop
mate-corba.x86_64 : CORBA Object Request Broker for MATE Desktop
mate-corba-devel.i686 : Development libraries, header files and utilities for
                      : mate-corba
mate-corba-devel.x86_64 : Development libraries, header files and utilities for
                        : mate-corba
mate-doc-utils.noarch : MATE Desktop doc utils
mate-icon-theme.noarch : Icon theme for MATE Desktop
mate-icon-theme-devel.noarch : Development files for mate-icon-theme
mate-menus.i686 : Displays menus for MATE Desktop
mate-menus.x86_64 : Displays menus for MATE Desktop
mate-menus-devel.i686 : Development files for mate-menus
mate-menus-devel.x86_64 : Development files for mate-menus
mate-menus-libs.i686 : Shared libraries for mate-menus
mate-menus-libs.x86_64 : Shared libraries for mate-menus


mate-notification-daemon was just pushed to updates-pending
Comment 20 Michael Scherer 2012-08-24 08:09:53 EDT
I see, from this bug report depency  : 
mate-control-center , not pushed, closed as won't fix

mate-screensaver, not pushed, closed as won't fix

mate-system-monitor, not pushed, close as won't fix

mate-mime-data, not pushed, close as won't fix

libmatekbd, review not started

libmateweather, review not started

mate-settings-daemon, still in review

mate-window-manager, closed as won't fix

that's 8 packages. And the feature is for F18, pushing this to f17 and F16 now is IMHO not a great idea, especially if the feature is postponed because not testable by alpha and under 85% ( especially if more than half of the team go away ).

And for installing fedora 18, I am able to do a upgrade from f17, and I would expect someone packaging a complete DE to do the same.
Comment 21 Dan Mashal 2012-08-24 20:06:11 EDT
>And for installing fedora 18, I am able to do a upgrade from f17, and I would >
>expect someone packaging a complete DE to do the same.

Done it already a few times. It is not even in Alpha yet.
Comment 22 Dan Mashal 2012-08-26 21:38:40 EDT
>Michael Scherer 2012-08-24 05:09:53 PDT
>I see, from this bug report depency  : 
>mate-screensaver, not pushed, closed as won't fix

Not part of MATE Desktop base repo, or needed for MATE desktop to work.

>>Michael Scherer 2012-08-24 05:09:53 PDT
>mate-mime-data, not pushed, close as won't fix

Repushed via bodhi.

>Michael Scherer 2012-08-24 05:09:53 PDT
>libmatekbd, review not started

Package approved.

>Michael Scherer 2012-08-24 05:09:53 PDT
>libmateweather, review not started

Package approved.

>Michael Scherer 2012-08-24 05:09:53 PDT
>mate-window-manager, closed as won't fix

Rebuilt from scratch and approved.
Comment 23 markm 2012-11-29 07:12:09 EST
Not sure if it's a right place, I've just installed fresh Fedora 18 in a virtual machine, with Mate-Desktop selected as a DE, got open box installed with no applications - was quite surprised to see empty desktop with no icons, no information whatsoever. Expected mate-desktop to be fully functional desktop, not broken.
Comment 24 markm 2012-11-29 07:23:46 EST
(In reply to comment #23)
> Not sure if it's a right place, I've just installed fresh Fedora 18 in a
> virtual machine, with Mate-Desktop selected as a DE, got open box installed
> with no applications - was quite surprised to see empty desktop with no
> icons, no information whatsoever. Expected mate-desktop to be fully
> functional desktop, not broken.

please ignore my comment, my bad - I must have selected open box instead of mate, tried again and all installed smoothly.
Comment 25 Dan Mashal 2013-03-20 05:55:41 EDT
All packages approved.

Note You need to log in before you can comment on or make changes to this bug.