Bug 106563 - OpenOffice.org start-up menus in wrong place
OpenOffice.org start-up menus in wrong place
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
David Lawrence
:
: 106740 106967 106989 107126 107509 107520 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-08 09:30 EDT by Tim Waugh
Modified: 2007-04-18 12:58 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-31 10:23:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2003-10-08 09:30:24 EDT
Description of problem:
The menu items for starting OpenOffice.org components are in Red
Hat->Office->More Office Applications, instead of Red Hat->Office.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-1
Comment 1 Dan Williams 2003-10-10 17:27:13 EDT
Actual bug was that redhat-menus was not in the BuildRequires section of the
specfile, so the build farm here at Red Hat didn't install it, and therefore
there were no .desktop files to package up in the RPM.  Will be fixed in 1.1.0-3.
Comment 2 Dan Williams 2003-10-10 17:27:42 EDT
*** Bug 106740 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2003-10-14 01:08:05 EDT
*** Bug 106967 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2003-10-14 09:07:22 EDT
*** Bug 106989 has been marked as a duplicate of this bug. ***
Comment 5 Dan Williams 2003-10-15 09:15:11 EDT
*** Bug 107126 has been marked as a duplicate of this bug. ***
Comment 6 Elton Woo 2003-10-17 13:36:13 EDT
To get the menu items in Gnome one has to either run /usr/lib/openoffice/setup
or launch oowriter from a console. However, though this adds the entries to the
Gnome desktop menu, *but* they do not get added to the KDE menus.
Comment 7 Dan Williams 2003-10-20 09:41:52 EDT
*** Bug 107520 has been marked as a duplicate of this bug. ***
Comment 8 Dan Williams 2003-10-20 09:42:01 EDT
*** Bug 107509 has been marked as a duplicate of this bug. ***
Comment 9 Rex Dieter 2003-10-22 12:25:48 EDT
I propose openoffice install global applnk/mimelnk/icons, and disable local
installations of these files.

Add/modify to specfile to inclue:
################################################
## APPLNK
# patch kde's applnk files
pushd %{buildroot}%{_libdir}/openoffice/share/kde/net
perl -pi -e 's@.xpm@@g' *.desktop
popd
# desktop-file case
%if "%{?desktop_file}" == "1"
mkdir -p %{buildroot}%{_datadir}/applications
for i in openoffice-printeradmin openoffice-setup \
         redhat-drawing redhat-math redhat-presentations redhat-word-processor \
         redhat-spreadsheet; do
  ln -sf %{_datadir}/desktop-menu-patches/$i.desktop
%{buildroot}%{_datadir}/applications/$i.desktop
done
rm -rf %{buildroot}%{_datadir}/applnk
rm -rf %{buildroot}%{_datadir}/gnome
%else
# non-desktop-file case
mkdir -p "%{buildroot}/%{_sysconfdir}/X11/applnk/Office/OpenOffice.org %{version}/"
cp -alf %{buildroot}%{_libdir}/openoffice/share/kde/net/*.desktop \
        "%{buildroot}/%{_sysconfdir}/X11/applnk/Office/OpenOffice.org %{version}/"
%endif

## ICONS
# Extract 48x48 PNGs for use by GNOME and Nautilus
# (Nautilus needs pngs under %{_datadir}/pixmaps)
mkdir -p %{buildroot}%{_datadir}/pixmaps
tar --directory %{buildroot}%{_datadir}/pixmaps/ -xjvf %{SOURCE4}
# KDE
mkdir -p %{buildroot}%{_datadir}/icons
cp -alf %{buildroot}%{_libdir}/openoffice/share/kde/net/share/icons/* \
        %{buildroot}%{_datadir}/icons/

## MIME-types
# KDE
mkdir -p %{buildroot}%{_datadir}/mimelnk
# copy to global location
cp -af  %{buildroot}%{_libdir}/openoffice/share/kde/net/share/mimelnk/* \
        %{buildroot}%{_datadir}/mimelnk/

## Fix instdb.ins, to *not* install local copies of these
for entry in Kdeapplnk Kdemimetext Kdeicons Gnome_Apps Gnome_Icons Gnome2_Apps; do
perl -pi -e "/^File gid_File_Extra_$entry/ .. /^End/ and (\
  s|^\tSize\s+\= .*|\tSize\t\t = 0;\r| or \
  s|^\tArchiveFiles\s+\= .*|\tArchiveFiles\t = 0;\r| or \
  s|^\tArchiveSize\s+\= .*|\tArchiveSize\t = 0;\r| or \
  s|^\tContains\s+\= .*|\tContains\t = ();\r| or \
  s|\t\t\t\t\t\".*|\r|g)" \
  %{buildroot}%{_libdir}/openoffice/program/instdb.ins
done


###################################3
Then add to %files:
# applnk files
%if "%{?desktop_file}" == "1"
%{_datadir}/applications/*
%else
%{_sysconfdir}/X11/applnk/Office
%endif
# mimelnk files
%{_datadir}/mimelnk/*/*
# icon files
%{_datadir}/pixmaps/*
%{_datadir}/icons/*/*/*

Comment 10 Dan Williams 2003-10-31 10:23:42 EST
Rex Dieter, your patch has largely been incorporated into 1.1.0-4. 
Thanks for the scripts.  This bug should be fixed in 1.1.0-4, though
people will need to "rm -f
~/.gnome2/vfolders/applications/ooo645*.desktop" to remove the
duplicate entries.

Dan

Note You need to log in before you can comment on or make changes to this bug.