Bug 409351 - Connecting to VPN fails
Connecting to VPN fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
: Regression
: 395141 410371 411411 411561 412471 412791 414401 415171 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 15:52 EST by Bryan Kearney
Modified: 2008-01-06 20:18 EST (History)
24 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.6.svn3138.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 20:18:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug Report (1.35 KB, text/plain)
2007-12-03 15:52 EST, Bryan Kearney
no flags Details
nm-vpn-properties bug report (17.89 KB, application/x-bzip)
2007-12-05 11:29 EST, George Billios
no flags Details
crash report from editing vpnc settings (9.24 KB, text/plain)
2007-12-06 12:00 EST, Jeff Bastian
no flags Details
crash report from trying to make vpnc connection (7.28 KB, text/plain)
2007-12-06 12:01 EST, Jeff Bastian
no flags Details
crash report from editing vpnc settings (take 2) (46.04 KB, text/plain)
2007-12-06 12:18 EST, Jeff Bastian
no flags Details
crash report from trying to make vpnc connection (take 2) (30.52 KB, text/plain)
2007-12-06 12:19 EST, Jeff Bastian
no flags Details
Bug report after trying to edit settings (331.88 KB, text/plain)
2007-12-07 14:38 EST, Michael Dugger
no flags Details
Bug report for attempt after reboot (348.50 KB, text/plain)
2007-12-08 08:15 EST, Bryan Kearney
no flags Details

  None (edit)
Description Bryan Kearney 2007-12-03 15:52:15 EST
Description of problem:
Connecting to a vpn, in wireless, fails.

Version-Release number of selected component (if applicable):
Fedora 8. RPMs:
NetworkManager-0.7.0-0.6.6.svn3109.fc8
NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-glib-0.7.0-0.5.svn3030.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8


How reproducible:
Updated to most current released fedora 8.

Steps to Reproduce:
1. Disconnect enhernet cord.
2. Connect to wireless access
3. select VPN from Network Manager
4) See bug report.

  
Additional info:
Bug report is attached.
Comment 1 Bryan Kearney 2007-12-03 15:52:15 EST
Created attachment 276181 [details]
Bug Report
Comment 2 Denis Leroy 2007-12-03 17:12:46 EST
Could you first try to connect manually with the vpnc command ? It's very
simple, usually something like

  vpnc --gateway vpn.foo.com --id group_name --username yourusername

This to make sure this is indeed a NM-vpnc problem rather than a vpnc one. Also,
seeing the bug report, could you give me the content of 

gconftool-2 -R /system/networking/connections/1

(assuming 1 is indeed the number of the right connectino directory, it should
have a vpn and vpn-properties directory).

thanks :-)
Comment 3 Nils Philippsen 2007-12-04 07:52:52 EST
Running vpnc manually works here. Trying to connect to the VPN with NM-vpnc
crashes nm-applet here. With a freshly run nm-applet I don't get messages in
.xsession-errors, but one in /var/log/messages:

Dec  4 13:46:43 gibraltar NetworkManager: nm-vpn-connection.c.661: NeedSecrets
failed: g-exec-error-quark Could not process the request because the VPN
connection settings were invalid.

This only happened after I updated to NetworkManager-0.7.0-0.6.6.svn3109.fc8.
Comment 4 Denis Leroy 2007-12-04 07:55:28 EST
Yowza!! You need to also update to NetworkManager-vpnc svn3109. The person who
pushed NM 3109 to stable forgot to also push NM-vpnc 3109. I just pushed it to
stable, but for the time being you can download it from testing.
Comment 5 Bryan Kearney 2007-12-04 08:03:40 EST
I was able to run vpnc from my machine, and was able to reprouce the bug by just
getting the connection information from the NM applet.
Comment 6 Nils Philippsen 2007-12-04 08:18:56 EST
nils@gibraltar:~> rpm -qa NetworkManager\*
NetworkManager-gnome-0.7.0-0.6.6.svn3109.fc8
NetworkManager-0.7.0-0.6.6.svn3109.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8

This was logged in /var/log/messages when I tried to start a newly configured
VPN connection:

Dec  4 14:16:44 gibraltar NetworkManager: nm-vpn-connection.c.661: NeedSecrets
failed: g-exec-error-quark Could not process the request because the VPN
connection settings were invalid.
Dec  4 14:16:44 gibraltar NetworkManager: <info>  Deactivating device eth0.
Dec  4 14:16:44 gibraltar NetworkManager: <info>  eth0: canceled DHCP
transaction, dhclient pid 9616
Dec  4 14:16:44 gibraltar avahi-daemon[2519]: Withdrawing address record for
192.168.195.119 on eth0.
Dec  4 14:16:44 gibraltar avahi-daemon[2519]: Leaving mDNS multicast group on
interface eth0.IPv4 with address 192.168.195.119.
Dec  4 14:16:44 gibraltar avahi-daemon[2519]: Interface eth0.IPv4 no longer
relevant for mDNS.
Dec  4 14:16:44 gibraltar avahi-daemon[2519]: Withdrawing address record for
fe80::21c:23ff:fea5:1165 on eth0.
Comment 7 Robert Locke 2007-12-04 08:47:38 EST
I have also updated to the "released" updates version of packages and began to
experience the crashing of nm-applet.  I grabbed the NetworkManager-vpnc from
updates-testing and now match Nils and still have nm-applet crashing when I try
to establish a vpnc connection.
Comment 8 Nils Philippsen 2007-12-04 08:59:39 EST
Just for the record, nm-applet crashes with me as well.
Comment 9 Denis Leroy 2007-12-04 09:28:20 EST
nm-applet is part of NetworkManager. Reassigning. 

Also, please verify the bug with all svn3109 versions. For the record, it works
for me no problem here on f-8:

NetworkManager-0.7.0-0.6.6.svn3109.fc8
NetworkManager-glib-devel-0.7.0-0.6.6.svn3109.fc8
NetworkManager-devel-0.7.0-0.6.6.svn3109.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
Comment 10 Nils Philippsen 2007-12-04 09:45:24 EST
(In reply to comment #9)

> Also, please verify the bug with all svn3109 versions.

As per comment #6, it seems I've done that already ;-).
Comment 11 Dan Williams 2007-12-04 09:49:37 EST
jkeating and I debugged this last night.  It's valid and we'll issue an update
to correct the problem.  The vpnc plugin may _not_ need to be updated; it may be
isolated to NM itself (libnm-util really).
Comment 12 Dan Williams 2007-12-04 09:50:53 EST
*** Bug 410371 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2007-12-04 14:34:44 EST
*** Bug 395141 has been marked as a duplicate of this bug. ***
Comment 14 Denis Leroy 2007-12-05 03:02:15 EST
*** Bug 411411 has been marked as a duplicate of this bug. ***
Comment 15 Denis Leroy 2007-12-05 03:02:59 EST
*** Bug 411561 has been marked as a duplicate of this bug. ***
Comment 16 Nils Philippsen 2007-12-05 03:59:46 EST
Same error with:

NetworkManager-glib-0.7.0-0.6.6.svn3134.fc8    \
NetworkManager-gnome-0.7.0-0.6.6.svn3134.fc8    > from Koji
NetworkManager-0.7.0-0.6.6.svn3134.fc8         /
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
Comment 17 Denis Leroy 2007-12-05 06:17:24 EST
Same here, also with rebuild NM-vpnc with svn3134. I'm able to edit the vpn
properties, but trying to connect still crashes nm-applet.
Comment 18 George Billios 2007-12-05 11:29:21 EST
Created attachment 278511 [details]
nm-vpn-properties bug report
Comment 19 George Billios 2007-12-05 11:29:42 EST
After the latest upgrade to NetworkManager I also experience problem connecting
with vpnc.

The applet doesn't crash but I get the same syslog messages that the settings
are invalid. I then started the nm-vpm-properties program, deleted the
connection and created a new one but the program crashed after I pressed apply. 

I attached the bug report above.
Comment 20 Denis Leroy 2007-12-05 14:01:16 EST
*** Bug 412471 has been marked as a duplicate of this bug. ***
Comment 21 Dan Williams 2007-12-05 14:26:37 EST
133t h0t bitz:

http://koji.fedoraproject.org/koji/taskinfo?taskID=276538

If everyone could try it out and report back.  If the VPN connection you want
isn't shown in the menu, please choose the "Configure VPN..." option and update
the connection details through the VPN connection editor applet.
Comment 22 Bryan Che 2007-12-05 14:40:41 EST
I just installed these rpm's, and they don't fix my problem.  When I try to
connect to the vpn via NetworkManager, the applet no longer crashes.  But, it
doesn't connect either--nothing happens.

Also, when I go to edit a vpn connection, the preferences dialog box crashes.
Comment 23 Dan Williams 2007-12-05 14:58:38 EST
You'll need to restart NetworkManager and pkill the applet, then start the
applet again.  Or reboot.  Did you do either of those?
Comment 24 Bryan Che 2007-12-05 15:02:09 EST
I rebooted before trying this--it didn't work after reboot.
Comment 25 Dan Poler 2007-12-05 15:11:04 EST
Same - with updated pkgs from koji:

** (nm-applet:24501): WARNING **: nm_object_get_property: Error getting 'Name'
for /org/freedesktop/NetworkManager/VPN/Connection/0: Method "Get" with
signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist



** (nm-applet:24501): WARNING **: nm_object_get_property: Error getting 'Name'
for /org/freedesktop/NetworkManager/VPN/Connection/0: Method "Get" with
signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist



** (nm-applet:24501): CRITICAL **: add_one_vpn_connection: assertion `name !=
NULL' failed
Comment 26 Dan Williams 2007-12-05 15:14:24 EST
@bche: can you get a backtrace of the VPN properties applet?  it's going to be
"nm-vpn-properties".  Please install both the NetworkManager-debuginfo and the
NetworkManager-vpnc-debuginfo.

@dan poler: can you try editing the connection from the VPN properties applet? 
That should fix up that problem.
Comment 27 Dan Poler 2007-12-05 15:28:37 EST
@dcbw: Hitting "Configure" in nm-vpn-properties causes it to crash.
Comment 28 Dan Williams 2007-12-05 15:39:17 EST
@dan poler: you mean choosing Configure VPN..., letting the VPN properties
applet run, selecting the VPN connection you want to edit, and clicking the
"Edit.." button on the right side of the window?

Could you report the version of NetworkManager-vpnc that you are using?  If you
don't hae at least NetworkManager-vpnc-0.7.0.svn3109 please update to the latest
in updates-testing.
Comment 29 Dan Williams 2007-12-05 15:39:49 EST
*** Bug 412791 has been marked as a duplicate of this bug. ***
Comment 30 Dan Poler 2007-12-05 15:53:28 EST
@dcbw: behavior is exactly as you described, yes.
Will update NetworkManager-vpnc and try again later on.

Comment 31 Didier G 2007-12-05 16:16:20 EST
With following modules 

NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8
NetworkManager-0.7.0-0.6.6.svn3138.fc8

I am now able to start VPN a first time but after I disconnect I cannot
reconnect using the same VPN. 
Comment 32 Dan Williams 2007-12-05 16:27:25 EST
@didier g: reconnecting works for me here; can you post some NetworkManager log
output from /var/log/messages about what happens when it fails?
Comment 33 Didier G 2007-12-05 17:30:15 EST
That is what happen when I have problem to reconnect :

Dec  5 23:24:05 qwerty NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' exec scheduled...
Dec  5 23:24:05 qwerty NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' executed
(org.freedesktop.NetworkManager.vpnc), PID 6680
Dec  5 23:24:06 qwerty NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Dec  5 23:24:06 qwerty NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Dec  5 23:24:06 qwerty NetworkManager: nm_vpn_connection_activate: assertion
`nm_vpn_connection_get_state (connection) == NM_VPN_CONNECTION_STATE_PREPARE' failed
Dec  5 23:24:06 qwerty NetworkManager: <info>  VPN connection 'vpn.qwerty'
(Connect) reply received.
Dec  5 23:24:06 qwerty kernel: tun0: Disabled Privacy Extensions
Dec  5 23:24:07 qwerty NetworkManager: <WARN>  connection_state_changed(): Could
not process the request because no VPN connection was active.
Comment 34 Denis Leroy 2007-12-05 17:35:05 EST
Dan, works here now, and without recompiling NM-vpnc.

The reconnection problem is another bug (332821), and the behavior hasn't
changed there.
Comment 35 Nils Philippsen 2007-12-06 06:59:01 EST
With:

NetworkManager-0.7.0-0.6.6.svn3138.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8

I restarted the daemon as well as the applet. When trying to start freshly
configured VPN connection, I don't get any reaction from the applet (no "lock"
throbber, no password questions) and the following in /var/log/messages:

Dec  6 12:57:08 gibraltar NetworkManager: nm-vpn-connection.c.661: NeedSecrets
failed: g-exec-error-quark Could not process the request because the VPN
connection settings were invalid.
Comment 36 Dan Williams 2007-12-06 07:13:24 EST
@nils, bche:  Can you try to update to:

https://admin.fedoraproject.org/updates/F8/FEDORA-2007-3839

I had thought this was already pushed to stable.  Yes, we do need to be a lot
better about updating the VPN plugins and NM in sync.  After installing this
(make sure nm-vpnc-service is killed, but you don't need to restart), edit the
connection again to ensure that it's OK and then try to restart the VPN.
Comment 37 Nils Philippsen 2007-12-06 07:52:48 EST
Largely works for me with NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8. One minor
nit, the icon sometimes seems a bit confused: at one occasion I started a VPN
connection, then the icon went "not connected" even though clicking on it showed
that a wired LAN connection and a VPN connection were active.
Comment 38 Brian Long 2007-12-06 09:32:27 EST
I have the same issue as #37 after updating to the same RPM versions.  I can
successfully add a VPN connection and connect, but the icon never shows the
padlock like it would in NM 0.6.5.
Comment 39 Bryan Che 2007-12-06 09:33:58 EST
After installing https://admin.fedoraproject.org/updates/F8/FEDORA-2007-3839, I
am able to connect to the vpn.
Comment 40 Jeff Bastian 2007-12-06 11:38:48 EST
I'm also having issues with vpnc after upgrading to 0.7.0-0.6.6.svn3109.fc8.  I
  currently have:
  NetworkManager-0.7.0-0.6.6.svn3109.fc8.i386
  NetworkManager-0.7.0-0.6.6.svn3109.fc8.x86_64
  NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8.i386
  NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8.x86_64
  NetworkManager-gnome-0.7.0-0.6.6.svn3109.fc8.x86_64
  NetworkManager-openvpn-0.7.0-2.svn3047.fc8.i386
  NetworkManager-openvpn-0.7.0-2.svn3047.fc8.x86_64
  NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.i386
  NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.x86_64

The openvpn packages are older, but I'm not using openvpn, so hopefully that
doesn't matter.

If I launch 'nm-applet' from a terminal and try to make a vpnc connection, I see
this in the terminal:
   ** (nm-applet:4039): WARNING **: nm_object_get_property: Error getting 'Name'
   for /org/freedesktop/NetworkManager/VPN/Connection/4: Method "Get" with
   signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

   ** (nm-applet:4039): WARNING **: nm_object_get_property: Error getting 'Name'
   for /org/freedesktop/NetworkManager/VPN/Connection/4: Method "Get" with
   signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

And this appears in /var/log/messages:
   Dec  6 10:29:33 tarantula NetworkManager: nm-vpn-connection.c.661:
   NeedSecrets failed: g-exec-error-quark Could not process the request because
   the VPN connection settings were invalid.

And then nm-applet crashes.

After restarting nm-applet, I tried to edit my vpnc settings and got this:
   ** ERROR **: file nm-vpnc.c: line 288 (impl_get_widget): assertion failed:
   (s_vpn_props)
   aborting...
Comment 41 Jeff Bastian 2007-12-06 12:00:18 EST
Created attachment 279951 [details]
crash report from editing vpnc settings

I removed the i386 packages from my system and installed the debuginfo packages
for NetworkManager and NetworkManager-vpnc.  I captured two crash reports. 
This is from trying to edit my vpnc settings.
Comment 42 Jeff Bastian 2007-12-06 12:01:40 EST
Created attachment 279971 [details]
crash report from trying to make vpnc connection

This crash report is from actually trying to make a vpnc connection.  The first
attempt to connect fails, but nm-applet does not crash.  The second attempt to
connect causes nm-applet to crash and generated this report.
Comment 43 Jeff Bastian 2007-12-06 12:18:39 EST
Created attachment 280011 [details]
crash report from editing vpnc settings (take 2)

I installled the glib2, gtk2, and glibc debuginfo packages to get more detailed
backtraces.  Here is a new backtrace from trying to edit my vpnc settings.
Comment 44 Jeff Bastian 2007-12-06 12:19:42 EST
Created attachment 280021 [details]
crash report from trying to make vpnc connection (take 2)

And here is a more detailed backtrace from trying to make a vpnc connection.
Comment 45 Dan Williams 2007-12-06 12:20:57 EST
jbastian: can you try to install the RPMs from here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=276538

and from here for NetworkManager-vpnc:

https://admin.fedoraproject.org/updates/F8/FEDORA-2007-3839

and report how that works out?
Comment 46 Jeff Bastian 2007-12-06 12:38:27 EST
Ahh, that's much better!  I can make vpnc connections now!  Thank you!

I now have:
NetworkManager-0.7.0-0.6.6.svn3138.fc8.x86_64
NetworkManager-debuginfo-0.7.0-0.6.6.svn3138.fc8.x86_64
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8.x86_64
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8.x86_64
NetworkManager-openvpn-0.7.0-2.svn3047.fc8.x86_64
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.x86_64
NetworkManager-vpnc-debuginfo-0.7.0-0.6.3.svn3109.fc8.x86_64


Comment 47 Jeff Bastian 2007-12-06 12:41:30 EST
(And I can edit my vpnc settings, too.)
Comment 48 Denis Leroy 2007-12-06 17:20:58 EST
*** Bug 414401 has been marked as a duplicate of this bug. ***
Comment 49 Denis Leroy 2007-12-07 03:18:55 EST
*** Bug 415171 has been marked as a duplicate of this bug. ***
Comment 50 Christopher J. Buckley 2007-12-07 06:02:10 EST
It seems that NetworkManager-vpnc is bogusly called... If I run NetworkManager
and I ask a VPNc connection I obtain:
--
NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' exec
scheduled...
NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc'
executed (org.freedesktop.NetworkManager.vpnc), PID 2900
kernel: tun: Universal TUN/TAP device driver, 1.6
kernel: tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' just
appeared, activating connections
NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' just
appeared, activating connections
NetworkManager: nm_vpn_connection_activate: assertion
`nm_vpn_connection_get_state (connection) == NM_VPN_CONNECTION_STATE_PREPARE' failed
NetworkManager: <info>  VPN connection 'Red Hat Surrey' (Connect) reply received.
kernel: tun0: Disabled Privacy Extensions
NetworkManager: <WARN>  connection_state_changed(): Could not process the
request because no VPN connection was active.
--

However if I run it by hand:
/usr/libexec/nm-vpnc-auth-dialog -n rh-vpn -s org.freedesktop.NetworkManager.vpnc

It just works (tm)
--
** (nm-vpnc-auth-dialog:4624): WARNING **: couldn't communicate with gnome
keyring daemon via dbus: The name org.gnome.keyring was not provided by any
.service files

** (nm-vpnc-auth-dialog:4624): WARNING **: couldn't communicate with gnome
keyring daemon via dbus: The name org.gnome.keyring was not provided by any
.service files

** (nm-vpnc-auth-dialog:4624): WARNING **: couldn't communicate with gnome
keyring daemon via dbus: The name org.gnome.keyring was not provided by any
.service files

** (nm-vpnc-auth-dialog:4624): WARNING **: couldn't communicate with gnome
keyring daemon via dbus: The name org.gnome.keyring was not provided by any
.service files
IPSec secret
<secret>
Xauth password
<my password>
--

Is this something related to the issue? Shall I fill a new bug?
Anyone have seen it?

Chris.
Comment 51 Michael Dugger 2007-12-07 14:38:49 EST
Created attachment 281511 [details]
Bug report after trying to edit settings
Comment 52 Michael Dugger 2007-12-07 14:40:01 EST
Clicking on the desired connection has no effect when trying to connect for me.
Comment 53 Fedora Update System 2007-12-07 16:34:22 EST
NetworkManager-0.7.0-0.6.6.svn3138.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'
Comment 54 Michael Dugger 2007-12-08 02:36:05 EST
Works for me after reboot.
Comment 55 Bryan Kearney 2007-12-08 08:15:22 EST
Created attachment 282001 [details]
Bug report for attempt after reboot
Comment 56 Bryan Kearney 2007-12-08 08:16:11 EST
I rebooted, deleted my old connection, and then attempted to add it back. I am
getting a crash when I restart. Attached is the bug report.
Comment 57 Christopher J. Buckley 2007-12-08 19:47:57 EST
Doesn't work for me.  

[root@localhost ~]# rpm -qa Network\*
NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3109.fc8
NetworkManager-glib-devel-0.7.0-0.6.6.svn3109.fc8
NetworkManager-devel-0.7.0-0.6.6.svn3109.fc8
NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-0.7.0-0.6.6.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8
[root@localhost ~]# yum --enablerepo=updates-testing update NetworkManager
Setting up Update Process
Could not find update match for NetworkManager
No Packages marked for Update

Comment 58 Denis Leroy 2007-12-08 20:08:30 EST
You're probably in "mirror hell". Try a yum clean all first. Rinse and repeat if
necessary.
Comment 59 Michael Dugger 2007-12-09 19:38:45 EST
I should say, it works after:
yum clean all
yum --enablerepo=updates-testing update NetworkManager

then a reboot.
Comment 60 Panu Matilainen 2007-12-10 02:12:09 EST
NetworkManager-0.7.0-0.6.6.svn3138.fc8 appears to have fixed it for me too.
Comment 61 Eric Paris 2007-12-10 12:44:36 EST
I can say that I'm getting the same thing as comment #50.

yum --enablerepo updates-testing update NetworkManager Networkmanager-vpnc
[root@localhost ~]# rpm -qa NetworkManager\*
NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8
NetworkManager-0.7.0-0.6.6.svn3138.fc8

I rebooted, deleted my old vpn connection and created a new one.  Tried to run
it the first time tt as me for my password and group password.  I entered them
and told it to save them both to the keyring.  I saw the icon act like it was
connecting momentarily and then nothing.  Looking in /var/log/messages I have
the exact same message as comment #50

Dec 10 12:43:43 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' exec scheduled...
Dec 10 12:43:43 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' executed
(org.freedesktop.NetworkManager.vpnc), PID 5947
Dec 10 12:43:43 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Dec 10 12:43:43 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Dec 10 12:43:43 localhost NetworkManager: nm_vpn_connection_activate: assertion
`nm_vpn_connection_get_state (connection) == NM_VPN_CONNECTION_STATE_PREPARE' failed
Dec 10 12:43:43 localhost NetworkManager: <info>  VPN connection 'RedHat'
(Connect) reply received.
Dec 10 12:43:43 localhost kernel: tun1: Disabled Privacy Extensions
Dec 10 12:43:43 localhost NetworkManager: <WARN>  connection_state_changed():
Could not process the request because no VPN connection was active.

Since we are not crashing any more maybe this bug is solved, should myself and
that reporter move to a new bug for this failure to work?
Comment 62 Patrick C. F. Ernzer 2007-12-11 10:16:30 EST
FWIW: # rpm -qa NetworkManager\*
NetworkManager-0.7.0-0.6.6.svn3138.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8

solves the problem for me. First connect attempt failed though (I had also
removed all the passwords from the keyring) after I entered the passwords lise such:
<WARN>  connection_state_changed(): Could not process the request becaus
e no VPN connection was active.

But subsequent attempts work just fine (don't know if I was just too slow to
enter the passwords)
Comment 63 Fedora Update System 2008-01-06 20:18:29 EST
NetworkManager-0.7.0-0.6.6.svn3138.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.