This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442457 - Unhandled exception in FC9 beta installation - "invalid object path"
Unhandled exception in FC9 beta installation - "invalid object path"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 444018 446378 446386 446424 451034 456112 459047 464841 465387 465388 467885 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-04-14 17:00 EDT by Cary Maister
Modified: 2008-10-25 12:20 EDT (History)
28 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 12:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump from when the exception occurred (440.47 KB, text/plain)
2008-04-14 18:37 EDT, Cary Maister
no flags Details
anaconda failing 0 (725.42 KB, image/jpeg)
2008-07-14 16:27 EDT, John Brier
no flags Details
anaconda failing 1 (482.25 KB, image/jpeg)
2008-07-14 16:28 EDT, John Brier
no flags Details

  None (edit)
Description Cary Maister 2008-04-14 17:00:26 EDT
Description of problem:
When trying to install Fedora 9 beta, after selecting my language from the
graphical installer, I get an "Exception Occurred" window.

Version-Release number of selected component (if applicable):
Fedora 9 beta

How reproducible:
Always reproducible.

Steps to Reproduce:
1. Boot using the Fedora installer disc 1 CD
2. Begin installation process, selecting US English as language and keyboard
  
Actual results:
"Exception Occurred" window indicating that an unhandled excception has
occurred. I'm unable to save the detailed exception, since my HD wasn't detected
yet. I'm retyping the top of the call stack, and the error message that seems to
be most relevant:

Traceback (most recent call first):
 File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 237, in __init__ 
 _dbus_bindings.validate_object_path(object_path)
 ...
ValueError: Invalid object path
'/org/freedesktop/Hal/devices/storage_model_SAMSUNG_HD160JJ/': ends with '/' and
is not just '/'



Expected results:
Hard disk is detected, and installation proceeds

Additional info:
Here is the dmesg output from my existing Gentoo installation on this machine:
scsi1 : ata_piix
  Vendor: ATA         Model: SAMASUNG HD160JJ/   Rev: ZM10
  Type:   Direct-Access                          ANSI SCSI revision: 05
Comment 1 Cary Maister 2008-04-14 17:13:07 EDT
Just noticed that system BIOS reports the Drive ID as "SAMSUNG HD160JJ/P".
Perhaps the P is getting truncated somewhere in the process?
Comment 2 Jeremy Katz 2008-04-14 18:18:41 EDT
Seems plausible... need to see more of the traceback to see where the problem is
really coming from though.
Comment 3 Cary Maister 2008-04-14 18:37:00 EDT
Created attachment 302400 [details]
Anaconda dump from when the exception occurred

Attached complete Anaconda dump from when the issue occurred.
Comment 4 Jeremy Katz 2008-04-14 18:45:48 EDT
To hal for now, although I'm not entirely sure that's where the problem lies
Comment 5 Colin Walters 2008-04-14 18:49:13 EDT
My guess is this is because the device identifier has a / in it, but HAL is not
quoting it.  
Comment 6 David Zeuthen 2008-04-15 13:25:49 EDT
We should be quoting this stuff. lshal output please? 
Comment 7 David Zeuthen 2008-04-15 13:26:59 EDT
Apparently we're not. I'll look into a fix.
Comment 8 Peter Gervase 2008-05-13 11:16:38 EDT
I'm getting a very similar error - 
ValueError: Invalid object path
'/org/freedesktop/Hal/devices/storage_model_SAMSUNG_HD080HJ/': ends with '/' and
is not just '/'

From comment #1, I also have that /p
Drive ID = SAMSUNG HD080HJ/P 

Checking in the BIOS, I changed RAID Autodetect / AHCI to RAID Autodetect / ATA
for that device, but after saving the change and trying to install again, I got
the same error. 

Going to control + alt + f3, I see as some of the messages:
FATAL: Module md not found.
FATAL: Module blkcipher not found. 

I do not have hard/software raid setup. 

Getting to control + alt + f2, and running # lshal during the install before it
freezes, 
# lshal
error: dbus_bus_get: org.freedesktop.DBus.Error.FileNotFound: Failed to connect
to socket /var/run/dbus/system_bus_socket: No such file or directory

# lshal
Could not initialize connection to hald.
Normally this means the HAL daemon (hald) is not runnning or not ready.

This is all from GOLD media, not beta. 
Comment 9 Colin Walters 2008-05-13 13:46:32 EDT
*** Bug 444018 has been marked as a duplicate of this bug. ***
Comment 10 Bug Zapper 2008-05-14 05:27:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Paul W. Frields 2008-05-14 08:42:36 EDT
This bug has bitten several visitors in #fedora during the last 24 hours.  Seems
to be a Samsung hard disk in each case, with the trailing '/' in the model string.
Comment 12 Jeremy Katz 2008-05-14 08:48:42 EDT
*** Bug 446378 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2008-05-14 09:05:51 EDT
*** Bug 446386 has been marked as a duplicate of this bug. ***
Comment 14 Paul W. Frields 2008-05-14 09:08:22 EDT
Added to http://fedoraproject.org/wiki/Bugs/F9Common#samsung-hdds
Comment 15 Cary Maister 2008-05-14 09:16:59 EDT
I worked around this issue by installing from the LiveCD, which apparently
doesn't do the same check on the HD using hal.
Comment 16 stef 2008-05-14 09:19:24 EDT
(In reply to comment #14)
> Added to http://fedoraproject.org/wiki/Bugs/F9Common#samsung-hdds

Sorry to point it bluntly but the indication in the page "For now, users are
advised to use a different hard disk model if possible." is far from satisfactory...

I've got something like 200 computers in my park on an identical model, and I
guess there are even more with SAMSUNG drives around, so doing a disk exchange
is a no way answer.
Comment 17 stef 2008-05-14 11:37:20 EDT
(In reply to comment #16)
I forgot to mention that I can't use the workaround pointed by comment #15 since
I have to create some kickstart set to boot the installation in different
configurations. I use a NFS server as source for this.
Comment 18 Will Woods 2008-05-14 12:03:57 EDT
The likely fix for this problem will be an updates.img that you'll load during
install. It's being worked on.
Comment 19 Chris Lumens 2008-05-14 12:42:30 EDT
*** Bug 446424 has been marked as a duplicate of this bug. ***
Comment 20 Peter Gervase 2008-05-14 17:47:37 EDT
(In reply to comment #15)
> I worked around this issue by installing from the LiveCD, which apparently
> doesn't do the same check on the HD using hal.

For those impatient souls (like me)- I tried this with the KDE version, and it
worked. It preserved my main lvm like I wanted (LogVol02) and was able to get
the OS installed on the lvm I had used before for the os (LogVol00) and set the
encryption on it. The only issue with this is that you don't get the click and
choose for which packages you want installed. No matter, just use yum to get
whatever that is needed installed afterwards.
Thanks a lot Cary. 
Comment 21 Devan Goodwin 2008-05-15 08:27:56 EDT
Hit this bug as well, but to get around I used the following completely
unsupported hackery to re-use the packages preupgrade downloaded for a live yum
upgrade instead.

1. cp -R /var/cache/yum/anaconda-upgrade/packages /var/cache/yum/fedora/packages
2. Follow the steps on http://fedoraproject.org/wiki/YumUpgradeFaq

Worked fine in my case with some minimal manual package uninstalls, but use at
your own risk.
Comment 22 stef 2008-05-15 08:36:32 EDT
(In reply to comment #21)
This does only apply in the case of an upgrade from FC8 to FC9 right ?

Comment 23 Devan Goodwin 2008-05-15 08:50:15 EDT
yum upgrades have been an unsupported alternative for some time, I think FC6 ->
F7 they would *not* work but since then it's been an option for those willing to
undertake the risk.
Comment 24 stef 2008-05-19 04:06:51 EDT
Still no news about a fix ?

I think this bug should be labelled as High priority since it prevents automated
installations, wich is the most interesting way to mass deploy the distro.
Comment 25 subrahmanyam PVB 2008-05-20 02:08:50 EDT
hi, i just downloaded the fc9 dvd iso and while trying to upgrade from fc8,
getting the same error as above:

ValueError: Invalid object path
'/org/freedesktop/Hal/devices/storage_model_SAMSUNG_HD160JJ/': ends with '/' and
is not just '/'

donno what to do but whatever fix you propose, should preferably not be
rendering my already-burnt-dvd useless. am i too greedy? but my resources are
limited here.
Comment 26 adriano 2008-05-20 06:10:25 EDT
...always faithful to fedora...
...however I don't believe that the other most important distro could have the
same problem and however I don't believe that the same bug in that distro could
stay opened so long time..
(I remember that when FC8 was released there was an upgrade problem with yum
external repos, but the fix was available in few days)
I apologize for this bugzilla use.
Comment 27 Colin Walters 2008-05-20 16:28:43 EDT
This bug is now forwarded upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=16040
Comment 28 stef 2008-05-28 04:28:13 EDT
still no news or ETA on a fix ?
Comment 29 Linuxine 2008-06-09 12:13:55 EDT
Hi,



I tried to update my Fedora 8 to Fedora 9 and I had exactly the same problem,
the installer crashed saying the same message "ValueError: Invalid object path..."



Any idea about what to do ? I really would like to upgrade my Fedora to use all
its wonderful new features... 

As the SAMSUNG hard disk are quite widespread (a least in my company, all our
Dell Workstation have Samsung HD), I think this should be considered as a major
problem that would penalize the deployment of this Fedora, so I'm concerned
about this.


Thanks a lot for your help !
Comment 30 stef 2008-06-10 05:16:09 EDT
(In reply to comment #29)
Add also the HP XW series Workstations, they also have samsung disks with a '/'
in their name.

This makes quite a lot of rigs impacted.
Comment 31 Chris Lumens 2008-06-12 10:53:35 EDT
*** Bug 451034 has been marked as a duplicate of this bug. ***
Comment 32 John Brier 2008-07-14 16:26:29 EDT
I am hitting this bug too on an HP xw4400 Workstation with the same Samsung
Harddrive. I'm attaching some pictures showing anaconda failing.
Comment 33 John Brier 2008-07-14 16:27:39 EDT
Created attachment 311769 [details]
anaconda failing 0
Comment 34 John Brier 2008-07-14 16:28:11 EDT
Created attachment 311770 [details]
anaconda failing 1
Comment 35 Jeremy Katz 2008-07-21 12:50:36 EDT
*** Bug 456112 has been marked as a duplicate of this bug. ***
Comment 36 bc 2008-08-04 21:27:34 EDT
is there any ETA on this Fix. A show-stopper defect like this one shouldn't be opened for so long. dissapointed!!!
Comment 37 Chris Lumens 2008-08-14 13:17:56 EDT
*** Bug 459047 has been marked as a duplicate of this bug. ***
Comment 38 John Curcio 2008-08-14 14:05:09 EDT
I have just run into this bug in a corporate environment and needs this issues resolved or a work-around developed reasonably soon as this will effect productivity at my site. It looks like this issues has been out for a while. Is there any estimate ETA? ... any reasonable suggested work-arounds? ... any good indications on exactly what hardware is making it choke? Any current, quasi-detailed assistance would be much appreciated.

Thanks,
John C

jcurcio@interactivesupercomputing.com
Comment 39 Michael J. Chudobiak 2008-08-14 14:15:15 EDT
(In reply to comment #38)

> there any estimate ETA? ... any reasonable suggested work-arounds? ... any good
> indications on exactly what hardware is making it choke? Any current,
> quasi-detailed assistance would be much appreciated.

The only current workarounds are:

1) Replace the disk with a non-Samsung one, which isn't too hard,

or 

2) Install using the LiveCD install-to-disk feature, instead of the standard installer disk. That actually works quite well.


I don't see anybody rushing to fix this at the upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=16040

- Mike
Comment 40 John Curcio 2008-08-14 19:56:57 EDT
 Thanks for the feedback.

#1 is not a reasonable work-around in a corporate environment [as mine is] since we could be talking about replacing a number of disks.

I did stumble upon the idea of installing via the LiveCD and that works pretty well ... however, there is one additional piece of information which would make this a MUCH easier solution for me. In order to burden our network connection as little as possible I would like to be able to point yum (via cli or synaptics, yumex, or pirut) to utilize a locally mounted DVD so I can install all the additional software which I need which does not show up on a LiveCD. Would you be so kind as to write the explicit directions to do so? [I know it's not that differcult, but when I was attempting it (quickly) earlier I could not get it to recognize the location].

Thank you very much for your help ... this will prove to be a big help for my company and I and will be _much_ appreciated.

John C
Comment 41 Erik van Pienbroek 2008-08-15 03:51:38 EDT
All the mentioned workarounds are no options for our environment. We're encountering this problem in a corporate environment which uses PXE boot and kickstart to install F9.

Would it somehow be possible to use the anaconda from F8 which points to the software repository of F9 (in a respin for example) ?
Comment 42 Michael J. Chudobiak 2008-08-15 07:26:17 EDT
John,

1) If you have a bunch of rpm files in a folder (on your DVD for example) that you want to install, you could use

cd /mnt/cdrom/whatever
yum localinstall *.rpm

Or, you could put your rpms on web server on your local network, and use the createrepo command to turn the folder into a proper yum repository. Then put a matching /etc/yum.repos.d/your-repo file in your local computers.


2) Do any of these "corporate environments" have programmers available?

Since the systems work using a LiveCD install, it suggests that the bug is not deep in dbus. Perhaps it is just in the Python dbus binding. If I look in the dbus-python source code, I see this:

_dbus_bindings/validation.c:

dbus_bool_t
dbus_py_validate_object_path(const char *path)
{
... snip ...
    if (ptr[-1] == '/') {
        PyErr_Format(PyExc_ValueError, "Invalid object path '%s': ends "
                     "with '/' and is not just '/'", path);
        return FALSE;
    }
... snip ...
}

So, for some reason, object paths ending with "/" are specifically rejected. Maybe removing that code will make things work. (Or maybe we'll find out why that check was added in the first place, that is, perhaps there is a deeper problem.)

Anyway, that would be a good place to starting testing.


- Mike
Comment 43 John Curcio 2008-08-15 07:48:30 EDT
If I do a yum localinstall *.rpm on an install DVD, isn't that going to install everything on that DVD? ... that might be a bit much so I think I'll skip that ;-) As for adding the rpm files on a web-server, that means I'll have to have a web-server up and running, copy everything from a locally mounted DVD into the appropiate location ... and the steps listed aren't as explicit as I had hoped [since as I mentioned, I attempted this previously but could not get it to work]. Still, I appreciate the reply ... I'll simply see if I can get yum to recognize a locally mounted install DVD on my own (again).
Comment 44 Michael J. Chudobiak 2008-08-15 07:59:54 EDT
Oh, I see.

If the DVD is mounted, can't you just change:

#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch

to:

baseurl=file:///path/to/your/repo
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch

I haven't tried it.

- Mike
Comment 45 Eric Doutreleau 2008-08-28 08:34:56 EDT
is there any news for these bugs?

i have been stucked for three months by these bugs
Comment 46 David Zeuthen 2008-09-23 13:10:22 EDT
fwiw, I mentioned the bug as a blocker for the next release

http://lists.freedesktop.org/archives/hal/2008-September/012252.html
Comment 47 Chris Lumens 2008-09-30 15:42:34 EDT
*** Bug 464841 has been marked as a duplicate of this bug. ***
Comment 48 Matthias Clasen 2008-10-01 20:10:01 EDT
A patch for this issue has been posted on the hal list
Comment 49 Matthias Clasen 2008-10-01 20:11:10 EDT
Richard, can we get that patch into rawhide ? 
Your recent snapshot does not include it yet.
Comment 50 Chris Lumens 2008-10-03 16:53:22 EDT
*** Bug 465388 has been marked as a duplicate of this bug. ***
Comment 51 Richard Hughes 2008-10-06 06:07:33 EDT
Version with patch here: http://koji.fedoraproject.org/koji/taskinfo?taskID=863240
Comment 52 Chris Lumens 2008-10-09 10:18:13 EDT
*** Bug 465387 has been marked as a duplicate of this bug. ***
Comment 53 Jose Pedro Oliveira 2008-10-20 11:43:32 EDT
FYI: The Fedora-10-Snap2-x86_64-DVD.iso installer finally works with Samsung disks (Model: SAMSUNG HD080HJ/ Rev: ZH10).
Comment 54 Richard Hughes 2008-10-21 11:22:11 EDT
*** Bug 467885 has been marked as a duplicate of this bug. ***
Comment 55 Tom "spot" Callaway 2008-10-24 17:16:43 EDT
Is this fixed in Fedora 10 Snap 3? I see jpo saying it works in Snap2, if so, I'd like to close this bug.
Comment 56 Richard Hughes 2008-10-25 12:20:16 EDT
Bug closed, as the HAL snapshot will have fixed this for new installs.

Note You need to log in before you can comment on or make changes to this bug.