Bug 537845 - Don't meta_bug() on XIOError for unknown displays
Summary: Don't meta_bug() on XIOError for unknown displays
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 524372 524885 532941 541228 544111 546892 549339 550772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-16 15:04 UTC by Owen Taylor
Modified: 2010-01-03 15:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-03 15:27:00 UTC


Attachments (Terms of Use)

Description Owen Taylor 2009-11-16 15:04:05 UTC
When accessibility is enabled, the Metacity process will have a display open for the accessibility bridge GTK+ module; if an X IO error is received on that display, this will hit the Metacity XIOErrorHandler, since XIOErrorHandler's are global for the process, which causes a meta_bug() rather than a graceful exit.

(See bug 537843 for the atexit() XCloseDisplay() in atk-bridge that turns this from unlikely to very likely.)

We should just exit in this case. [Maybe _exit() to work around the atk-bridge problem]

Comment 1 Owen Taylor 2009-11-16 15:16:10 UTC
*** Bug 524372 has been marked as a duplicate of this bug. ***

Comment 2 Owen Taylor 2009-11-16 15:17:37 UTC
*** Bug 524885 has been marked as a duplicate of this bug. ***

Comment 3 Owen Taylor 2009-11-16 15:31:55 UTC
*** Bug 532941 has been marked as a duplicate of this bug. ***

Comment 4 Bug Zapper 2009-11-16 15:42:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Owen Taylor 2009-11-30 16:04:20 UTC
*** Bug 541228 has been marked as a duplicate of this bug. ***

Comment 6 Owen Taylor 2009-12-03 22:55:12 UTC
*** Bug 544111 has been marked as a duplicate of this bug. ***

Comment 7 Owen Taylor 2009-12-14 15:34:30 UTC
*** Bug 546892 has been marked as a duplicate of this bug. ***

Comment 8 Owen Taylor 2009-12-21 13:04:44 UTC
*** Bug 549339 has been marked as a duplicate of this bug. ***

Comment 9 Owen Taylor 2009-12-29 14:44:35 UTC
*** Bug 550772 has been marked as a duplicate of this bug. ***

Comment 10 Owen Taylor 2010-01-03 15:27:00 UTC
This was fixed by metacity-2.28.0-13.fc12 in fedora-updates


Note You need to log in before you can comment on or make changes to this bug.