Bug 580728 - nautilus desktop file causes complaints about "x-directory" old media type
nautilus desktop file causes complaints about "x-directory" old media type
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 581091 584210 644718 650764 655099 (view as bug list)
Depends On:
Blocks: 580944
  Show dependency treegraph
 
Reported: 2010-04-08 17:26 EDT by Michal Jaegermann
Modified: 2015-03-03 17:46 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-11 11:48:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2010-04-08 17:26:01 EDT
Description of problem:

Whatever looks at desktop files during an installation is not that happy with the following:

Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)

No idea what kind of "a modern equivalent" is expected.

Version-Release number of selected component (if applicable):
nautilus-2.30.0-1.fc14
Comment 1 Bug Zapper 2010-07-30 07:17:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tomáš Bžatek 2010-11-19 11:02:17 EST
*** Bug 655099 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Wickert 2010-12-04 07:09:55 EST
*** Bug 581091 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Wickert 2010-12-04 07:09:59 EST
*** Bug 584210 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Wickert 2010-12-04 07:10:05 EST
*** Bug 644718 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Wickert 2010-12-04 07:10:12 EST
*** Bug 650764 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Wickert 2010-12-04 07:15:39 EST
Bug 513562 is the same for RHEL5.
Comment 8 Edgar Hoch 2010-12-28 13:48:16 EST
The problem still exists with nautilus-2.32.2-1.fc14.x86_64.

Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)

This seems to be a simular problem like the one described in bug 580944 (but this is for fedora 13 - and 14?).
Comment 9 Marek Zdunek 2011-02-04 16:44:59 EST
Warning in file "/usr/share/applications/chromium-browser.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/chromium-browser.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/chromium-browser.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)

suddenly appears today

2.6.35.10-74.fc14.x86_64
nautilus.x86_64   2.32.2.1-2.fc14

Note You need to log in before you can comment on or make changes to this bug.