Bug 590490 - [abrt] crash in FlightGear-2.0.0-1.fc13: Process /usr/bin/fgfs was killed by signal 11 (SIGSEGV)
[abrt] crash in FlightGear-2.0.0-1.fc13: Process /usr/bin/fgfs was killed by ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: FlightGear (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Fabrice Bellet
Fedora Extras Quality Assurance
abrt_hash:26832acdf64dc58deebb747792b...
:
: 544185 590778 597301 597702 600537 601374 601435 603614 607842 611623 612479 613234 615555 (view as bug list)
Depends On: 601631
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 16:13 EDT by Alexandre Gouger
Modified: 2010-08-17 14:36 EDT (History)
29 users (show)

See Also:
Fixed In Version: FlightGear-2.0.0-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-07 19:25:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.89 KB, text/plain)
2010-05-09 16:13 EDT, Alexandre Gouger
no flags Details

  None (edit)
Description Alexandre Gouger 2010-05-09 16:13:39 EDT
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: fgfs --aircraft=SenecaII
component: FlightGear
crash_function: flightgear::CameraGroup::buildGUICamera
executable: /usr/bin/fgfs
global_uuid: 26832acdf64dc58deebb747792b2b8e0680dd01f
kernel: 2.6.33.3-85.fc13.i686
package: FlightGear-2.0.0-1.fc13
rating: 4
reason: Process /usr/bin/fgfs was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
Start Flightgear with the command: fgfs --aircraft=SenecaII
Note: Graphics Chipset is Intel 945GM

How to reproduce
-----
1.Start Flightgear with the command: fgfs --aircraft=SenecaII
2.
3.
Comment 1 Alexandre Gouger 2010-05-09 16:13:41 EDT
Created attachment 412673 [details]
File: backtrace
Comment 2 Karel Klíč 2010-05-25 05:02:56 EDT
*** Bug 590778 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Pakosta 2010-05-26 11:10:50 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Become root
2. Try to launch fresh installed FlightGear
3. Nothing happens, abrt notification pops up
Comment 4 Leslie Satenstein 2010-06-01 18:37:44 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Click to start
2. Aborts immediately
3.


Comment
-----
Rerun to reproduce.  Very unforgiving
Comment 5 clifford snow 2010-06-02 01:44:29 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Run FlightGear - fgfs  
2. It crashes
3. Everytime


Comment
-----
fgfs reports 
Error: Not able to create requested visual.
Error: Not able to create requested visual.
Segmentation fault (core dumped)
Comment 6 Fabrice Bellet 2010-06-08 04:08:36 EDT
*** Bug 597301 has been marked as a duplicate of this bug. ***
Comment 7 Fabrice Bellet 2010-06-08 04:09:50 EDT
*** Bug 597702 has been marked as a duplicate of this bug. ***
Comment 8 Fabrice Bellet 2010-06-08 04:10:57 EDT
*** Bug 600537 has been marked as a duplicate of this bug. ***
Comment 9 Fabrice Bellet 2010-06-08 04:15:02 EDT
*** Bug 601435 has been marked as a duplicate of this bug. ***
Comment 10 Fabrice Bellet 2010-06-08 04:17:41 EDT
*** Bug 601374 has been marked as a duplicate of this bug. ***
Comment 11 Fabrice Bellet 2010-06-08 06:40:50 EDT
Could you try with package mesa from rawhide, and report if you still have a crash ?

http://koji.fedoraproject.org/koji/buildinfo?buildID=175654
Comment 12 Pant 2010-06-08 08:08:05 EDT
I am still having a crash. the same one..(In reply to comment #11)
> Could you try with package mesa from rawhide, and report if you still have a
> crash ?
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=175654    

I am still having a crash. the same one..
Comment 13 Brendan Jones 2010-06-10 03:19:54 EDT
Removing the Fedora packages and compiling from source yields the same result.
Comment 14 Brendan Jones 2010-06-10 03:25:48 EDT
Removing the Fedora packages and compiling from source yields the same result.
Comment 15 clifford snow 2010-06-10 18:57:11 EDT
I think you have this info, but just in case.  This is what I get from gdb

Program terminated with signal 11, Segmentation fault.
#0  flightgear::CameraGroup::buildGUICamera (this=0x10ec0d0, cameraNode=
    0x11209d0, window=0x0) at CameraGroup.cxx:421
421         camera->setGraphicsContext(window->gc.get());



(gdb) bt
#0  flightgear::CameraGroup::buildGUICamera (this=0x10ec0d0, 
    cameraNode=0x11209d0, window=0x0) at CameraGroup.cxx:421
#1  0x0000000000473285 in flightgear::CameraGroup::buildCameraGroup (
    viewer=<value optimized out>, gnode=0x11d2d10) at CameraGroup.cxx:462
#2  0x0000000000479c20 in fgOSOpenWindow (stencil=<value optimized out>)
    at fg_os_osgviewer.cxx:159
#3  0x000000000042d6da in fgMainInit (argc=1, argv=0x7fffa9b73d68)
    at main.cxx:938
#4  0x000000000042b64e in main (argc=1, argv=0x7fffa9b73d68)
    at bootstrap.cxx:229
(gdb)
Comment 16 Brendan Jones 2010-06-13 08:46:35 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: 686
OS Release: Fedora release 13 (Goddard)
Video: ATI Radion, radeon.agpmode=-1

A little more information is required to my previous post. Crash and backtrace is reproducible as described by other testers, both with the FlightGear fedora packages and building from source. 

Not sure if this helps but I have no problems running on latest rawhide build, however this is x86_64 arch with nvidia proprietary drivers w/kernel nomodeset. Let me know if would help testing this with rawhide and the 686 machine above.
Comment 17 Mikel Asla 2010-06-14 06:40:25 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Una vez instalado ejecuto FlightGear desde el lanzador de programas alt-f2
2.
3.
Comment 18 Ludek Bartek 2010-06-15 01:10:32 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Starting the application using CLI (fgfs)
2.
3.


Comment
-----
I've tried to start the application using the fgfs command.
Comment 19 Fabrice Bellet 2010-06-15 13:33:45 EDT
*** Bug 603614 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2010-06-15 13:39:17 EDT
FlightGear-2.0.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/FlightGear-2.0.0-2.fc13
Comment 21 Fabrice Bellet 2010-06-15 13:43:48 EDT
I pushed an update that avoids the crash when the application requests a visual that cannot be found. However, the underlying problem, of the glx visual being not available, is IMO caused by bug #601631
Comment 22 clifford snow 2010-06-16 00:10:13 EDT
I installed FlightGear-2.0.0-2.fc14.x86_64 (That is what rawhide gave me instead of the fc13 version)  It fails with the following error:
 Error: Not able to create requested visual.
 Error: Not able to create requested visual.
 Error: Not able to create requested visual.
   GraphicsWindow has not been created successfully.
 Viewer::realize() - failed to set up any windows
Comment 23 Fabrice Bellet 2010-06-16 04:05:54 EDT
(In reply to comment #22)
> I installed FlightGear-2.0.0-2.fc14.x86_64 (That is what rawhide gave me
> instead of the fc13 version)  It fails with the following error:
>  Error: Not able to create requested visual.
>  Error: Not able to create requested visual.
>  Error: Not able to create requested visual.
>    GraphicsWindow has not been created successfully.
>  Viewer::realize() - failed to set up any windows    

do you have the same warning than in comment #1 of bug #601631, when setting the environment variable LIBGL_DIAGNOSTIC before launching fgfs from command line ?
Comment 24 Fedora Update System 2010-06-16 13:42:07 EDT
FlightGear-2.0.0-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update FlightGear'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/FlightGear-2.0.0-2.fc13
Comment 25 Fabrice Bellet 2010-06-18 04:26:19 EDT
*** Bug 544185 has been marked as a duplicate of this bug. ***
Comment 26 Brendan Jones 2010-06-20 05:19:40 EDT
Package: FlightGear-2.0.0-2.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)
Video: NVIDIA proprietary

I can confirm that the new package works on a fresh Fedora 13 install with the above system. However on the 686 machine following Fabrice's instructions in Comment 24 (w/radeon opensource driver kernel nomodeset) I get the same results as Comment 22. Is there something else that I need to update here?

Thanks for your time Fabrice, let me know how I can help.

Brendan
Comment 27 Richard Keech 2010-06-20 07:52:25 EDT
FlightGear-2.0.0-2.fc13 still fails like before with

Error: Not able to create requested visual.
Error: Not able to create requested visual.
Error: Not able to create requested visual.
  GraphicsWindow has not been created successfully.
Viewer::realize() - failed to set up any windows

I'm using nouveau driver.  I might need to switch to NVIDIA proprietary.
Comment 28 Brendan Jones 2010-06-20 08:27:57 EDT
Maybe, but not necessarily - I'm seeing this with the xorg radeon as well (fabrice maybe can help me out here - I'm not sure if I have a full understanding of the issue?) 

Are you in a position to try out the proprietary driver? 

If you want some help installing the prop driver let me know - not a fan of using proprietary drivers unless absolutely necessary but I'd like to see this working in any case.
Comment 29 Theophanis Kontogiannis 2010-06-23 05:12:33 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
launched flight gear via the menu
Comment 30 Roberts Klotins 2010-06-27 12:55:11 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. just tried to start the program

2.
3.
Comment 31 Przemek Klosowski 2010-06-28 10:10:41 EDT
I don't think this is directly caused by proprietary drivers;
I quote from my report in a related bug 
https://bugzilla.redhat.com/show_bug.cgi?id=544185
that I opened for FC12, and updated for FC13

the problem is the dereference of the null pointer 'window' in
flightgear::CameraGroup::buildGUICamera; the problem is that 
flightgear::CameraGroup::buildCameraGroup calls buildGUICamera with only one
parameter, i.e. the second parameter 'window' is a null pointer.    

In buildGUIcamera the NULL window is handled by creating a new one with
wBuild->buildWindow(windowNode) where windowNode=cameraNode->getNode("window")

This, however, results in an "Error: Not able to create requested visual."

This seems to be the same issue as in 
http://code.google.com/p/flightgear-bugs/issues/detail?id=136
Comment 32 Przemek Klosowski 2010-06-28 11:30:34 EDT
http://comments.gmane.org/gmane.comp.graphics.openscenegraph.user/58051 implies that it's a Mesa problem and that it was fixed by Dave Airlie in early May
http://cgit.freedesktop.org/mesa/mesa/commit/?id=26a9b7e4c737c89b47844303bb7413ceab0280a5

It seems that FC13 uses Mesa 7.8.1 which was tagged in April so Dave's patch is probably not included there. 7.8.2 was tagged in June so this one is probably fixing this. I checked that the new Mesa is available yet, even in updates-testing.

Should we log a bug against Mesa?
Comment 33 Fabrice Bellet 2010-06-29 03:56:13 EDT
*** Bug 607842 has been marked as a duplicate of this bug. ***
Comment 34 Fabrice Bellet 2010-06-29 04:10:47 EDT
(In reply to comment #32)
> http://comments.gmane.org/gmane.comp.graphics.openscenegraph.user/58051 implies
> that it's a Mesa problem and that it was fixed by Dave Airlie in early May
> http://cgit.freedesktop.org/mesa/mesa/commit/?id=26a9b7e4c737c89b47844303bb7413ceab0280a5
> 
> It seems that FC13 uses Mesa 7.8.1 which was tagged in April so Dave's patch is
> probably not included there. 7.8.2 was tagged in June so this one is probably
> fixing this. I checked that the new Mesa is available yet, even in
> updates-testing.
> 
> Should we log a bug against Mesa?    

I already filled a bug report against mesa : #601631
Comment 35 Roberts Klotins 2010-07-01 14:49:57 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. just trying to launch flightgear
2. Error: Not able to create requested visual
3. Segmentation fault
Comment 36 Brendan Jones 2010-07-01 20:06:19 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_32
OS Release: Fedora release 13 (Goddard)    

I can confirm that the issue is resolved by using the the following packages from rawhide:

FlightGear.i686             2.0.0-2.fc14 (I believe this is in updates-testing)
mesa-dri-drivers.i686       7.9-0.2.fc14        
mesa-libGL.i686             7.9-0.2.fc14         

regards,

Brendan
Comment 37 Theophanis Kontogiannis 2010-07-02 04:20:38 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
just run it from the menu
Comment 38 Benjamin Van Dyke 2010-07-02 04:25:53 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
I attempted to start FlightGear
Comment 39 Fabrice Bellet 2010-07-06 03:48:37 EDT
*** Bug 611623 has been marked as a duplicate of this bug. ***
Comment 40 Theophanis Kontogiannis 2010-07-08 05:22:54 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
launch flight gear
Comment 41 Arnold Hennig 2010-07-09 14:19:09 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Just start the program
2.
3.
Comment 42 Rui Correia 2010-07-14 18:58:56 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.yum install FlightGear
2.goto menu Games>FlightGear
3.


Comment
-----
Just did that, installed from fedora's repositories and tried to start the game from fedora's games menu.
Comment 43 Rui Correia 2010-07-15 10:39:27 EDT
(In reply to comment #36)
> Package: FlightGear-2.0.0-1.fc13
> Architecture: x86_32
> OS Release: Fedora release 13 (Goddard)    
> 
> I can confirm that the issue is resolved by using the the following packages
> from rawhide:
> 
> FlightGear.i686             2.0.0-2.fc14 (I believe this is in updates-testing)
> mesa-dri-drivers.i686       7.9-0.2.fc14        
> mesa-libGL.i686             7.9-0.2.fc14         
> 
> regards,
> 
> Brendan    

Hi,
Just to let you know that I was able to run current fgfs just by installing mesa-libGL-7.9-0.5.fc14.x86_64.
I didn't need to use mesa-dri-drivers-7.9-0.5.fc14.x86_64.
This is my current FG bin FlightGear-2.0.0-1.fc13.x86_64.
Comment 44 Fabrice Bellet 2010-07-18 14:34:29 EDT
*** Bug 615555 has been marked as a duplicate of this bug. ***
Comment 45 Fabrice Bellet 2010-07-18 14:35:37 EDT
*** Bug 613234 has been marked as a duplicate of this bug. ***
Comment 46 Fabrice Bellet 2010-07-20 04:03:02 EDT
*** Bug 612479 has been marked as a duplicate of this bug. ***
Comment 47 Fedora Update System 2010-07-20 13:33:18 EDT
FlightGear-2.0.0-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/FlightGear-2.0.0-4.fc13
Comment 48 Theophanis Kontogiannis 2010-07-27 06:16:39 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Just started flight gear
Comment 49 Theophanis Kontogiannis 2010-07-28 08:33:25 EDT
Package: FlightGear-2.0.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Just started flight gear
Comment 50 Igor Bezrodnik 2010-08-03 20:15:45 EDT
Install :

FlightGear-2.0.0-4.fc13.i686.rpm &
FlightGear-debuginfo-2.0.0-4.fc13.i686.rpm;
 
but still couldn't run flight gear.
Still problem with visual!	

"Error: Not able to create requested visual.
Error: Not able to create requested visual.
Error: Not able to create requested visual.
  GraphicsWindow has not been created successfully.
Viewer::realize() - failed to set up any windows"
Comment 51 Arnold Hennig 2010-08-04 05:54:19 EDT
I solved the problem:

I installed
mesa-dri-drivers-7.9-0.5.fc14.x86_64
and
mesa-libGL-7.9-0.5.fc14.x86_64

start flight gear with:
fgfs-wrapper --disable-splash-screen
Comment 52 Fabrice Bellet 2010-08-05 14:55:06 EDT
Please test with this mesa update for Fedora 13:
https://admin.fedoraproject.org/updates/mesa-7.8.1-8.fc13
Comment 53 enrico.gottardo 2010-08-07 02:53:08 EDT
Great Fabrice! After an update it works just out of the box.
Many thanks
Comment 54 Fedora Update System 2010-08-07 19:25:24 EDT
FlightGear-2.0.0-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 55 Igor Bezrodnik 2010-08-17 14:36:38 EDT


Great Fabrice! 
Thanks !
After update of mesa driver  FlightGear works fine!

https://admin.fedoraproject.org/updates/mesa-7.8.1-8.fc13

Note You need to log in before you can comment on or make changes to this bug.