Bug 656317 - libwx_gtk2u_stc-2.8.so: cannot open shared object file: No such file or directory
libwx_gtk2u_stc-2.8.so: cannot open shared object file: No such file or direc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Wx (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 658298 659941 672577 678059 679589 688001 700923 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-23 08:46 EST by Petr Pisar
Modified: 2011-05-02 07:03 EDT (History)
12 users (show)

See Also:
Fixed In Version: perl-ExtUtils-XSpp-0.15-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 18:28:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (11.13 KB, image/png)
2010-12-20 05:32 EST, Ralf Corsepius
no flags Details

  None (edit)
Description Petr Pisar 2010-11-23 08:46:06 EST
When starting padre (perl-Padre package), I got graphical error message:

libwx_gtk2u_stc-2.8.so: cannot open shared object file: No such file or directory

with detail log:

02:37:21 PM: libwx_gtk2u_stc-2.8.so: cannot open shared object file: No such file or directory
02:37:21 PM: libwx_gtk2u_adv-2.8.so: cannot open shared object file: No such file or directory
02:37:21 PM: libwx_gtk2u_aui-2.8.so: cannot open shared object file: No such file or directory

As a result padre cannot draw pictures and format text in some windows like in `About' window.

This bug appears in F14 and F15 if wxGTK-devel is not installed.

Despite the error message, the versioned library is opened according strace.

In addition, padre segfaults in wxGTK in F14 if the error window get focus after dismissing splash screen.

It seems like a bug in perl-Wx or wxGTK. We need to create minimal reproducer before reassigning to proper Bugzilla component.
Comment 1 Petr Pisar 2010-12-01 03:30:00 EST
*** Bug 658298 has been marked as a duplicate of this bug. ***
Comment 2 Petr Pisar 2010-12-06 05:09:40 EST
*** Bug 659941 has been marked as a duplicate of this bug. ***
Comment 3 mdeggers 2010-12-20 04:52:48 EST
Reinstalling wxGTK-devel seems to have fixed this for me. I cannot reproduce a SIGSEGV by running padre from the command line and changing focus or clicking on the splash screen to prematurely close it.
Comment 4 Ralf Corsepius 2010-12-20 05:20:26 EST
(In reply to comment #3)
> Reinstalling wxGTK-devel seems to have fixed this for me.
Generally speaking, when installing a *-devel package "fixes" this kind of issues, this an string indication of something trying to dlopen wrong module and the dlopen mechanism being used not being sufficiently fault tolerant.

> I cannot reproduce a
> SIGSEGV by running padre from the command line and changing focus or clicking
> on the splash screen to prematurely close it.
Well, padre immediate dumps core upon start-up, on Fedora 14 for me.
Comment 5 Ralf Corsepius 2010-12-20 05:32:23 EST
Created attachment 469718 [details]
Screenshot


I wasn't entirely correct. Padre doesn't immediately segfault, but launches a dialog box upon startup (cf. attachment). 

When trying to highlight this dialog box (clicking on the window's border) or when trying to click on the "Details" button, a segfault occurs.

When clicking on the "OK" button, padre starts.
Comment 6 Marcela Mašláňová 2011-01-25 11:27:11 EST
*** Bug 672577 has been marked as a duplicate of this bug. ***
Comment 7 Petr Pisar 2011-01-27 11:56:03 EST
Notice for myself: New perl-Wx version 0.98 has been built for F15. Recheck the problem with this version again.
Comment 8 Petr Pisar 2011-02-17 04:41:00 EST
*** Bug 678059 has been marked as a duplicate of this bug. ***
Comment 9 Petr Pisar 2011-02-17 05:53:53 EST
New perl-Wx-0.98 fixes the segfault and removes the warning. perl-Wx-0.92 warns and segfaults. Tested in F15 where I downgraded the perl-Wx package only (after manual rebuild because of missing XS provides).

The only drawback is perl-Wx-0.98 displays garbage in the padre About image for first time. Subsequent padre invocations show correct image. I wiped ~/.padre and the About image remains fine with perl-Wx-0.98, so it must be something with linker or Wx cache (if something such exists).

Reassigning to perl-Wx.
Comment 10 Petr Pisar 2011-02-17 07:24:32 EST
I tested versions not packaged in Fedora:

0.94 is affected
0.95 does not warn, does not segfault, but does not show images in splash or about window.
0.96 same as 0.95
0.97 works as good as 0.98
Comment 11 Petr Pisar 2011-02-17 07:36:26 EST
Yet another observation:

0.97 does not draw splash image, just a gray background of splash window. 0.98 draws the splash image.
Comment 12 Petr Pisar 2011-02-17 07:40:08 EST
(In reply to comment #11)
> Yet another observation:
> 
> 0.97 does not draw splash image, just a gray background of splash window. 0.98
> draws the splash image.

Actually it's matter of timing, 0.98 usually does not draw splash image.
Comment 13 Simon Lachance 2011-02-19 12:42:02 EST
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start Padre
2.
3.
Comment 14 Petr Pisar 2011-02-23 03:54:52 EST
*** Bug 679589 has been marked as a duplicate of this bug. ***
Comment 15 Dave Cross 2011-03-01 15:42:47 EST
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start Padre
2. Watch crash
3.
Comment 16 rdesfo 2011-03-06 18:40:51 EST
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. opened terminal
2. ran 'padre"
3. crash
Comment 17 rdesfo 2011-03-07 15:14:02 EST
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. <ALT + F2>
2. typed 'padre'
3. clicked <enter>
Comment 18 Fedora Update System 2011-03-11 12:37:12 EST
perl-ExtUtils-XSpp-0.15-2.fc13,perl-5.10.1-122.fc13,perl-Wx-0.98-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/perl-ExtUtils-XSpp-0.15-2.fc13,perl-5.10.1-122.fc13,perl-Wx-0.98-5.fc13
Comment 19 Fedora Update System 2011-03-11 12:37:21 EST
perl-ExtUtils-XSpp-0.15-2.fc14,perl-5.12.3-142.fc14,perl-Wx-0.98-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-ExtUtils-XSpp-0.15-2.fc14,perl-5.12.3-142.fc14,perl-Wx-0.98-5.fc14
Comment 20 nubnoj6 2011-03-15 17:50:47 EDT
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
b
Comment 21 nubnoj6 2011-03-15 17:51:55 EDT
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
b
Comment 22 Petr Pisar 2011-03-16 04:31:58 EDT
*** Bug 688001 has been marked as a duplicate of this bug. ***
Comment 23 nubnoj6 2011-03-19 15:34:31 EDT
Package: perl-Padre-0.64-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Try to open padre from the command line
2. Get a box with the error
3.
Comment 24 Tom "spot" Callaway 2011-03-19 21:50:50 EDT
Hey nubnoj6, please test the update in Comment 19.
Comment 25 Fedora Update System 2011-04-06 18:28:33 EDT
perl-ExtUtils-XSpp-0.15-2.fc14, perl-5.12.3-142.fc14, perl-Wx-0.98-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2011-04-06 18:33:15 EDT
perl-ExtUtils-XSpp-0.15-2.fc13, perl-5.10.1-122.fc13, perl-Wx-0.98-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Marcela Mašláňová 2011-05-02 04:55:07 EDT
*** Bug 700923 has been marked as a duplicate of this bug. ***
Comment 28 gatlibs 2011-05-02 07:03:53 EDT
perl-Padre runs without wxGTK-devel on F15Beta.

Note You need to log in before you can comment on or make changes to this bug.