Bug 785460 (Horde_Mime) - Review Request: php-horde-Horde-Mime - Horde MIME Library
Summary: Review Request: php-horde-Horde-Mime - Horde MIME Library
Keywords:
Status: CLOSED ERRATA
Alias: Horde_Mime
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: horde-channel Horde_Translation Horde_Exception Horde_Util Horde_Stream_Filter Horde_Mail Horde_Support Horde_Text_Flowed
Blocks: 785463 Horde_Prefs Horde_Icalendar Horde_Data Horde_Mime_Viewer Horde_Core Horde_Imap_Client Horde_Vfs Horde_Crypt Horde_Itip
TreeView+ depends on / blocked
 
Reported: 2012-01-29 02:02 UTC by Nick Bebout
Modified: 2013-03-29 21:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-29 01:25:29 UTC
fedora: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)
phpci.log (19.17 KB, text/plain)
2013-03-26 12:06 UTC, Remi Collet
no flags Details
review.txt (7.27 KB, text/plain)
2013-03-26 12:06 UTC, Remi Collet
no flags Details

Description Nick Bebout 2012-01-29 02:02:30 UTC
Spec URL: http://nb.fedorapeople.org/horde-reviews/php-horde-Horde-Mime.spec
SRPM URL: http://nb.fedorapeople.org/horde-reviews/php-horde-Horde-Mime-1.4.1-1.fc16.src.rpm
Description: Provides methods for dealing with MIME (RFC 2045) and related e-mail (RFC822/2822/5322) standards.

Comment 2 Remi Collet 2013-01-10 15:09:41 UTC
Please update to 2.0.x

Please also consider php 5.5 patch attached in 
http://bugs.horde.org/ticket/11913

Comment 5 Remi Collet 2013-03-26 12:06:16 UTC
Created attachment 716472 [details]
phpci.log

phpci version 2.14.0.

Comment 6 Remi Collet 2013-03-26 12:06:44 UTC
Created attachment 716473 [details]
review.txt

Generated by fedora-review 0.4.0 (660ce56) last change: 2013-01-29
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 785460

Comment 7 Remi Collet 2013-03-26 12:08:43 UTC
----- MUST:

[!]: License field in the package spec file matches the actual license.

	Please correct License (with the comment) :

	# lib/Horde/Mime.php is BSD and LGPLv2
	# other files are LGPLv2
	License: LGPLv2 and BSD

----- SHOULD

[!]: Requires correct, justified where necessary.
	A typo in the Requires list.
		BuildRequires:  php-pear(PEAR) >= 1.7.0
	Listed twice should be 
		Requires:  php-pear(PEAR) >= 1.7.0

----- COULD

[!]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
	
As Buildroot is not present, both could be clean (not a blocker)

Comment 9 Remi Collet 2013-03-27 07:50:20 UTC
-License:        LGPLv2
+# lib/Horde/Mime.php is BSD and LGPLv2
+# other files are LGPLv2
+License:        LGPLv2 and BSD

[x]: License field in the package spec file matches the actual license.

-BuildRequires:  php-pear(PEAR) >= 1.7.0
+Requires:       php-pear(PEAR) >= 1.7.0

[x]: Requires correct, justified where necessary.

-rm -rf %{buildroot}
-%defattr(-,root,root,-)

[x]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[x]: Package does not run rm -rf %{buildroot} 

All blockers fixed.

=== APPROVED ===

Comment 10 Nick Bebout 2013-03-27 08:48:52 UTC
New Package SCM Request
=======================
Package Name: php-horde-Horde-Mime
Short Description: Horde MIME library
Owners: nb remi
Branches: el6 f18 f19
InitialCC:

Comment 11 Gwyn Ciesla 2013-03-27 12:26:44 UTC
Git done (by process-git-requests).

Comment 12 Fedora Update System 2013-03-27 20:21:22 UTC
php-horde-Horde-Mime-2.0.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/php-horde-Horde-Mime-2.0.4-2.fc18

Comment 13 Fedora Update System 2013-03-27 20:21:50 UTC
php-horde-Horde-Mime-2.0.4-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-horde-Horde-Mime-2.0.4-2.el6

Comment 14 Fedora Update System 2013-03-29 01:25:38 UTC
php-horde-Horde-Mime-2.0.4-2.fc18, php-horde-Horde-Perms-2.1.0-1.fc18, php-horde-Horde-Prefs-2.3.2-2.fc18, php-horde-Horde-Data-2.0.3-3.fc18, php-horde-Horde-Icalendar-2.0.4-1.fc18 has been pushed to the Fedora 18 stable repository.

Comment 15 Fedora Update System 2013-03-29 21:27:08 UTC
php-horde-Horde-Mime-2.0.4-2.el6, php-horde-Horde-Prefs-2.3.2-2.el6, php-horde-Horde-Data-2.0.3-3.el6, php-horde-Horde-Perms-2.1.0-1.el6, php-horde-Horde-Icalendar-2.0.4-1.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.