Bug 916415 - ERROR with transaction check vs depsolve:compiz = 0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16 is needed by (installed) compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64
Summary: ERROR with transaction check vs depsolve:compiz = 0.9.5.92.1-0.2.gite676f1b12...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 917691 919035 919986 926891 964757 968810 970397 970744 975553 976070 977151 977234 998160 1000077 1000082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-28 02:43 UTC by Peter Rayner
Modified: 2013-08-23 07:26 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-03 07:07:25 UTC
Type: ---


Attachments (Terms of Use)

Description Peter Rayner 2013-02-28 02:43:55 UTC
generated by running yum update on a fedora 18 system

Comment 1 Jan Zeleny 2013-03-04 16:28:25 UTC
*** Bug 917691 has been marked as a duplicate of this bug. ***

Comment 2 Jan Zeleny 2013-03-07 14:13:24 UTC
*** Bug 919035 has been marked as a duplicate of this bug. ***

Comment 3 Jan Zeleny 2013-03-11 08:22:41 UTC
*** Bug 919986 has been marked as a duplicate of this bug. ***

Comment 4 Jan Zeleny 2013-03-25 07:33:34 UTC
*** Bug 926891 has been marked as a duplicate of this bug. ***

Comment 5 Fedora End Of Life 2013-04-03 16:45:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 6 Jan Zeleny 2013-05-20 06:21:23 UTC
*** Bug 964757 has been marked as a duplicate of this bug. ***

Comment 7 Jan Zeleny 2013-05-30 08:30:43 UTC
*** Bug 968810 has been marked as a duplicate of this bug. ***

Comment 8 Andrew Haninger 2013-06-02 02:40:50 UTC
I'm getting this bug on Fedora 18. My system currently reports that there are 84 updates to install, but when I attempt to install them, I get this error and the other updates are not installed.

I also get no "Restart" option. Only "Install Updates & Restart".

Comment 9 Andrew Haninger 2013-06-02 07:02:13 UTC
For what it's worth, when I ran yum update from the command line, I got this:

Running Transaction Check
ERROR with transaction check vs depsolve:
compiz = 0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16 is needed by (installed) compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 has missing requires of compiz = ('0', '0.9.5.92.1', '0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16')
compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 has missing requires of libboost_serialization-mt.so.1.47.0()(64bit)
compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 has missing requires of libcomposite.so()(64bit)
compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 has missing requires of libopengl.so()(64bit)
1:totem-youtube-3.2.1-2.fc16.x86_64 has missing requires of libclutter-glx-1.0.so.0()(64bit)
1:totem-youtube-3.2.1-2.fc16.x86_64 has missing requires of libcogl.so.5()(64bit)
1:totem-youtube-3.2.1-2.fc16.x86_64 has missing requires of totem = ('1', '3.2.1', '2.fc16')
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-06-02.02-59.lQ3Pt0.yumtx

Comment 10 Andrew Haninger 2013-06-03 05:46:55 UTC
I was just able to install updates using the graphical Software Update utility by first unchecking all compiz updates.

Now when I check for updates, I only see an update available for compiz-1:0.8.8-21.fc18 (64-bit) under "Bug fix updates". If I try to install it, a second update appears: compiz-1:0.8.8-15.fc18 (64-bit) and then I get an error "Failed to process request."

Hope this helps.

Comment 11 Jan Zeleny 2013-06-03 07:07:25 UTC
If you follow the information yum gives you, you will be able to solve this issue:

1) (in the bug summary and comment 9) compiz-gtk is blocking update of compiz - remove compiz-gtk package to solve this

2) (comment 9) some installed packages are missing their dependencies - remove those packages to solve this.

In any case this is not a bug in yum.

Comment 12 Jan Zeleny 2013-06-04 06:46:25 UTC
*** Bug 970397 has been marked as a duplicate of this bug. ***

Comment 13 Jan Zeleny 2013-06-10 08:01:29 UTC
*** Bug 970744 has been marked as a duplicate of this bug. ***

Comment 14 Jan Zeleny 2013-06-19 06:48:48 UTC
*** Bug 975553 has been marked as a duplicate of this bug. ***

Comment 15 Mike Melko 2013-06-20 03:52:23 UTC
Uninstalling the compiz-gtk package worked, thank you. Apparently this package conflicts with Gnome 3.

Comment 16 Jan Zeleny 2013-06-20 06:58:02 UTC
*** Bug 976070 has been marked as a duplicate of this bug. ***

Comment 17 Jan Zeleny 2013-06-24 06:35:25 UTC
*** Bug 977151 has been marked as a duplicate of this bug. ***

Comment 18 Jan Zeleny 2013-06-24 06:50:13 UTC
*** Bug 977234 has been marked as a duplicate of this bug. ***

Comment 19 Jan Zeleny 2013-08-19 07:43:51 UTC
*** Bug 998160 has been marked as a duplicate of this bug. ***

Comment 20 Jan Zeleny 2013-08-23 07:25:49 UTC
*** Bug 1000077 has been marked as a duplicate of this bug. ***

Comment 21 Jan Zeleny 2013-08-23 07:26:50 UTC
*** Bug 1000082 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.