Bug 2386 - Netscape crashes when starting java
Netscape crashes when starting java
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 3062 3131 3222 3240 3490 3585 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-27 14:14 EDT by tbyrd
Modified: 2008-05-01 11:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-27 16:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tbyrd 1999-04-27 14:14:31 EDT
This seems to be similar to the description of bug# 2096,
every time java comes up on a site, netscape immeadiately
crashes this happens both with netscape 4.08, and 4.51.
this happens both on a Compaq P2 350 running RH 5.9,
and on a Dell P5 200 running Raw Hide 1.3.4
Comment 1 Bill Nottingham 1999-04-27 15:49:59 EDT
Try running 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi`
and then '/etc/rc.d/init.d/xfs restart`. Does that solve
the problem?Try running 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi`
and then '/etc/rc.d/init.d/xfs restart`. Does that solve
the problem?

------- Email Received From  Todd Byrd <tbyrd@wolffang.stx.com> 04/27/99 15:53 -------
Comment 2 ceaob 1999-04-30 03:58:59 EDT
I have installed a download RH 6.0 (29/4 as workstation and have had
the same problem
- the  fix suggested worked for me
Comment 3 Brian Ryner 1999-05-03 14:20:59 EDT
I also had this problem, and this fix worked.  Are you planning to
issue an updated package soon?
Comment 4 aouana 1999-05-11 05:23:59 EDT
I have installed a RH 6.0 (02/5 on P2 350 and have had the Bus error
problem )
- the  fix  worked for me
should think to update the RH6.0 package early
Comment 5 Jeff Johnson 1999-06-03 12:57:59 EDT
*** Bug 3062 has been marked as a duplicate of this bug. ***

When i try to access some pages that have some Java content,
Netscape (from RH60) crashes, and close all its windows.
Examples: http://www.palmtec.com/ and the Yahoo games
(blackgammon)
This is really annoying!

------- Additional Comments From jturner@redhat.com  05/26/99 11:05 -------


*** Bug 3063 has been marked as a duplicate of this bug. ***

When i try to access some pages that have some Java content,
Netscape (from RH60) crashes, and close all its windows.
Examples: http://www.palmtec.com/ and the Yahoo games
(blackgammon)
This is really annoying!

------- Additional Comments From jbj@redhat.com  06/03/99 12:46 -------


*** Bug 3110 has been marked as a duplicate of this bug. ***

When accessing some web pages with Java content, Netscape
crashes; all it's windows are closed.
An example is http://www.palmtec.com/
Another is Yahoo games (blackgammon)
I've submitted this once again, then appeared as Solved, but
it's not (no upgrade available on any package).
Comment 6 Jeff Johnson 1999-06-03 12:58:59 EDT
*** Bug 3131 has been marked as a duplicate of this bug. ***

Enabling Java on Netscape 4.51 and 4.6 causes netscape to
crash when it encounters an applet with the command line
report of a bus error on an HP Vectra VL8 computer. Attemps
to open the java console on Netscape cause the same problem.
Comment 7 Jeff Johnson 1999-06-03 12:59:59 EDT
*** Bug 3240 has been marked as a duplicate of this bug. ***

Despite the fact that I've seen this bug mentioned four or
so times, I thought I'd relay that I am having this same
problem, as is a buddy of mine here at work.  It seems that
on the machines which we did fresh installs (2) we have this
problem.  On his machine at work, which he updated, he's not
having this problem.  Could it be the JIT compiler? It seems
that if you turn of JIT, netscape doesn't have this problem.

2 more for the netscape bug... Score.
Comment 8 Jeff Johnson 1999-06-03 13:00:59 EDT
*** Bug 3222 has been marked as a duplicate of this bug. ***

Perhaps this is a known issue.

I was running the netscape-common|navigator 4.51 packages,
and upgraded to 4.6, from the updates RPMs (obtained from
metalab.unc.edu/pub/Linux/distributions/redhat/updates).
Any page that starts Java causes the browser to die.  It
gives a "Bus error".  Sounds like the problems we used to
have that necessitated doing LD_PRELOAD stuff, no?
Comment 9 Jeff Johnson 1999-06-16 09:51:59 EDT
*** Bug 3490 has been marked as a duplicate of this bug. ***

Netscape 4.51 and 4.6 (downloaded from errata page) crash
with a bus error when java is started.  I cannot view any
pages with that contain java.
Comment 10 Jason Costomiris 1999-06-16 09:54:59 EDT
'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi'
Then restart xfs
Comment 11 Alan Cox 1999-06-18 10:54:59 EDT
*** Bug 2711 has been marked as a duplicate of this bug. ***

User may find sitations where the correct fonts are not
being displayed, or upon going to a java enabled page with
Netscape, it will immediately crash out.

------- Additional Comments From jturner@redhat.com  05/10/99 13:46 -------
Recommeded workaround is to run "chkfontpath --list" and verify that
all necessary fonts are listed.  If something is missing, run
"chkfontpath --add PATH-TO-FONT" which will add that font and should
take care of the problem.

------- Additional Comments From notting@redhat.com  05/11/99 10:16 -------


*** Bug 2651 has been marked as a duplicate of this bug. ***

A fresh workstation install leaves netscape-communicator
that has a bus error when running Java applets.  This does
not happen with an upgrade from 5.2.  Adding compatability
libraries seems to fix it.  The dependencies for the
netscape-common rpm should be fixed.

------- Additional Comments From notting@redhat.com  05/10/99 10:00 -------
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi', and restart
the font server. This should fix the problem.

------- Additional Comments From notting@redhat.com  05/11/99 10:35 -------


*** Bug 2495 has been marked as a duplicate of this bug. ***

Netscape Crash when i go to a site with java.

If i disable java it works fine.

I  use redhat 6.0

the sites i have tried is :

chat.everyday.se
sydsvenskan.se



------- Additional Comments From notting@redhat.com  05/03/99 11:03 -------
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi',
then restart the font server ('/etc/rc.d/init.d/xfs restart').
Does that solve the problem?

------- Additional Comments From jflythe@skillsoft.com  05/11/99 10:29 -------
I have been having this problem on both of my RH 6.0 systems.
This fixed my problems on both of my systems.

------- Additional Comments From notting@redhat.com  05/11/99 14:02 -------


*** Bug 2740 has been marked as a duplicate of this bug. ***

here are the events:

i'm using netscape enterprise server on other computers and
using my local computer to administer the servers.  when i
try to start an ssl based server on the remote machine,
netscape pops up a window (java based, i think), and lets me
enter the decryption key password.  i type it, click ok and
all is well.

enter redhat 6.0 stock from the cdrom (using enlightenment).
when i click "start ssl-server", netscape prints "loading
java" in the status bar at the bottom, then crashes.  now,
before we write this off as a netscape bug, i decided to run
netscape 451 from another computer (a sparc 3k w/ solaris
251) and export the DISPLAY to my redhat6 linux box.  i do
the same "start ssl-server" steps, and netscape again
crashes.

when i run the same netscape on the console of the sparc, it
works fine.  same if i run netscape 451 on win98.  it just
appears that the window manager, linux, or gnome is barfing
at netscape wanted to display that child window for the
password.

i'm posting this as a gnome bug, but it could be something
in enlightenment or X or who knows what.

------- Additional Comments From notting@redhat.com  05/12/99 11:00 -------


*** Bug 2753 has been marked as a duplicate of this bug. ***

I recently upgraded to RH 6.0 on my Micron Millenia PII box.
Netscape has been suffering many many crashes. Any page with
an embedded JAVA applet causes a crash as well as random
other crashes. Crashes are always a result of a "bus error."

I remember this being a problem with an old libc and memory
allocation with Netscape 2.0 (I just remember patching my
system for that)... I don't know if this is similar or not.
I've tried downgrading my netscape packages as well as
reinstalling, with no luck, so it seems that the problem
might be elsewhere...

-nate
nate@jnf.cx

------- Additional Comments From notting@redhat.com  05/13/99 15:38 -------


*** Bug 2795 has been marked as a duplicate of this bug. ***

When i go to a site with java in it or simply start the java
console, netscape is killed !!

------- Additional Comments From jbj@redhat.com  05/16/99 19:42 -------


*** Bug 2495 has been marked as a duplicate of this bug. ***

Netscape Crash when i go to a site with java.

If i disable java it works fine.

I  use redhat 6.0

the sites i have tried is :

chat.everyday.se
sydsvenskan.se



------- Additional Comments From notting@redhat.com  05/03/99 11:03 -------
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi',
then restart the font server ('/etc/rc.d/init.d/xfs restart').
Does that solve the problem?

------- Additional Comments From jflythe@skillsoft.com  05/11/99 10:29 -------
I have been having this problem on both of my RH 6.0 systems.
This fixed my problems on both of my systems.

------- Additional Comments From notting@redhat.com  05/11/99 10:35 -------


*** This bug has been marked as a duplicate of 2711 ***

------- Additional Comments From notting@redhat.com  05/17/99 17:50 -------


*** Bug 2887 has been marked as a duplicate of this bug. ***

When loading the URL http://java.sun.com netscape crashes.

The last lines of strace are:
--- SIGSEGV (Segmentation fault) ---
getpid()                                = 922
kill(922, SIGBUS)                       = 0
--- SIGBUS (Bus error) ---
+++ killed by SIGBUS +++

And yes, the environment variable CLASSPATH is unset.


------- Additional Comments From bpinaud@ireste.fr  05/17/99 19:08 -------
I have installed Communicator 4.6 (in tar.gz) and set the CLASSPATH,
but now, netscape is not killed but the page is displayed and the
applet is not running like the java console which doesn't work

------- Additional Comments From notting@redhat.com  06/17/99 10:42 -------


*** Bug 3522 has been marked as a duplicate of this bug. ***

Multiple versions of Netscape (4.08, 4.51, 4.6) crash with a
bus error when navigating to a site with Java applets.  As
soon as the status bar reads "Starting Java", the
application dies.

As reported by Kalle Korpijoki <KKJOKI@my-dejanews.com> (and
probably several others) reported, this problem is solved by
adding the entry:

/usr/X11R6/lib/X11/fonts/75dpi

as the last entry of the "catalogue=" field in
/etc/X11/fs/config.  The font server must be restarted by
typing:

/etc/rc.d/init.d/xfs restart

from an xterm running as root.

Thanks to the folks on Deja.com for finding and posting a
(the?) solution.

-Mike Panzitta
mike@doberman.com

------- Additional Comments From alan@redhat.com  06/18/99 10:17 -------
Mike Shaver of netscape has confirmed this is a problem with the sun
jdk code and the font setup. They don't appear to plan to fix i, s the
work around will be needed.
Comment 12 Jeff Johnson 1999-06-19 15:00:59 EDT
*** Bug 3585 has been marked as a duplicate of this bug. ***

On trying to run Java in Netscape (vers. 4.51, 4.6 and 4.61)
Netscape simply crashes with a Bus Error. This never
happened with RedHat 5.2.
Comment 13 Harry Hart 1999-07-23 19:44:59 EDT
I had the problem, too, using RedHat 6.0 (Intel) and Netscape
Communicator 4.61 (US).  However, the recommended 'chkfontpath' fix
seems to have cured the problem.
Comment 14 foo 1999-09-17 00:57:59 EDT
the 'chkfontpath' fix did not solve the problem for me.  In order to
resolve this issue I needed to edit /etc/X11/fs/config by hand and
move the 75dpi font to the end of the list and restart xfs.  This has
resolved the issue on several different machines.

Note You need to log in before you can comment on or make changes to this bug.