Bug 320941 - crashes when adding new openvpn connection
crashes when adding new openvpn connection
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Niemueller
Fedora Extras Quality Assurance
:
: 372721 376491 384091 384331 395931 398001 426203 426768 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 18:20 EDT by Andy Grover
Modified: 2008-01-24 10:50 EST (History)
22 users (show)

See Also:
Fixed In Version: 0.7.0-6.svn3169.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:37:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug Buddy bug report for nm-vpn-properties (334.83 KB, text/plain)
2007-11-05 10:31 EST, Jared Smith
no flags Details
bug buddy crash log (339.13 KB, text/plain)
2007-11-23 10:25 EST, Renato Ramonda
no flags Details
crash on save (330.70 KB, text/plain)
2007-11-23 10:30 EST, Paul Belanger
no flags Details
BugBuddy Report from 2007-12-26 19:37 (353.77 KB, text/plain)
2007-12-26 20:38 EST, David Schnardthorst
no flags Details
nm-applet bug report (666.40 KB, application/octet-stream)
2007-12-27 04:28 EST, ezra di biase
no flags Details

  None (edit)
Description Andy Grover 2007-10-05 18:20:07 EDT
Description of problem:
Creating a new OpenVPN connection, right after openvpn/vpnc dropdown, it crashes.

Version-Release number of selected component (if applicable):
openvpn.i386                             2.1-0.19.rc4.fc7    
NetworkManager.i386                      1:0.7.0-0.3.svn2914.fc
NetworkManager-openvpn.i386              0.3.2-7.fc6

How reproducible:
100%
Comment 1 Tim Niemueller 2007-10-08 05:33:01 EDT
Does create mean create a new connection entry or establishing a connection? And
is dropdown deleting a connection entry or tearing down a connection? Sorry,
"creating" and "dropdown" suggest that you mixed operations and I just want to
make sure...
Comment 2 Andy Grover 2007-10-08 13:11:39 EDT
creating a new connecion entry.

1) Click NetworkManager applet, VPN connections, Configure VPN
2) Click Add
3) Click forward
4) Select "openvpn client" and click forward
5) Bug buddy pops up
Comment 3 Jared Smith 2007-10-16 17:15:30 EDT
I have the same thing, with the following versions:

openvpn-2.1-0.19.rc4.fc7
NetworkManager-0.7.0-0.3.svn2970.fc8
NetworkManager-openvpn-0.3.2-7.fc6

I'm following the same steps as Andy is in comment number 2 above.
Comment 4 Jared Smith 2007-11-05 10:31:01 EST
Created attachment 248341 [details]
Bug Buddy bug report for nm-vpn-properties
Comment 5 Jared Smith 2007-11-05 10:35:46 EST
Now that the package has been rebuilt for F8, I've tried again:

openvpn-2.1-0.19.rc4.fc7
NetworkManager-0.7.0-0.5.svn3030.fc8
NetworkManager-openvpn-0.7.0-2.svn3047.fc8

This time, I do the following:

1) Click NetworkManager applet, VPN connections, Configure VPN
2) Click Add
3) Click forward
4) Select "openvpn client" and click forward
5) Under "Connection Name", I type "test"
6) The second I start typing in the "Gateway Address" box, it crashes.

I've attached the results of Bug Buddy, if they're of any use.
Comment 6 Jared Smith 2007-11-10 22:53:19 EST
I've also tried this on Fedora 8 PPC, and it has the exact same problem.  Also,
I noticed that if you *first* add the gateway address, the program crashes when
you start typing in the "Connection Name" box.  These two text boxes are somehow
linked to the crash.  Nothing else in the dialog seems to matter.
Comment 7 Tim Niemueller 2007-11-11 08:55:31 EST
Confirmed. I'm looking at it.
Comment 8 Tim Niemueller 2007-11-11 17:05:42 EST
*** Bug 376491 has been marked as a duplicate of this bug. ***
Comment 9 Christopher J. Buckley 2007-11-15 06:12:06 EST
*** Bug 384331 has been marked as a duplicate of this bug. ***
Comment 10 Christopher J. Buckley 2007-11-15 06:21:15 EST
*** Bug 384331 has been marked as a duplicate of this bug. ***
Comment 11 Tim Niemueller 2007-11-15 07:09:03 EST
*** Bug 384091 has been marked as a duplicate of this bug. ***
Comment 12 Jon Escombe 2007-11-21 03:59:43 EST
Hi Tim,

The error is inside impl_is_valid() in nm-openvpn.c

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208173712 (LWP 23915)]
0x00200c8e in impl_is_valid (self=0x9839650) at nm-openvpn.c:557
557             if ( (strlen (connectionname) == 0) ||

Appears to be a null pointer for the 'port' item, presumably because the entry
field is no longer in that dialog (there's also a null pointer for routes_entry
lurking)..
Comment 13 Tim Niemueller 2007-11-23 09:00:33 EST
*** Bug 372721 has been marked as a duplicate of this bug. ***
Comment 14 Tim Niemueller 2007-11-23 10:04:51 EST
I have added a patch which fixes that problem. During investigation it became
obvious once more that NM is currently in flux. So please test this version and
report if it is not working (due to other reasons, can't test right now by myself).

You can find the packages at
http://koji.fedoraproject.org/koji/buildinfo?buildID=25302.
Please try and let me know if it works for you.
Comment 15 Renato Ramonda 2007-11-23 10:25:22 EST
Created attachment 267591 [details]
bug buddy crash log

crash when saving conf.
Comment 16 Renato Ramonda 2007-11-23 10:26:13 EST
The crash of the first dialog appears to be fixed. Now it crashes when
confirming the configuration (saving).

(see the above attached file)
Comment 17 Paul Belanger 2007-11-23 10:29:16 EST
(In reply to comment #16)
> The crash of the first dialog appears to be fixed. Now it crashes when
> confirming the configuration (saving).
> 
> (see the above attached file)

I too can confirm this.  See my attached.
Comment 18 Paul Belanger 2007-11-23 10:30:08 EST
Created attachment 267601 [details]
crash on save
Comment 19 Tim Niemueller 2007-11-23 10:56:23 EST
Ok, will check this tonight.
Comment 20 Tim Niemueller 2007-11-25 06:54:19 EST
*** Bug 398001 has been marked as a duplicate of this bug. ***
Comment 21 Daniel Challen 2007-11-28 05:57:43 EST
*** Bug 395931 has been marked as a duplicate of this bug. ***
Comment 22 Casey Harkins 2007-12-03 20:21:39 EST
One of the problems is that the advanced settings dialog is not getting loaded
from the glade XML file (the patched rpms linked to above work around these
crashes, but don't actually solve the problem). However, fixing that still
causes crashes in a couple other places.

Hopefully I'll get it figured out and can get a patch up here soon.
Comment 23 Tim Niemueller 2007-12-03 20:26:16 EST
I'd really appreciate that as my current time constraints do not permit to work
on this as much as I want...
Comment 24 Mogens Kjaer 2007-12-05 04:18:45 EST
I don't know if this is the same bug I see:

This is on a x86_64 system.

If I add a new VPN entry, fill in Connection Name,
Gateway, and group name, press Forward, press Apply,
then nothing happens. The new entry doesn't show up in the
list.

I've done this many times before on F7 i386. The patched version
mentioned in comment #14 makes no difference.
Comment 25 Stanislav Polasek 2007-12-05 15:12:56 EST
I have exactly the same problem as in previous comment. No only it does not save
the connection settings, but if I define the vpn and then go back from the
"Finished Create VPN Connection" window, the entered settings disappear and the
"Create VPN connection 2 of 2" window is empty again. x86_64 arch, too.
Comment 26 Casey Harkins 2007-12-05 15:40:09 EST
Hold tight guys. There are a number of issues in the openvpn plugin, but I'm
very close to getting them all resolved. I've successfully connected to the vpn
with my changes, but the remote address was hard coded and the vpn routes are
not getting set up. I'll submit the changes upstream when I've got these last
few quirks figured out and I suspect they'll push an update after that.
Comment 27 Casey Harkins 2007-12-11 11:48:46 EST
This should be fixed in trunk now with revisions 3140 and 3162. There were a
number of other openvpn issues that have been dealt with as well.
Comment 28 Tim Niemueller 2007-12-12 10:09:12 EST
Great, going to package this tonight.
Comment 29 Tim Niemueller 2007-12-13 10:28:43 EST
I have built new packages incorporating Casey's patches and the patch for the
NULL pointer checks that was originally added as patch to the RPM and is now
upstream.

You can get the RPMs from
http://koji.fedoraproject.org/koji/buildinfo?buildID=27997. Please let me know
how it goes.
Comment 30 Daniel Challen 2007-12-14 04:45:18 EST
with the updated (svn3169) RPM I can now define an OpenVPN connection, and it is
added to the list. Immediately after defining it I can highlight it in the list
and click Edit: the dialog appears but only the connection name field is
populated, all other fields are blank. If I click the Edit button for an OpenVPN
connection any other time after the initial creation, no window appears, and the
window listing connections closes. Trying to initiate one of these OpenVPN
connections triggers a log message:
NetworkManager: nm_vpn_connection_activate: assertion
`nm_vpn_connection_get_state (connection) == NM_VPN_CONNECTION_STATE_PREPARE' failed
NetworkManager: nm-vpn-connection.c.661: NeedSecrets failed: g-exec-error-quark
Could not process the request because the VPN connection settings were invalid.
Comment 31 Carlos Labarca J. 2007-12-14 08:52:40 EST
In x86_64 the error is the same
When I save the connection appears the next error

** (nm-vpn-properties:4282): CRITICAL **: nm_gconf_set_valuehash_helper:
assertion `value != NULL' failed


Comment 32 Steven Pritchard 2007-12-19 09:47:40 EST
*** Bug 426203 has been marked as a duplicate of this bug. ***
Comment 33 Jared Smith 2007-12-19 09:58:10 EST
Casey, Tim...

Thanks for your effort in trying to get this working.  Unfortunately, the fix
doesn't completely fix the problem.  While it no longer crashes while defining a
new VPN connection, it crashes NetworkManager when I try to use a VPN connection
I've defined.

I'm on PPC, for what it's worth.
Comment 34 Casey Harkins 2007-12-19 15:03:10 EST
Jared: 

Can you confirm your package versions for NetworkManager, NetworkManger-gnome
and NetworkManager-openvpn?

Also, can you install the debuginfo versions of the packages and post the debug
log here. I've been running with these patches applied for a number of weeks
without any problems.
Comment 35 Tim Niemueller 2007-12-26 18:34:05 EST
*** Bug 426768 has been marked as a duplicate of this bug. ***
Comment 36 David Schnardthorst 2007-12-26 20:34:41 EST
daves@wavesco.com
Comment 37 David Schnardthorst 2007-12-26 20:38:36 EST
Created attachment 290432 [details]
BugBuddy Report from 2007-12-26 19:37
Comment 38 ezra di biase 2007-12-27 04:28:42 EST
Created attachment 290446 [details]
nm-applet bug report

Same thing here...
Comment 39 Christoph Höger 2008-01-09 04:32:13 EST
Hi,

are any new builds for NM-openvpn approaching?

tim, if you need a helping hand for building I could take a little time to
become a comaintainer or someting.  
Comment 40 Renato Ramonda 2008-01-09 05:31:23 EST
Today I received updated NM (main) packages (version svn3138) from fedora
updates, and together with the (unreleased)  NM-openvpn version svn3169.f8 I
took from koji it seems to work. 

I'll test it this evening, or tomorrow. 

At the moment it seems there are come issues with disconnecting (lots of CPU
cycles, for seconds, and then the connection is down BUT the icon still shows a
red X (and not a locked padlock, go figure).
Comment 41 Michael Cronenworth 2008-01-09 16:47:26 EST
Updated NM to the latest svn3138 then installed the NM-openvpn svn3169 package.

I've successfully tested openvpn using Password Authentication. It finally works!

Good work guys!
Comment 42 Michael Cronenworth 2008-01-09 18:08:50 EST
There's one thing I'd like to add.

VPN is working great. One thing that bothers me is the route table config. Upon
connecting, NM removes my previous default gateway and doesn't set a route for
the VPN subnet. This causes me to lose my regular internet without redoing the
route table. After fixing my route table I have access to both VPN and regular
internet.

My VPN is not set for NAT and is not set to redirect-gateway so as far as I know
its NM doing this. Am I wrong?
Comment 43 Casey Harkins 2008-01-10 14:48:21 EST
Michael:

I'm aware of that problem and am hoping to get it fixed. You can work around
this by going to the advanced openvpn settings, checking the "only use vpn
connection for these addresses" and entering the subnets you want to use the vpn
for. There are a few other openvpn issues I hope to address as well, but it'll
be a few weeks before I'll have time to start addressing them.

As for this particular bug, it sounds like it could be closed out. Any other new
issues should be filed as new bugs.
Comment 45 Fedora Update System 2008-01-11 17:11:25 EST
NetworkManager-openvpn-0.7.0-6.svn3169.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager-openvpn'
Comment 46 Stefan Neufeind 2008-01-13 06:41:28 EST
With svn3169 adding a connection, editing it etc. works fine for me. However
using a non-standard port-number (e.g. 443 instead of 1194) seems to be a
problem. I can enter it in the advanced dialog, it even gets exported correctly
when I export the VPN-entry. However both upon editing the entry and upon
connecting it still uses port 1194.

Is there any workaround to at least get it to connect to the correct port?

When I change the port on the server to 1194 and try to reconnect I get
SIGTERM[hard,init_instance] received, process exiting
Does than mean something crashed during connect?
Comment 47 Syamsul Anuar 2008-01-13 11:00:10 EST
I hv the exact same problem with Stefan Neufind
Comment 48 Casey Harkins 2008-01-13 12:00:08 EST
Thanks Stefan and Syamsul, I'll take a look when I get back from a couple weeks
of traveling. Glancing over the code, it looks like it should be using the port,
but testing shows it clearly isn't.
Comment 49 Tim Niemueller 2008-01-14 04:33:12 EST
Please file a new bug for the port problem.
Comment 50 Tim Niemueller 2008-01-17 19:09:20 EST
If there are no more comments on this I'll mark the update as stable and close
this bug.
Comment 51 Daniel Challen 2008-01-18 05:10:32 EST
The updates appear to fix the problems I had initially, thank you, however I
can't fully test as I'm getting a SELinux denial when OpenVPN tries to access my
X.509 certificate files in /home/dan/vpn_certs/ . I'll open a new bug on that. 
Comment 52 Tim Niemueller 2008-01-18 05:18:53 EST
There is already bug 214556 for this. A good solution has not been implemented,
yet. We probably need the blog transmission via dbus as it is done for the WPA
Enterprise CA.
Comment 53 Fedora Update System 2008-01-22 10:37:11 EST
NetworkManager-openvpn-0.7.0-6.svn3169.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 54 ezra di biase 2008-01-24 10:41:59 EST
I still have problems: could not create VPN (with opevpn).
These are my packages:

NetworkManager-gnome-0.7.0-0.6.7.svn3204.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-0.7.0-0.6.7.svn3204.fc8
NetworkManager-glib-0.7.0-0.6.7.svn3204.fc8
NetworkManager-openvpn-0.7.0-6.svn3169.fc8

Thanks
Ezra
Comment 55 Carlos Labarca J. 2008-01-24 10:50:21 EST
Hi Ezra,

I had the same problem. My solution is uninstalling NetworkManager and openvpn,
and install all again.  It's work for me

Regards
Carlos Labarca

Note You need to log in before you can comment on or make changes to this bug.